aboutsummaryrefslogtreecommitdiff
path: root/games/swell-foop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/swell-foop/Makefile')
-rw-r--r--games/swell-foop/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/games/swell-foop/Makefile b/games/swell-foop/Makefile
index 496873d28918..d84ff0d76c30 100644
--- a/games/swell-foop/Makefile
+++ b/games/swell-foop/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= swell-foop
-PORTVERSION= 3.18.1
+PORTVERSION= 3.24.0
CATEGORIES= games gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -10,19 +10,25 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gnome swell-foop
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= vala:lang/vala \
itstool:textproc/itstool
-LIB_DEPENDS= libclutter-gtk-1.0.so:graphics/clutter-gtk3
+LIB_DEPENDS= libclutter-gtk-1.0.so:graphics/clutter-gtk3 \
+ libclutter-1.0.so:graphics/clutter \
+ libcogl.so:graphics/cogl \
+ libjson-glib-1.0.so:devel/json-glib
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome pathfix pkgconfig tar:xz
-USE_GNOME= gtk30 intlhack libxml2:build
+USES= gettext gmake gnome localbase pathfix \
+ pkgconfig tar:xz
+USE_GNOME= cairo gtk30 intlhack libxml2:build
+USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr
INSTALLS_ICONS= yes
-USE_GL= gl
+USE_GL= egl gl
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.gnome.swell-foop.gschema.xml