aboutsummaryrefslogtreecommitdiff
path: root/games/tanglet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/tanglet/Makefile')
-rw-r--r--games/tanglet/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/games/tanglet/Makefile b/games/tanglet/Makefile
index fe7baa9a01e3..902ca042a438 100644
--- a/games/tanglet/Makefile
+++ b/games/tanglet/Makefile
@@ -14,9 +14,9 @@ COMMENT= Single player word finding game based on Boggle
LICENSE= GPLv3
USE_BZIP2= yes
-USES= desktop-file-utils
-USE_QT4= moc_build qmake_build rcc_build gui iconengines imageformats
-QMAKEFLAGS= QMAKE_LFLAGS="-lz"
+USES= desktop-file-utils qmake
+USE_QT4= moc_build rcc_build gui iconengines_run imageformats_run
+LDFLAGS+= -lz
INSTALLS_ICONS= yes
PORTDOCS= CREDITS ChangeLog NEWS
@@ -28,10 +28,6 @@ post-patch:
@${REINPLACE_CMD} -i '' -e '/PKGCONFIG += zlib/d' \
${WRKSRC}/tanglet.pro
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX}
-
post-install:
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps/