aboutsummaryrefslogtreecommitdiff
path: root/games/tileworld/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/tileworld/Makefile')
-rw-r--r--games/tileworld/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/tileworld/Makefile b/games/tileworld/Makefile
new file mode 100644
index 000000000000..eac587ea5fd9
--- /dev/null
+++ b/games/tileworld/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: tileworld
+# Date created: 08. Oct 02
+# Whom: sec@42.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tileworld
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://www.muppetlabs.com/~breadbox/pub/software/tworld/
+DISTNAME= tworld-${PORTVERSION}
+
+MAINTAINER= sec@42.org
+
+LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+USE_REINPLACE= YES
+ALL_TARGET= tworld
+
+MAN6= tworld.6
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|make|$${MAKE}|g; s|cp -i|cp|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>