aboutsummaryrefslogtreecommitdiff
path: root/games/tinymux/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/tinymux/Makefile')
-rw-r--r--games/tinymux/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/games/tinymux/Makefile b/games/tinymux/Makefile
index c98eac808aab..735aacc18a1e 100644
--- a/games/tinymux/Makefile
+++ b/games/tinymux/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: TinyMUX
+# New ports collection makefile for: TinyMUX
# Date created: 1998/05/28
# Whom: cjohnson
#
@@ -7,14 +7,22 @@
PORTNAME= tinymux
PORTVERSION= 1.6p0
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= ftp://ftp.digex.net/pub/mud/tinymux/
+MASTER_SITES= http://www.moosh.net/pub/mush/servers/tinymux/TinyMUX-1.x/
-BUILD_DEPENDS= ${LOCALBASE}/lib/libgdbm.a:${PORTSDIR}/databases/gdbm
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
WRKSRC= ${WRKDIR}/src
-#GNU_CONFIGURE= YES
-USE_AUTOCONF= YES
+
+USE_AUTOCONF= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-extract:
+ @${RM} -f ${WRKSRC}/gdbm.h
#
# Distribution does not include an install target. So here it is.