aboutsummaryrefslogtreecommitdiff
path: root/games/tomatoes
diff options
context:
space:
mode:
Diffstat (limited to 'games/tomatoes')
-rw-r--r--games/tomatoes/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/tomatoes/Makefile b/games/tomatoes/Makefile
index 9e02b9f9f132..1e6499e3aec7 100644
--- a/games/tomatoes/Makefile
+++ b/games/tomatoes/Makefile
@@ -28,6 +28,12 @@ MAKEFILE= makefile
USE_GMAKE= yes
USE_SDL= mixer image sound
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not build on 4.X
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${DATADIR}/music
@@ -35,4 +41,4 @@ do-install:
${INSTALL_DATA} ${TDATA}/tomatoes.mpk ${DATADIR}
${INSTALL_DATA} ${TDATA}/music/IHaveNoTomatoes.it ${DATADIR}/music
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>