aboutsummaryrefslogtreecommitdiff
path: root/games/trenchbroom/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/trenchbroom/Makefile')
-rw-r--r--games/trenchbroom/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/trenchbroom/Makefile b/games/trenchbroom/Makefile
index 31cad862435a..602ec6f66d48 100644
--- a/games/trenchbroom/Makefile
+++ b/games/trenchbroom/Makefile
@@ -1,6 +1,6 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
-PORTNAME= trenchbroom
+PORTNAME= ${GH_PROJECT:tl}
PORTVERSION= 2.0.0.b
PORTREVISION= 11
CATEGORIES= games cad
@@ -10,7 +10,8 @@ COMMENT= Cross-platform level editor for Quake-engine based games
LICENSE= GPLv3
-LIB_DEPENDS= libfreeimage.so:graphics/freeimage
+LIB_DEPENDS= libfreeimage.so:graphics/freeimage \
+ libfreetype.so:print/freetype2
USE_GITHUB= yes
GH_ACCOUNT= kduske
@@ -27,6 +28,8 @@ PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
post-patch:
+ @${REINPLACE_CMD} -e 's,_MSC_VER,__${OPSYS}__,' \
+ ${WRKSRC}/common/src/SharedPointer.h
@${GREP} -Rl --null std::tr1:: ${WRKSRC}/common/src | ${XARGS} -0 \
${REINPLACE_CMD} -e 's,std::tr1::,std::,g'
@${REINPLACE_CMD} -e 's,Build ,&Type: ,' \