aboutsummaryrefslogtreecommitdiff
path: root/games/tuxracer-commercial/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/tuxracer-commercial/Makefile')
-rw-r--r--games/tuxracer-commercial/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/tuxracer-commercial/Makefile b/games/tuxracer-commercial/Makefile
index 2c712a839745..3f934e46937a 100644
--- a/games/tuxracer-commercial/Makefile
+++ b/games/tuxracer-commercial/Makefile
@@ -16,8 +16,6 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
MAINTAINER= eanholt@gladstone.uoregon.edu
-BROKEN= "Does not build"
-
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
tcl83.1:${PORTSDIR}/lang/tcl83
@@ -25,6 +23,7 @@ USE_MESA= yes
USE_GMAKE= yes
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_AUTOMAKE= yes
+AUTOMAKE_ARGS= -a
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
THREAD_LIB="${PTHREAD_LIB}"
MAKE_ENV= ${CONFIGURE_ENV}
@@ -37,6 +36,9 @@ CONFIGURE_ARGS= --with-tcl-inc="${LOCALBASE}/include/tcl8.3" \
WORKDATA= ${WRKDIR}/${PORTNAME}-data-${PORTVERSION}
COURSEDIRS= 1 2 3 4 5 6 7 8 9 10 11
+post-extract:
+ ${RM} ${WRKSRC}/missing
+
post-install:
${MKDIR} ${DATADIR}
(cd ${WORKDATA} && ${TAR} -c -f - *) | \