aboutsummaryrefslogtreecommitdiff
path: root/games/uhexen2/files/patch-hexenworld__Client__Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/uhexen2/files/patch-hexenworld__Client__Makefile')
-rw-r--r--games/uhexen2/files/patch-hexenworld__Client__Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/games/uhexen2/files/patch-hexenworld__Client__Makefile b/games/uhexen2/files/patch-hexenworld__Client__Makefile
index 7c659fce873a..ebe2b3f1f39c 100644
--- a/games/uhexen2/files/patch-hexenworld__Client__Makefile
+++ b/games/uhexen2/files/patch-hexenworld__Client__Makefile
@@ -1,29 +1,31 @@
---- ./hexenworld/Client/Makefile.orig Fri Oct 6 13:43:35 2006
-+++ ./hexenworld/Client/Makefile Tue Jan 9 16:56:32 2007
-@@ -89,11 +89,11 @@
+--- hexenworld/Client/Makefile.orig Sat Sep 15 09:16:44 2007
++++ hexenworld/Client/Makefile Mon Oct 8 15:51:44 2007
+@@ -113,13 +113,13 @@
USE_SDLAUDIO=yes
USE_MIDI=yes
USE_CDAUDIO=yes
-USE_SDLCD=no
+USE_SDLCD=yes
WITH_SPLASHES=yes
+ LINK_DIRECTX=no
OPT_EXTRA=yes
LINK_GL_LIBS=no
+ USE_3DFXGAMMA=yes
-USE_X86_ASM=yes
+USE_X86_ASM?=no
+ COMPILE_32BITS=no
# build environment sanity checks
- ifeq ($(USE_X86_ASM),yes)
-@@ -125,7 +125,7 @@
- #ARCHFLAGS:=
+@@ -176,7 +176,7 @@
+
+ else
- ifndef DEBUG
-CFLAGS := $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
+CFLAGS := $(CFLAGS) $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
- HAVE_GCC_4_0:=$(shell sh $(UHEXEN2_TOP)/scripts/gcc40check.sh $(CC))
- DISABLE_UNIT_AT_A_TIME ?=$(HAVE_GCC_4_0)
-@@ -141,7 +141,9 @@
+ ifdef NO_UNIT_AT_A_TIME
+ CFLAGS := $(CFLAGS) $(call check_gcc,-fno-unit-at-a-time,)
+@@ -184,7 +184,9 @@
ifeq ($(OPT_EXTRA),yes)
# Note: re-check these flags for non-ia32 machines