aboutsummaryrefslogtreecommitdiff
path: root/games/uhexen2/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/uhexen2/files')
-rw-r--r--games/uhexen2/files/patch-hexen2__Makefile22
-rw-r--r--games/uhexen2/files/patch-hexenworld__Client__Makefile22
-rw-r--r--games/uhexen2/files/patch-hexenworld__Master__Makefile19
-rw-r--r--games/uhexen2/files/patch-hexenworld__Server__Makefile14
-rw-r--r--games/uhexen2/files/patch-launcher__Makefile27
-rw-r--r--games/uhexen2/files/patch-scripts__makefile.inc34
6 files changed, 64 insertions, 74 deletions
diff --git a/games/uhexen2/files/patch-hexen2__Makefile b/games/uhexen2/files/patch-hexen2__Makefile
index 38016eaf9279..54ec06f63a20 100644
--- a/games/uhexen2/files/patch-hexen2__Makefile
+++ b/games/uhexen2/files/patch-hexen2__Makefile
@@ -1,29 +1,31 @@
---- ./hexen2/Makefile.orig Fri Oct 6 13:43:32 2006
-+++ ./hexen2/Makefile Tue Jan 9 16:56:32 2007
-@@ -89,11 +89,11 @@
+--- hexen2/Makefile.orig Sat Sep 15 09:16:44 2007
++++ hexen2/Makefile Mon Oct 8 15:56:50 2007
+@@ -113,13 +113,13 @@
USE_SDLAUDIO=yes
USE_MIDI=yes
USE_CDAUDIO=yes
-USE_SDLCD=no
+USE_SDLCD=yes
WITH_SPLASHES=yes
+ LINK_DIRECTX=no
OPT_EXTRA=yes
LINK_GL_LIBS=no
+ USE_3DFXGAMMA=yes
-USE_X86_ASM=yes
+USE_X86_ASM?=no
+ COMPILE_32BITS=no
# build environment sanity checks
- ifeq ($(USE_X86_ASM),yes)
-@@ -125,7 +125,7 @@
- #ARCHFLAGS:=
+@@ -176,7 +176,7 @@
+
+ else
- ifndef DEBUG
-CFLAGS := $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
+CFLAGS := $(CFLAGS) $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
- HAVE_GCC_4_0:=$(shell sh $(UHEXEN2_TOP)/scripts/gcc40check.sh $(CC))
- DISABLE_UNIT_AT_A_TIME ?=$(HAVE_GCC_4_0)
-@@ -141,7 +141,9 @@
+ ifdef NO_UNIT_AT_A_TIME
+ CFLAGS := $(CFLAGS) $(call check_gcc,-fno-unit-at-a-time,)
+@@ -184,7 +184,9 @@
ifeq ($(OPT_EXTRA),yes)
# Note: re-check these flags for non-ia32 machines
diff --git a/games/uhexen2/files/patch-hexenworld__Client__Makefile b/games/uhexen2/files/patch-hexenworld__Client__Makefile
index 7c659fce873a..ebe2b3f1f39c 100644
--- a/games/uhexen2/files/patch-hexenworld__Client__Makefile
+++ b/games/uhexen2/files/patch-hexenworld__Client__Makefile
@@ -1,29 +1,31 @@
---- ./hexenworld/Client/Makefile.orig Fri Oct 6 13:43:35 2006
-+++ ./hexenworld/Client/Makefile Tue Jan 9 16:56:32 2007
-@@ -89,11 +89,11 @@
+--- hexenworld/Client/Makefile.orig Sat Sep 15 09:16:44 2007
++++ hexenworld/Client/Makefile Mon Oct 8 15:51:44 2007
+@@ -113,13 +113,13 @@
USE_SDLAUDIO=yes
USE_MIDI=yes
USE_CDAUDIO=yes
-USE_SDLCD=no
+USE_SDLCD=yes
WITH_SPLASHES=yes
+ LINK_DIRECTX=no
OPT_EXTRA=yes
LINK_GL_LIBS=no
+ USE_3DFXGAMMA=yes
-USE_X86_ASM=yes
+USE_X86_ASM?=no
+ COMPILE_32BITS=no
# build environment sanity checks
- ifeq ($(USE_X86_ASM),yes)
-@@ -125,7 +125,7 @@
- #ARCHFLAGS:=
+@@ -176,7 +176,7 @@
+
+ else
- ifndef DEBUG
-CFLAGS := $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
+CFLAGS := $(CFLAGS) $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
- HAVE_GCC_4_0:=$(shell sh $(UHEXEN2_TOP)/scripts/gcc40check.sh $(CC))
- DISABLE_UNIT_AT_A_TIME ?=$(HAVE_GCC_4_0)
-@@ -141,7 +141,9 @@
+ ifdef NO_UNIT_AT_A_TIME
+ CFLAGS := $(CFLAGS) $(call check_gcc,-fno-unit-at-a-time,)
+@@ -184,7 +184,9 @@
ifeq ($(OPT_EXTRA),yes)
# Note: re-check these flags for non-ia32 machines
diff --git a/games/uhexen2/files/patch-hexenworld__Master__Makefile b/games/uhexen2/files/patch-hexenworld__Master__Makefile
index 2af19494ebcf..a2cb98bcd1d0 100644
--- a/games/uhexen2/files/patch-hexenworld__Master__Makefile
+++ b/games/uhexen2/files/patch-hexenworld__Master__Makefile
@@ -1,18 +1,11 @@
---- ./hexenworld/Master/Makefile.orig Fri Oct 6 13:43:35 2006
-+++ ./hexenworld/Master/Makefile Tue Jan 9 16:56:32 2007
-@@ -24,14 +24,11 @@
- # Compiler flags
+--- hexenworld/Master/Makefile.orig Thu Jul 12 14:41:20 2007
++++ hexenworld/Master/Makefile Mon Oct 8 15:58:40 2007
+@@ -41,7 +41,7 @@
- # Overrides for the default CPUFLAGS
--ifeq ($(MACH_TYPE),x86)
--CPUFLAGS:=-march=i386
--endif
- # Overrides for the default ARCHFLAGS
- #ARCHFLAGS:=
+ else
- ifndef DEBUG
-CFLAGS := $(CPUFLAGS) -O2 -Wall
+CFLAGS := $(CFLAGS) $(CPUFLAGS) -O2 -Wall
- endif
- # Other build flags
+ ifdef NO_UNIT_AT_A_TIME
+ CFLAGS := $(CFLAGS) $(call check_gcc,-fno-unit-at-a-time,)
diff --git a/games/uhexen2/files/patch-hexenworld__Server__Makefile b/games/uhexen2/files/patch-hexenworld__Server__Makefile
index 3e5c8b8065e6..49bff0f655a9 100644
--- a/games/uhexen2/files/patch-hexenworld__Server__Makefile
+++ b/games/uhexen2/files/patch-hexenworld__Server__Makefile
@@ -1,11 +1,11 @@
---- ./hexenworld/Server/Makefile.orig Fri Oct 6 13:43:35 2006
-+++ ./hexenworld/Server/Makefile Tue Jan 9 16:56:32 2007
-@@ -30,7 +30,7 @@
- #ARCHFLAGS:=
+--- hexenworld/Server/Makefile.orig Thu Jul 12 14:41:20 2007
++++ hexenworld/Server/Makefile Mon Oct 8 16:01:34 2007
+@@ -64,7 +64,7 @@
+
+ else
- ifndef DEBUG
-CFLAGS := $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
+CFLAGS := $(CFLAGS) $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
- HAVE_GCC_4_0:=$(shell sh $(UHEXEN2_TOP)/scripts/gcc40check.sh $(CC))
- DISABLE_UNIT_AT_A_TIME ?=$(HAVE_GCC_4_0)
+ ifdef NO_UNIT_AT_A_TIME
+ CFLAGS := $(CFLAGS) $(call check_gcc,-fno-unit-at-a-time,)
diff --git a/games/uhexen2/files/patch-launcher__Makefile b/games/uhexen2/files/patch-launcher__Makefile
index 7adb678d731e..e14a1e3927b1 100644
--- a/games/uhexen2/files/patch-launcher__Makefile
+++ b/games/uhexen2/files/patch-launcher__Makefile
@@ -1,6 +1,6 @@
---- ./launcher/Makefile.orig Fri Oct 6 13:43:36 2006
-+++ ./launcher/Makefile Tue Jan 9 16:56:32 2007
-@@ -11,27 +11,11 @@
+--- launcher/Makefile.orig Mon Aug 13 10:01:46 2007
++++ launcher/Makefile Sun Oct 21 14:38:45 2007
+@@ -19,19 +19,7 @@
HOST_OS:=$(shell uname)
@@ -17,15 +17,28 @@
-ifeq ($(CC_OVERRIDE),)
-CC := $(CC_DEFAULT)
-endif
-+CC ?= gcc
++CC_DEFAULT:=cc
LINKER:= $(CC)
+@@ -39,11 +27,7 @@
+ XDELTA_FLAGS:=
+ XDELTA_LINK:= -L$(XDELTA_DIR)/.libs -lxdelta -L$(XDELTA_DIR)/libedsio/.libs -ledsio
+
-ifdef DEMO
--TMPNAME:= h2demo
+-H2LAUNCH:= h2demo
-else
- TMPNAME:= h2launcher
+ H2LAUNCH:= h2launcher
-endif
ifdef GTK1
- H2LAUNCH:= $(TMPNAME).gtk1
+ GTK_CFLAGS:= $(shell gtk-config --cflags)
+@@ -124,7 +108,7 @@
+ ALL_OBJECTS := $(LAUNCHER_OBJS) $(GUI_OBJS) $(XPATCH_OBJS) \
+ $(LIBXDELTA_OBJS) $(LIBEDSIO_OBJS) $(LAUNCHER_MAIN)
+
+-$(H2LAUNCH): $(LAUNCHER_OBJS) $(LAUNCHER_MAIN) $(GUI_OBJS) $(XPATCH_OBJS)
++$(H2LAUNCH): $(ALL_OBJECTS)
+ @rm -f $(H2LAUNCH)
+ $(LINKER) -o $(H2LAUNCH) $(ALL_OBJECTS) $(LDFLAGS)
+
diff --git a/games/uhexen2/files/patch-scripts__makefile.inc b/games/uhexen2/files/patch-scripts__makefile.inc
index edd33da68e99..b89449a8a24c 100644
--- a/games/uhexen2/files/patch-scripts__makefile.inc
+++ b/games/uhexen2/files/patch-scripts__makefile.inc
@@ -1,16 +1,15 @@
---- ./scripts/makefile.inc.orig Fri Oct 6 13:43:36 2006
-+++ ./scripts/makefile.inc Tue Jan 9 16:56:32 2007
-@@ -15,7 +15,8 @@
+--- scripts/makefile.inc.orig Thu Jul 12 14:41:20 2007
++++ scripts/makefile.inc Mon Oct 8 16:11:27 2007
+@@ -17,7 +17,7 @@
# Common paths:
# X directory
--X11_PATH ?=/usr/X11R6
-+X11BASE ?= /usr/X11R6
-+X11_PATH ?= $(X11BASE)
+-X11BASE ?=/usr/X11R6
++X11BASE ?=/usr/local
# MinGW32 directory:
MINGWDIR ?=/mingw
-@@ -61,22 +62,7 @@
+@@ -73,22 +73,7 @@
endif
# Compiler selection:
@@ -30,26 +29,7 @@
-ifeq ($(CC_OVERRIDE),)
-CC := $(CC_DEFAULT)
-endif
-+CC ?= gcc
++CC ?= cc
NASM ?= $(NASM_BIN)
WINDRES ?= windres
-@@ -104,9 +90,6 @@
-
- # default CPU flags
- CPUFLAGS:=
--ifeq ($(MACH_TYPE),x86)
--CPUFLAGS:=-march=i586
--endif
-
- # NASM flags:
- # These are required for IA32 assembly for hexen2/hexenworld clients
-@@ -121,7 +104,7 @@
- # be added to the make command
- DFLAGS := -g -Wall
- ifdef DEBUG
--CFLAGS := $(DFLAGS)
-+CFLAGS := $(CFLAGS) $(DFLAGS)
- endif
-
- # the "sdl-config" command