aboutsummaryrefslogtreecommitdiff
path: root/games/untahris
diff options
context:
space:
mode:
Diffstat (limited to 'games/untahris')
-rw-r--r--games/untahris/Makefile33
-rw-r--r--games/untahris/distinfo6
-rw-r--r--games/untahris/files/patch-intface.cpp19
-rw-r--r--games/untahris/pkg-message5
-rw-r--r--games/untahris/pkg-plist12
5 files changed, 48 insertions, 27 deletions
diff --git a/games/untahris/Makefile b/games/untahris/Makefile
index 8e5b769304cb..a6210434a0f2 100644
--- a/games/untahris/Makefile
+++ b/games/untahris/Makefile
@@ -6,44 +6,39 @@
#
PORTNAME= untahris
-DISTVERSION= 1.0beta
-PORTREVISION= 1
+PORTVERSION= 2.0
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= Play several classic fun, simple arcade games in multiplayer mode
-USE_SDL= sdl net ttf
-USE_GCC= 3.4+
+USE_SDL= sdl net ttf mixer
WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_FILES= bin/untahris %%DATADIR%%/VeraBd.ttf %%DATADIR%%/graph16.unt
-PLIST_DIRS= %%DATADIR%%
-
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not compile on 4.x
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's|verabd.ttf|${DATADIR}/VeraBd.ttf|; \
- s|graph%d|${DATADIR}/graph%d|' ${WRKSRC}/intface.cpp
+ @${REINPLACE_CMD} -e 's|VeraBd.ttf|${DATADIR}/VeraBd.ttf|; \
+ s|graph%d|${DATADIR}/&|; s|[a-z]*\.wav|${DATADIR}/&|' \
+ ${WRKSRC}/intface.cpp
@${REINPLACE_CMD} -e 's|TPlayground::||' ${WRKSRC}/untahris.h
do-build:
cd ${WRKSRC} && ${CXX} ${CXXFLAGS} `${SDL_CONFIG} --libs --cflags` \
- -lSDL_net -lSDL_ttf untahris.cpp -o untahris
+ -lSDL_net -lSDL_ttf -lSDL_mixer untahris.cpp -o untahris
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/untahris ${PREFIX}/bin
${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/VeraBd.ttf ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/graph16.unt ${DATADIR}
+.for f in VeraBd.ttf graph16.unt *.wav
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.post.mk>
diff --git a/games/untahris/distinfo b/games/untahris/distinfo
index 0f1ad1087988..44a52d1795e2 100644
--- a/games/untahris/distinfo
+++ b/games/untahris/distinfo
@@ -1,3 +1,3 @@
-MD5 (untahris-1.0beta-src.tgz) = 567f6b203dc8b7efb26ec7f9eae08fe0
-SHA256 (untahris-1.0beta-src.tgz) = 9c1067c9edb64fce5e23c11de34fe20ed6591e3048388fec89e921f9e350d0a5
-SIZE (untahris-1.0beta-src.tgz) = 70050
+MD5 (untahris-2.0-src.tgz) = 85af8afdbff12f347ec60f2d50fb899c
+SHA256 (untahris-2.0-src.tgz) = a1fbe980d2a4842c492bb23878ccaf2e6aa4fa9e46fde209306990942d89b17f
+SIZE (untahris-2.0-src.tgz) = 1102921
diff --git a/games/untahris/files/patch-intface.cpp b/games/untahris/files/patch-intface.cpp
index e6dab8a29897..3b01833106c4 100644
--- a/games/untahris/files/patch-intface.cpp
+++ b/games/untahris/files/patch-intface.cpp
@@ -1,9 +1,18 @@
---- intface.cpp.orig Mon Sep 4 19:16:15 2006
-+++ intface.cpp Fri Sep 8 06:57:45 2006
-@@ -517,7 +517,7 @@
- thruster.pixel[y][x] = 'P';
+--- intface.cpp.orig Wed May 2 02:41:32 2007
++++ intface.cpp Thu Aug 9 03:04:09 2007
+@@ -45,7 +45,7 @@
+ SDL_Quit();
}
-
+
+- if (Mix_OpenAudio(44100, MIX_DEFAULT_FORMAT, 2, 8000) != 0)
++ if (Mix_OpenAudio(44100, MIX_DEFAULT_FORMAT, 2, 8192) != 0)
+ printf("Failed to initialize audio.\n");
+ else {
+ Mix_AllocateChannels(16);
+@@ -653,7 +653,7 @@
+ Ic(icBazooka).fillWith("0", d.Res);
+ Ic(icBazooka).gradFill(d.Res*4/8-1, 0, d.Res*4/8, d.Res*3/4, 0x80FFFFFF, 0xFFFFFFFF);
+
- char buf[64];
+ char buf[1024];
sprintf(buf, "graph%d.unt", d.Res);
diff --git a/games/untahris/pkg-message b/games/untahris/pkg-message
new file mode 100644
index 000000000000..3c7388da4b05
--- /dev/null
+++ b/games/untahris/pkg-message
@@ -0,0 +1,5 @@
+ATTENTION!
+
+If, after being updated to version > 1.0, the game hangs after
+pressing <ENTER> in the main menu, please delete ~/.untahris.config
+file and restart the game.
diff --git a/games/untahris/pkg-plist b/games/untahris/pkg-plist
new file mode 100644
index 000000000000..69f761701113
--- /dev/null
+++ b/games/untahris/pkg-plist
@@ -0,0 +1,12 @@
+bin/untahris
+%%DATADIR%%/VeraBd.ttf
+%%DATADIR%%/birth.wav
+%%DATADIR%%/blue.wav
+%%DATADIR%%/death.wav
+%%DATADIR%%/graph16.unt
+%%DATADIR%%/green.wav
+%%DATADIR%%/hit.wav
+%%DATADIR%%/place.wav
+%%DATADIR%%/red.wav
+%%DATADIR%%/shoot.wav
+@dirrm %%DATADIR%%