aboutsummaryrefslogtreecommitdiff
path: root/games/urbanterror-data/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/urbanterror-data/Makefile')
-rw-r--r--games/urbanterror-data/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/games/urbanterror-data/Makefile b/games/urbanterror-data/Makefile
new file mode 100644
index 000000000000..c8859d0d63b1
--- /dev/null
+++ b/games/urbanterror-data/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: urbanterror-data
+# Date created: 2007-09-10
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= urbanterror
+PORTVERSION= 4.0
+CATEGORIES= games
+MASTER_SITES= http://mirrormaid.yi.org/ \
+ http://mrsentry.net/release/ \
+ http://outlands.quaddown.org/files/ \
+ ftp://ftp.snt.utwente.nl/pub/games/urbanterror/ \
+ ftp://ftp.vectranet.pl/pub/gry/UrbanTerror/
+PKGNAMESUFFIX= -data
+DISTNAME= UrbanTerror${PORTVERSION:S/.//}_full
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Standalone realism based mod originally for Quake III Arena
+
+USE_ZIP= yes
+NO_BUILD= yes
+NO_PACKAGE= Package will be 560MB; set FORCE_PACKAGE if you really want it
+WRKSRC= ${WRKDIR}/q3ut4
+
+DATADIR= ${Q3DIR}/q3ut4
+
+post-extract:
+ @cd ${WRKSRC} && ${MV} readme40.txt ..
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CP} -r ${WRKSRC}/* ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/readme40.txt ${DOCSDIR}
+.endif
+
+.include "${.CURDIR}/../quake3-data/Makefile.include"
+.include <bsd.port.mk>