aboutsummaryrefslogtreecommitdiff
path: root/games/violetland/files/patch-boost-1.52
diff options
context:
space:
mode:
Diffstat (limited to 'games/violetland/files/patch-boost-1.52')
-rw-r--r--games/violetland/files/patch-boost-1.5241
1 files changed, 41 insertions, 0 deletions
diff --git a/games/violetland/files/patch-boost-1.52 b/games/violetland/files/patch-boost-1.52
new file mode 100644
index 000000000000..c90329f43b04
--- /dev/null
+++ b/games/violetland/files/patch-boost-1.52
@@ -0,0 +1,41 @@
+--- CMakeLists.txt.old 2012-11-05 15:19:11.501044743 +0100
++++ CMakeLists.txt 2012-11-05 15:19:25.415250207 +0100
+@@ -8,7 +8,6 @@
+ find_package(SDL_mixer REQUIRED)
+ find_package(OpenGL REQUIRED)
+ find_package(Boost COMPONENTS filesystem system REQUIRED)
+-add_definitions(-DBOOST_FILESYSTEM_VERSION=2)
+
+ if(${MINGW})
+ set(INTL_LIBRARY intl)
+--- src/system/utility/FileUtility.cpp.old 2012-11-05 21:26:07.865488297 +0100
++++ src/system/utility/FileUtility.cpp 2012-11-05 21:30:44.881208230 +0100
+@@ -20,7 +20,7 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_regular_file(*dir_it))
+- files.push_back(dir_it->filename());
++ files.push_back(dir_it->path().filename().string());
+ ++dir_it;
+ }
+ return files;
+@@ -32,8 +32,8 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_directory(*dir_it))
+- if (dir_it->path().filename()[0] != '.')
+- subDirs.push_back(dir_it->path().filename());
++ if (dir_it->path().filename().string()[0] != '.')
++ subDirs.push_back(dir_it->path().filename().string());
+ ++dir_it;
+ }
+ return subDirs;
+@@ -45,7 +45,7 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_directory(*dir_it))
+- if (dir_it->path().filename()[0] != '.')
++ if (dir_it->path().filename().string()[0] != '.')
+ ++count;
+ ++dir_it;
+ }