aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth
diff options
context:
space:
mode:
Diffstat (limited to 'games/wesnoth')
-rw-r--r--games/wesnoth/Makefile7
-rw-r--r--games/wesnoth/files/patch-src-tools-exploder_utils.cpp10
2 files changed, 14 insertions, 3 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index bde61325e1e3..daab00e17998 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wesnoth
PORTVERSION= 1.8.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTNAME}-${PORTVERSION} \
http://files.wesnoth.org/
@@ -15,12 +15,13 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTNAME}-${PORTVERS
MAINTAINER= philip@FreeBSD.org
COMMENT= A fantasy turn-based strategy game
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs
-
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
+ png15:${PORTSDIR}/graphics/png
+
CONFLICTS= wesnoth-devel-[0-9]*
USE_SDL= image mixer net ttf
diff --git a/games/wesnoth/files/patch-src-tools-exploder_utils.cpp b/games/wesnoth/files/patch-src-tools-exploder_utils.cpp
new file mode 100644
index 000000000000..82e3f5397be3
--- /dev/null
+++ b/games/wesnoth/files/patch-src-tools-exploder_utils.cpp
@@ -0,0 +1,10 @@
+--- src/tools/exploder_utils.cpp.orig 2012-05-09 12:03:45.000000000 +0200
++++ src/tools/exploder_utils.cpp 2012-05-09 12:04:21.000000000 +0200
+@@ -16,6 +16,7 @@
+ #include "game_config.hpp"
+ #include "serialization/string_utils.hpp"
+ #include <png.h>
++#include <zlib.h>
+
+ exploder_point::exploder_point(const std::string &s)
+ : x(0)