aboutsummaryrefslogtreecommitdiff
path: root/games/xgalaga/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xgalaga/Makefile')
-rw-r--r--games/xgalaga/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/games/xgalaga/Makefile b/games/xgalaga/Makefile
index 87988a5b07de..3b3de7fdbfb8 100644
--- a/games/xgalaga/Makefile
+++ b/games/xgalaga/Makefile
@@ -1,36 +1,33 @@
-# Created by: asami
+# Created by: Satoshi Asami <asami@FreeBSD.org>
# $FreeBSD$
PORTNAME= xgalaga
PORTVERSION= 2.1.1.0
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
+MASTER_SITES= SF/${PORTNAME}
MAINTAINER= turutani@scphys.kyoto-u.ac.jp
-COMMENT= Galaga resurrected on X
+COMMENT= Clone of the classic game Galaga for X11
+
+LICENSE= GPLv2
USES= gmake
-MAKE_JOBS_UNSAFE= yes
USE_XORG= xpm xmu
HAS_CONFIGURE= yes
-MAN6= xgalaga.6x
-MANCOMPRESSED= yes
+
# xgalaga has a very strange usage of these variables...
CONFIGURE_ARGS= --prefix=${LOCALBASE}/lib/X11/xgalaga \
--mandir=${LOCALBASE}/man \
--exec_prefix=${LOCALBASE}/bin
+MAN6= xgalaga.6x
+MANCOMPRESSED= yes
+
OPTIONS_DEFINE= SOUND
OPTIONS_DEFAULT= SOUND
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MSOUND)
-CONFIGURE_ARGS+= --without-sound
-PLIST_SUB= SOUND="@comment "
-.else
-PLIST_SUB= SOUND=""
-.endif
+SOUND_CONFIGURE_OFF= --without-sound
post-install:
@${STRIP_CMD} ${PREFIX}/bin/xgalaga