aboutsummaryrefslogtreecommitdiff
path: root/games/xhexagons/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xhexagons/Makefile')
-rw-r--r--games/xhexagons/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/xhexagons/Makefile b/games/xhexagons/Makefile
new file mode 100644
index 000000000000..27e565f3af2b
--- /dev/null
+++ b/games/xhexagons/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xhexagons
+# Version required: 5.4.4
+# Date created: 20 May 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= xhexagons-5.4.4
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITE_SUBDIR= games/xpuzzles
+
+MAINTAINER= andy@icc.surw.chel.su
+
+WRKSRC= ${WRKDIR}/xhexagons
+USE_IMAKE= yes
+MAN1= xhexagons.1
+MANCOMPRESSED= no
+
+# Not configured to use Motif.
+# Optionally edit ${WRKSRC}/Imakefile before build.
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/xhexagons ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/Hexagons.ad ${PREFIX}/lib/X11/app-defaults/Hexagons
+ @${INSTALL_MAN} ${WRKSRC}/xhexagons.man ${PREFIX}/man/man1/xhexagons.1
+
+.include <bsd.port.mk>