aboutsummaryrefslogtreecommitdiff
path: root/games/xkoules/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xkoules/Makefile')
-rw-r--r--games/xkoules/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/games/xkoules/Makefile b/games/xkoules/Makefile
index c6c28bbe8e84..5d8538d971e0 100644
--- a/games/xkoules/Makefile
+++ b/games/xkoules/Makefile
@@ -15,22 +15,19 @@ EXTRACT_SUFX= -src.tar.gz
MAINTAINER= ports@FreeBSD.org
-.if ${MACHINE_ARCH} == "alpha"
-PLIST= ${PKGDIR}/pkg-plist.alpha
+.if ${MACHINE_ARCH} == "i386"
+PLIST_SUB= SNDSRV:=""
+.else
+PLIST_SUB= SNDSRV:="@comment "
.endif
USE_IMAKE= yes
MAN6= xkoules.6
-MANCOMPRESSED= no
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xkoules ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/share/xkoules
-.if ${MACHINE_ARCH} == "i386"
- ${INSTALL_PROGRAM} ${WRKSRC}/koules.sndsrv.freebsd ${PREFIX}/share/xkoules
-.endif
- ${INSTALL_DATA} ${WRKSRC}/sounds/*.raw ${PREFIX}/share/xkoules
- ${INSTALL_MAN} ${WRKSRC}/xkoules.6 ${PREFIX}/man/man6
+post-extract:
+ @${CP} ${WRKSRC}/xkoules.6 ${WRKSRC}/xkoules.man
+
+post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/xkoules
.for file in ANNOUNCE BUGS Card ChangeLog Koules.FAQ TODO