aboutsummaryrefslogtreecommitdiff
path: root/games/xmastermind
diff options
context:
space:
mode:
Diffstat (limited to 'games/xmastermind')
-rw-r--r--games/xmastermind/Makefile4
-rw-r--r--games/xmastermind/files/patch-aa8
2 files changed, 6 insertions, 6 deletions
diff --git a/games/xmastermind/Makefile b/games/xmastermind/Makefile
index 60c8be6c9a53..279eb04b6048 100644
--- a/games/xmastermind/Makefile
+++ b/games/xmastermind/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmastermind
PORTVERSION= 0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/strategy
@@ -17,7 +17,7 @@ COMMENT= Mastermind game for X Window System
LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
-USE_X_PREFIX= yes
+USE_XORG= x11 xpm
pre-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
diff --git a/games/xmastermind/files/patch-aa b/games/xmastermind/files/patch-aa
index ee322a413bff..afb6f3547394 100644
--- a/games/xmastermind/files/patch-aa
+++ b/games/xmastermind/files/patch-aa
@@ -5,14 +5,14 @@
CC = gcc
-CFLAGS = -O2 -Wall -Wpointer-arith -Wstrict-prototypes -pedantic -ansi
-+.if exists(${X11BASE}/include/X11/forms.h)
-+XFORMSINC=-I${X11BASE}/include/X11
++.if exists(${LOCALBASE}/include/X11/forms.h)
++XFORMSINC=-I${LOCALBASE}/include/X11
+.endif
-+CFLAGS+= -Wall -Wpointer-arith -Wstrict-prototypes -pedantic -ansi -I${X11BASE}/include ${XFORMSINC}
++CFLAGS+= -Wall -Wpointer-arith -Wstrict-prototypes -pedantic -ansi -I${LOCALBASE}/include ${XFORMSINC}
CLIBS = -lm
#GRAPHLIBS = -lforms -L/usr/X11R6/lib/ -lX11 -static
-GRAPHLIBS = -lforms -L/usr/X11R6/lib/ -lX11
-+GRAPHLIBS = -lforms -L${X11BASE}/lib -lX11 -lXpm
++GRAPHLIBS = -lforms -L${LOCALBASE}/lib -lX11 -lXpm
MF = Makefile
ALLLIBS = $(GRAPHLIBS) $(CLIBS)