aboutsummaryrefslogtreecommitdiff
path: root/games/xroach/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/xroach/files')
-rw-r--r--games/xroach/files/patch-Makefile24
-rw-r--r--games/xroach/files/patch-xroach.c58
2 files changed, 0 insertions, 82 deletions
diff --git a/games/xroach/files/patch-Makefile b/games/xroach/files/patch-Makefile
deleted file mode 100644
index a5c1aea51fff..000000000000
--- a/games/xroach/files/patch-Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
---- Makefile.orig Tue Jun 8 19:12:04 1993
-+++ Makefile Sun Sep 8 03:45:39 2002
-@@ -1,9 +1,16 @@
--# @(#)Makefile 8.1 (Berkeley) 6/8/93
-+# @(#)Makefile 8.1 (Berkeley) 5/31/93
-
- PROG= xroach
--MAN6= xroach.0
--CFLAGS+= -I${.CURDIR}/bitmaps
--DPADD= ${LIBX} ${LIBM}
--LDADD= -lX11/X11 -lm
-+MAN6= xroach.6
-+
-+DPADD+= ${LOCALBASE}/lib/libX11.a ${LIBM}
-+CFLAGS+= -I${LOCALBASE}/include -I${.CURDIR}/bitmaps
-+LDADD+= -L${LOCALBASE}/lib -lX11 -lm
-+
-+MANDIR= ${LOCALBASE}/man/man
-+
-+BINOWN= bin
-+BINDIR= ${LOCALBASE}/bin
-+BINMODE= 755
-
- .include <bsd.prog.mk>
diff --git a/games/xroach/files/patch-xroach.c b/games/xroach/files/patch-xroach.c
deleted file mode 100644
index ea392fd27ae5..000000000000
--- a/games/xroach/files/patch-xroach.c
+++ /dev/null
@@ -1,58 +0,0 @@
---- xroach.c.orig 1993-06-04 21:47:09.000000000 +0200
-+++ xroach.c 2011-12-20 19:03:53.816175581 +0100
-@@ -77,7 +77,7 @@
- int MarkHiddenRoaches();
- Pixel AllocNamedColor();
-
--void
-+int
- main(ac, av)
- int ac;
- char *av[];
-@@ -96,19 +96,23 @@
- /*
- Process command line options.
- */
-- for (ax=1; ax<ac; ax++) {
-- arg = av[ax];
-+ for (ax=1; ax<ac; ) {
-+ arg = av[ax++];
-+
-+ if (ax >= ac)
-+ Usage();
-+
- if (strcmp(arg, "-display") == 0) {
-- display_name = av[++ax];
-+ display_name = av[ax++];
- }
- else if (strcmp(arg, "-rc") == 0) {
-- roachColor = av[++ax];
-+ roachColor = av[ax++];
- }
- else if (strcmp(arg, "-speed") == 0) {
-- roachSpeed = atof(av[++ax]);
-+ roachSpeed = atof(av[ax++]);
- }
- else if (strcmp(arg, "-roaches") == 0) {
-- maxRoaches = strtol(av[++ax], (char **)NULL, 0);
-+ maxRoaches = strtol(av[ax++], (char **)NULL, 0);
- }
- else {
- Usage();
-@@ -212,6 +216,7 @@
- CoverRoot();
-
- XCloseDisplay(display);
-+ return(0);
- }
-
- #define USEPRT(msg) fprintf(stderr, msg)
-@@ -465,7 +470,7 @@
- Region covered;
- Region visible;
- Window *children;
-- int nChildren;
-+ unsigned int nChildren;
- Window dummy;
- XWindowAttributes wa;
- int wx;