aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/stockfish/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
index 2531279c02c9..d325180e7c1f 100644
--- a/games/stockfish/Makefile
+++ b/games/stockfish/Makefile
@@ -25,8 +25,9 @@ ALL_TARGET= build ARCH=${MYARCH}
# workaround the ARCH usage in the stockfish Makefile
.if ${MYARCH} == "i386"
-MYARCH= x86-32
-ALL_TARGET= build ARCH=${MYARCH}
+ALL_TARGET= build ARCH=x86-32
+.elif ${MYARCH} == "amd64"
+ALL_TARGET= build ARCH=x86-64
.endif
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"