aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/asc/Makefile2
-rw-r--r--games/atomix/Makefile2
-rw-r--r--games/baduki/Makefile2
-rw-r--r--games/bombermaze/Makefile2
-rw-r--r--games/clanbomber/Makefile2
-rw-r--r--games/freeciv-gtk2/Makefile2
-rw-r--r--games/freeciv/Makefile2
-rw-r--r--games/gcompris/Makefile2
-rw-r--r--games/gcompris2/Makefile2
-rw-r--r--games/glife/Makefile2
-rw-r--r--games/gniffel/Makefile2
-rw-r--r--games/gno3dtet/Makefile2
-rw-r--r--games/gnocatan/Makefile2
-rw-r--r--games/gnome-games/Makefile2
-rw-r--r--games/gnomebreakout/Makefile2
-rw-r--r--games/gnomegames/Makefile2
-rw-r--r--games/gnomegames2/Makefile2
-rw-r--r--games/gnomememoryblocks/Makefile2
-rw-r--r--games/gtktetcolor/Makefile2
-rw-r--r--games/heroes/Makefile2
-rw-r--r--games/lbreakout/Makefile2
-rw-r--r--games/ltris/Makefile2
-rw-r--r--games/pioneers/Makefile2
-rw-r--r--games/pythoong/Makefile2
-rw-r--r--games/teg/Makefile2
25 files changed, 25 insertions, 25 deletions
diff --git a/games/asc/Makefile b/games/asc/Makefile
index ee7cad21895d..8953ba38fd05 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -35,7 +35,7 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
DATAFILE= main.con
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@find ${WRKSRC} \( -name "*.cpp" -or -name "*.h" \) | xargs \
${PERL} -pi -e 's|malloc\.h|stdlib.h|g'
diff --git a/games/atomix/Makefile b/games/atomix/Makefile
index 18d3abb7651b..3abba5fa2085 100644
--- a/games/atomix/Makefile
+++ b/games/atomix/Makefile
@@ -19,7 +19,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/baduki/Makefile b/games/baduki/Makefile
index 3f0dcbfab2c2..19b4faea9402 100644
--- a/games/baduki/Makefile
+++ b/games/baduki/Makefile
@@ -20,7 +20,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/games/bombermaze/Makefile b/games/bombermaze/Makefile
index ae0a5b46b11a..853e40a9f4ad 100644
--- a/games/bombermaze/Makefile
+++ b/games/bombermaze/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS+= -fpermissive
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/clanbomber/Makefile b/games/clanbomber/Makefile
index 3380b73e4212..7089a21f8d30 100644
--- a/games/clanbomber/Makefile
+++ b/games/clanbomber/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= clanCore.0:${PORTSDIR}/devel/clanlib
USE_XLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-pthread -L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include"
CFLAGS+= -fpermissive
diff --git a/games/freeciv-gtk2/Makefile b/games/freeciv-gtk2/Makefile
index 956e6c8504fd..0ce17a95b1fa 100644
--- a/games/freeciv-gtk2/Makefile
+++ b/games/freeciv-gtk2/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --disable-gtktest
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/games/freeciv/Makefile b/games/freeciv/Makefile
index 956e6c8504fd..0ce17a95b1fa 100644
--- a/games/freeciv/Makefile
+++ b/games/freeciv/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --disable-gtktest
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
index 8c4c8e4ef96e..7925c5f06bd7 100644
--- a/games/gcompris/Makefile
+++ b/games/gcompris/Makefile
@@ -29,7 +29,7 @@ post-extract:
@${RM} -f ${WRKSRC}/config.cache
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
diff --git a/games/gcompris2/Makefile b/games/gcompris2/Makefile
index 8c4c8e4ef96e..7925c5f06bd7 100644
--- a/games/gcompris2/Makefile
+++ b/games/gcompris2/Makefile
@@ -29,7 +29,7 @@ post-extract:
@${RM} -f ${WRKSRC}/config.cache
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
diff --git a/games/glife/Makefile b/games/glife/Makefile
index c204e37e51d0..6121acf31318 100644
--- a/games/glife/Makefile
+++ b/games/glife/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/gniffel/Makefile b/games/gniffel/Makefile
index cb496433d224..7f7b256e1d61 100644
--- a/games/gniffel/Makefile
+++ b/games/gniffel/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/gno3dtet/Makefile b/games/gno3dtet/Makefile
index 7a3d93633ef3..7cc322fdb2d9 100644
--- a/games/gno3dtet/Makefile
+++ b/games/gno3dtet/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
diff --git a/games/gnocatan/Makefile b/games/gnocatan/Makefile
index 67732eae2f11..3a6e759c510d 100644
--- a/games/gnocatan/Makefile
+++ b/games/gnocatan/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index 83b8044bef9c..3fc21bbd6026 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/gnomebreakout/Makefile b/games/gnomebreakout/Makefile
index 6d13b8ec2aed..ef909a27c5ea 100644
--- a/games/gnomebreakout/Makefile
+++ b/games/gnomebreakout/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/gnomegames/Makefile b/games/gnomegames/Makefile
index 83b8044bef9c..3fc21bbd6026 100644
--- a/games/gnomegames/Makefile
+++ b/games/gnomegames/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/gnomegames2/Makefile b/games/gnomegames2/Makefile
index 83b8044bef9c..3fc21bbd6026 100644
--- a/games/gnomegames2/Makefile
+++ b/games/gnomegames2/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/gnomememoryblocks/Makefile b/games/gnomememoryblocks/Makefile
index 2ff6489043c7..4e376c16f6ce 100644
--- a/games/gnomememoryblocks/Makefile
+++ b/games/gnomememoryblocks/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/gtktetcolor/Makefile b/games/gtktetcolor/Makefile
index 64301f0d5e94..ec51d9314218 100644
--- a/games/gtktetcolor/Makefile
+++ b/games/gtktetcolor/Makefile
@@ -20,7 +20,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index a94bb9fc2854..ea4a58cda9dc 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -40,7 +40,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sdl_mixer=${LOCALBASE}
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- LIBS="-L${LOCALBASE}/lib -lgnugetopt -pthread -lsmpeg" \
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt ${PTHREAD_LIBS} -lsmpeg" \
CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index db895af96ced..663e60048260 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= LIBS="-lcompat" \
SDL_CONFIG="${SDL_CONFIG}"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
xargs ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'
diff --git a/games/ltris/Makefile b/games/ltris/Makefile
index 64c3cfd7b531..030810c2f3fa 100644
--- a/games/ltris/Makefile
+++ b/games/ltris/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
LIBS="`${SDL_CONFIG} --libs` -L${LOCALBASE}/lib -lcompat"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
xargs ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'
diff --git a/games/pioneers/Makefile b/games/pioneers/Makefile
index 67732eae2f11..3a6e759c510d 100644
--- a/games/pioneers/Makefile
+++ b/games/pioneers/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/games/pythoong/Makefile b/games/pythoong/Makefile
index 4d188369fe42..ef06f47fa44b 100644
--- a/games/pythoong/Makefile
+++ b/games/pythoong/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/games/teg/Makefile b/games/teg/Makefile
index dcc79bb89c20..66c66024c5d7 100644
--- a/games/teg/Makefile
+++ b/games/teg/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \