aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/anki/Makefile12
-rw-r--r--games/balazar/Makefile14
-rw-r--r--games/balazarbrothers/Makefile14
-rw-r--r--games/bouncy/Makefile2
-rw-r--r--games/brainworkshop/Makefile2
-rw-r--r--games/childsplay/Makefile6
-rw-r--r--games/craft/Makefile2
-rw-r--r--games/endgame-singularity/Makefile2
-rw-r--r--games/funnyboat/Makefile2
-rw-r--r--games/gcompris/Makefile4
-rw-r--r--games/glchess/Makefile4
-rw-r--r--games/hypatia_engine/Makefile8
-rw-r--r--games/jools/Makefile2
-rw-r--r--games/kye/Makefile2
-rw-r--r--games/magicor/Makefile2
-rw-r--r--games/nelly/Makefile2
-rw-r--r--games/outerspace/Makefile2
-rw-r--r--games/plutocracy/Makefile2
-rw-r--r--games/poker-engine/Makefile13
-rw-r--r--games/ptkei/Makefile2
-rw-r--r--games/py-fife/Makefile1
-rw-r--r--games/py-mnemosyne/Makefile10
-rw-r--r--games/py-poker-eval/Makefile1
-rw-r--r--games/py-sgflib/Makefile1
-rw-r--r--games/py-sgfsummary/Makefile3
-rw-r--r--games/pydance/Makefile2
-rw-r--r--games/pyfa/Makefile12
-rw-r--r--games/pysolfc/Makefile2
-rw-r--r--games/pyspacewar/Makefile2
-rw-r--r--games/pysycache/Makefile2
-rw-r--r--games/pythonchess/Makefile2
-rw-r--r--games/pythonsudoku/Makefile4
-rw-r--r--games/retroarch/Makefile6
-rw-r--r--games/slune/Makefile10
-rw-r--r--games/unknown-horizons/Makefile8
-rw-r--r--games/wxlauncher/Makefile4
-rw-r--r--games/zephulor/Makefile2
37 files changed, 90 insertions, 81 deletions
diff --git a/games/anki/Makefile b/games/anki/Makefile
index 3d6d6425e28a..f9744db50314 100644
--- a/games/anki/Makefile
+++ b/games/anki/Makefile
@@ -16,12 +16,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= lame:audio/lame \
mplayer:multimedia/mplayer \
- ${PYTHON_PKGNAMEPREFIX}pyaudio>0:audio/py-pyaudio \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10 \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}beautifulsoup32>=0:www/py-beautifulsoup32 \
- ${PYTHON_PKGNAMEPREFIX}httplib2>0:www/py-httplib2 \
- ${PYTHON_PKGNAMEPREFIX}send2trash>0:deskutils/py-send2trash
+ ${PYTHON_PKGNAMEPREFIX}pyaudio>0:audio/py-pyaudio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup32>=0:www/py-beautifulsoup32@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httplib2>0:www/py-httplib2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}send2trash>0:deskutils/py-send2trash@${PY_FLAVOR}
USES= desktop-file-utils pyqt:4 python:2 shared-mime-info shebangfix tar:tgz
SHEBANG_FILES= tools/build_ui.sh tools/tests.sh
diff --git a/games/balazar/Makefile b/games/balazar/Makefile
index bad6c9792258..9f403f40da3b 100644
--- a/games/balazar/Makefile
+++ b/games/balazar/Makefile
@@ -15,17 +15,17 @@ LICENSE= GPLv2+
LIB_DEPENDS= libcal3d.so:graphics/cal3d \
libfreetype.so:print/freetype2
-RUN_DEPENDS= soya_editor:graphics/py-soya3d \
- ${PYTHON_PKGNAMEPREFIX}openal>0:audio/py-openal \
- ${PYTHON_PKGNAMEPREFIX}vorbis>0:audio/py-vorbis \
- ${PYTHON_PKGNAMEPREFIX}tofu>0:net/py-tofu \
- ${PYTHON_PKGNAMEPREFIX}cerealizer>0:security/py-cerealizer \
- ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted
+RUN_DEPENDS= soya_editor:graphics/py-soya3d@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openal>0:audio/py-openal@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}vorbis>0:audio/py-vorbis@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tofu>0:net/py-tofu@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cerealizer>0:security/py-cerealizer@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${FLAVOR}
BROKEN= fails to package: pkg-static: py27-twisted-17.5.0_1 conflicts with py27-twistedCore-15.2.1 (installs files into the same place)
NO_ARCH= yes
-USES= gettext python tar:bzip2
+USES= gettext python:2.7 tar:bzip2
USE_GL= glew
USE_SDL= mixer sdl
USE_PYTHON= autoplist distutils
diff --git a/games/balazarbrothers/Makefile b/games/balazarbrothers/Makefile
index 3b6cc8c4bebb..4ce53205ad68 100644
--- a/games/balazarbrothers/Makefile
+++ b/games/balazarbrothers/Makefile
@@ -18,15 +18,15 @@ BROKEN= conflicting dependencies
LIB_DEPENDS= libcal3d.so:graphics/cal3d \
libfreetype.so:print/freetype2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}vorbis>0:audio/py-vorbis \
- ${PYTHON_PKGNAMEPREFIX}soya3d>0:graphics/py-soya3d \
- ${PYTHON_PKGNAMEPREFIX}tofu>0:net/py-tofu \
- ${PYTHON_PKGNAMEPREFIX}cerealizer>0:security/py-cerealizer \
- ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}vorbis>0:audio/py-vorbis@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}soya3d>0:graphics/py-soya3d@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tofu>0:net/py-tofu@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cerealizer>0:security/py-cerealizer@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${FLAVOR}
NO_ARCH= yes
-USES= gettext python tar:bzip2
+USES= gettext python:2.7 tar:bzip2
USE_GL= glew
USE_PYTHON= autoplist distutils
@@ -40,7 +40,7 @@ DESKTOP_ENTRIES="BalazarBrothers" "" "" "balazarbrothers" "" ""
OPTIONS_DEFINE= OPENAL
OPTIONS_DEFAULT= OPENAL
-OPENAL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openal>0:audio/py-openal
+OPENAL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openal>0:audio/py-openal@${FLAVOR}
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/games/bouncy/Makefile b/games/bouncy/Makefile
index 90cc87ce3514..0cb0e58247d2 100644
--- a/games/bouncy/Makefile
+++ b/games/bouncy/Makefile
@@ -19,7 +19,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GPL.txt
RUN_DEPENDS= ${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL
+ ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL@${PY_FLAVOR}
WRKSRC= ${WRKDIR}/${PORTNAME}-post-${DISTVERSION}
diff --git a/games/brainworkshop/Makefile b/games/brainworkshop/Makefile
index 103177de5ac4..d920cef86f33 100644
--- a/games/brainworkshop/Makefile
+++ b/games/brainworkshop/Makefile
@@ -12,7 +12,7 @@ COMMENT= Free open-source version of the Dual N-Back mental exercise
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyglet/__init__.py:graphics/py-pyglet
-USES= dos2unix python:run zip
+USES= dos2unix python:2.7,run zip
NO_BUILD= yes
DOS2UNIX_FILES= brainworkshop.pyw
diff --git a/games/childsplay/Makefile b/games/childsplay/Makefile
index 6d2f4c423372..f3d99d9fb2d5 100644
--- a/games/childsplay/Makefile
+++ b/games/childsplay/Makefile
@@ -13,9 +13,9 @@ COMMENT= Educative games for children
LICENSE= GPLv3 # only
LICENSE_FILE= ${WRKSRC}/gpl-3.0.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10 \
- ${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game@${PY_FLAVOR}
NO_BUILD= yes
diff --git a/games/craft/Makefile b/games/craft/Makefile
index 3f21673dba8c..1adc271533df 100644
--- a/games/craft/Makefile
+++ b/games/craft/Makefile
@@ -26,7 +26,7 @@ USES= cmake compiler:c11
USE_XORG= x11 xi xrandr
USE_GL= gl glu
-SERVER_USES= python
+SERVER_USES= python:2.7
SERVER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.2:www/py-requests \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3
SERVER_CMAKE_ON= -DSERVER:BOOL=ON
diff --git a/games/endgame-singularity/Makefile b/games/endgame-singularity/Makefile
index b528f1d5a049..40c209c1ae9f 100644
--- a/games/endgame-singularity/Makefile
+++ b/games/endgame-singularity/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= py*-game>=1.8:devel/py-game \
USE_GITHUB= yes
-USES= python
+USES= python:2.7
USE_PYTHON= autoplist distutils
USE_SDL= image mixer
PORTDOCS= AUTHORS Changelog README.txt TODO
diff --git a/games/funnyboat/Makefile b/games/funnyboat/Makefile
index 10f27de7247a..ee4fc92e6757 100644
--- a/games/funnyboat/Makefile
+++ b/games/funnyboat/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:devel/py-game
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= python:run zip
+USES= python:2.7,run zip
NO_BUILD= yes
NO_ARCH= yes
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
index 0c04ec3c4ee4..8f1a7cc9b167 100644
--- a/games/gcompris/Makefile
+++ b/games/gcompris/Makefile
@@ -13,12 +13,12 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= texi2html:textproc/texi2html \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libao.so:audio/libao \
libassetml.so:devel/libassetml \
libdbus-glib-1.so:devel/dbus-glib
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
gnucap:cad/gnucap
USES= display:configure gettext gmake libtool localbase pathfix \
diff --git a/games/glchess/Makefile b/games/glchess/Makefile
index bcadea05ef3f..041e6d6f10d5 100644
--- a/games/glchess/Makefile
+++ b/games/glchess/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= 3D OpenGL based chess game
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/gdkgl/__init__.py:x11-toolkits/py-gtkglext
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/gdkgl/__init__.py:x11-toolkits/py-gtkglext@${FLAVOR}
-USES= desktop-file-utils python shared-mime-info
+USES= desktop-file-utils python:2.7 shared-mime-info
USE_GNOME= gconf2
USE_PYTHON= distutils
GCONF_SCHEMAS= glchess.schemas
diff --git a/games/hypatia_engine/Makefile b/games/hypatia_engine/Makefile
index 2e43350ba224..947838beaecd 100644
--- a/games/hypatia_engine/Makefile
+++ b/games/hypatia_engine/Makefile
@@ -12,11 +12,11 @@ COMMENT= Game engine for 2D top-down, tile-based action RPGs
LICENSE= MIT
RUN_DEPENDS= ${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}pyganim>0:graphics/py-pyganim \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
- ${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py-enum34
+ ${PYTHON_PKGNAMEPREFIX}pyganim>0:graphics/py-pyganim@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${FLAVOR} \
+ ${PY_ENUM34}
-USES= python:2
+USES= python
USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>
diff --git a/games/jools/Makefile b/games/jools/Makefile
index 2ec7e0b2b6f2..49a4ea4570a7 100644
--- a/games/jools/Makefile
+++ b/games/jools/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYGAME}
-USES= python
+USES= python:2.7
USE_PYTHON= distutils
PORTDOCS= POINTS manual.html manual.pdf manual.tex
diff --git a/games/kye/Makefile b/games/kye/Makefile
index 58b6c964b896..d3260e1e849a 100644
--- a/games/kye/Makefile
+++ b/games/kye/Makefile
@@ -23,7 +23,7 @@ RESTRICTED= kye-data_nuke_levels is charityware
RESTRICTED_FILES= kye-data_nuke_levels.20121101.tar.gz
USE_GNOME= pygtk2 librsvg2
-USES= python
+USES= python:2.7
USE_PYTHON= distutils
PORTDOCS= NEWS README
diff --git a/games/magicor/Makefile b/games/magicor/Makefile
index 33fff5cb847d..5bf8376f872c 100644
--- a/games/magicor/Makefile
+++ b/games/magicor/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:devel/py-game
-USES= python shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= *.py
NO_BUILD= yes
NO_ARCH= yes
diff --git a/games/nelly/Makefile b/games/nelly/Makefile
index 88f849bd4471..2c8e3e5dcf2c 100644
--- a/games/nelly/Makefile
+++ b/games/nelly/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Nelly's Rooftop Garden, physics-based puzzle game
RUN_DEPENDS= ${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL
+ ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL@${PY_FLAVOR}
USES= python:2
diff --git a/games/outerspace/Makefile b/games/outerspace/Makefile
index 9ac271e0ae15..c4d264c002d1 100644
--- a/games/outerspace/Makefile
+++ b/games/outerspace/Makefile
@@ -12,7 +12,7 @@ COMMENT= On-line strategy game
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:devel/py-game
-USES= python
+USES= python:2.7
NO_BUILD= yes
NO_ARCH= yes
diff --git a/games/plutocracy/Makefile b/games/plutocracy/Makefile
index 7e0fefcb1a5a..0890ad379933 100644
--- a/games/plutocracy/Makefile
+++ b/games/plutocracy/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
-USES= python tar:bzip2
+USES= python:2.7 tar:bzip2
USE_SDL= sdl pango
USE_GL= gl glu
USE_PYTHON= distutils
diff --git a/games/poker-engine/Makefile b/games/poker-engine/Makefile
index d39083cc89f8..881b035708d3 100644
--- a/games/poker-engine/Makefile
+++ b/games/poker-engine/Makefile
@@ -14,15 +14,16 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/bin/rsync:net/rsync \
- ${PYTHON_SITELIBDIR}/pokereval.py:games/py-poker-eval \
- ${PYTHON_SITELIBDIR}/libxml2.py:textproc/py-libxml2 \
- ${PYTHON_SITELIBDIR}/libxslt.py:textproc/py-libxslt
+ ${PYTHON_SITELIBDIR}/pokereval.py:games/py-poker-eval@${FLAVOR} \
+ ${PYTHON_SITELIBDIR}/libxml2.py:textproc/py-libxml2@${FLAVOR} \
+ ${PYTHON_SITELIBDIR}/libxslt.py:textproc/py-libxslt@${FLAVOR}
RUN_DEPENDS= ${LOCALBASE}/bin/rsync:net/rsync \
- ${PYTHON_SITELIBDIR}/pokereval.py:games/py-poker-eval \
- ${PYTHON_SITELIBDIR}/libxml2.py:textproc/py-libxml2 \
- ${PYTHON_SITELIBDIR}/libxslt.py:textproc/py-libxslt
+ ${PYTHON_SITELIBDIR}/pokereval.py:games/py-poker-eval@${FLAVOR} \
+ ${PYTHON_SITELIBDIR}/libxml2.py:textproc/py-libxml2@${FLAVOR} \
+ ${PYTHON_SITELIBDIR}/libxslt.py:textproc/py-libxslt@${FLAVOR}
USES= gettext gmake pathfix pkgconfig python:2
+USE_PYTHON= flavors
GNU_CONFIGURE= yes
test:
diff --git a/games/ptkei/Makefile b/games/ptkei/Makefile
index 59b2e65333eb..06291acbf890 100644
--- a/games/ptkei/Makefile
+++ b/games/ptkei/Makefile
@@ -13,7 +13,7 @@ COMMENT= Python/Tk graphical client for Wolfpack Empire servers
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/Pmw/__init__.py:x11-toolkits/py-Pmw
-USES= python shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= empire.py scripts/*.py
do-build:
diff --git a/games/py-fife/Makefile b/games/py-fife/Makefile
index 7955103baf5f..44fb66b62e0d 100644
--- a/games/py-fife/Makefile
+++ b/games/py-fife/Makefile
@@ -61,6 +61,7 @@ LOGGING_CMAKE_BOOL= logging
PYTHON_CMAKE_BOOL= build-python
PYTHON_USES= python:2
+PYTHON_USE= python=flavors
PYTHON_BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:devel/swig30
LIBRARY_CMAKE_BOOL= build-library
diff --git a/games/py-mnemosyne/Makefile b/games/py-mnemosyne/Makefile
index 093f2625d87f..5f771b40cfec 100644
--- a/games/py-mnemosyne/Makefile
+++ b/games/py-mnemosyne/Makefile
@@ -15,12 +15,12 @@ COMMENT= Flash-card tool which optimises your learning process
LICENSE= LGPL3
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.2.0:math/py-matplotlib \
- ${PYTHON_PKGNAMEPREFIX}cherrypy>=3.2:www/py-cherrypy \
- ${PYTHON_PKGNAMEPREFIX}webob>=1.2.2:www/py-webob
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.2.0:math/py-matplotlib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cherrypy>=3.2:www/py-cherrypy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}webob>=1.2.2:www/py-webob@${FLAVOR}
-USES= fortran pyqt:4 python
+USES= fortran pyqt:4 python:2.7
USE_PYQT= gui_run network_run sql_run webkit_run
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/games/py-poker-eval/Makefile b/games/py-poker-eval/Makefile
index 8c54a82d69d9..3349255277b0 100644
--- a/games/py-poker-eval/Makefile
+++ b/games/py-poker-eval/Makefile
@@ -18,6 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpoker-eval.so:games/poker-eval
USES= autoreconf libtool pathfix pkgconfig python:2
+USE_PYTHON= flavors
GNU_CONFIGURE= yes
CONFIGURE_ARGS= PYTHON=""
diff --git a/games/py-sgflib/Makefile b/games/py-sgflib/Makefile
index 76d61e19ff9e..f9ccbc987a7a 100644
--- a/games/py-sgflib/Makefile
+++ b/games/py-sgflib/Makefile
@@ -17,6 +17,7 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/lgpl.txt
USES= python shebangfix
+USE_PYTHON= flavors
NO_BUILD= yes
NO_ARCH= yes
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
diff --git a/games/py-sgfsummary/Makefile b/games/py-sgfsummary/Makefile
index 629e61fd0305..9ccb08671351 100644
--- a/games/py-sgfsummary/Makefile
+++ b/games/py-sgfsummary/Makefile
@@ -12,9 +12,10 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= SGF Summarizer
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/sgflib.py:games/py-sgflib
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/sgflib.py:games/py-sgflib@${FLAVOR}
USES= python shebangfix tar:tgz
+USE_PYTHON= flavors
SHEBANG_FILES= sgfsummary.py
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
NO_BUILD= yes
diff --git a/games/pydance/Makefile b/games/pydance/Makefile
index 9ce303f2a370..02241b7df9c5 100644
--- a/games/pydance/Makefile
+++ b/games/pydance/Makefile
@@ -18,7 +18,7 @@ COMMENT= Dancing simulation game similar to the kind in arcades
BUILD_DEPENDS= ${PYGAME}
RUN_DEPENDS= ${PYGAME}
-USES= python shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= pydance.py utils/findbpm.py
USE_PYTHON= distutils noegginfo
SUB_FILES= pkg-message
diff --git a/games/pyfa/Makefile b/games/pyfa/Makefile
index a59375a9f1d1..8870dcfd6137 100644
--- a/games/pyfa/Makefile
+++ b/games/pyfa/Makefile
@@ -13,9 +13,9 @@ COMMENT= Fitting tool for EVE Online
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=0.6:databases/py-sqlalchemy10 \
- ${PYTHON_PKGNAMEPREFIX}requests>=2.3.0:www/py-requests
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=0.6:databases/py-sqlalchemy10@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.3.0:www/py-requests@${PY_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= pyfa-org
@@ -34,9 +34,9 @@ WX_COMPS= wx:run python:run
OPTIONS_DEFINE= DPSGRAPHING
DPSGRAPHING_DESC= DPS graphing (requires NumPy and matplotlib)
-DPSGRAPHING_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.5.0:math/py-matplotlib \
- ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy \
- ${PYTHON_PKGNAMEPREFIX}more-itertools>0:devel/py-more-itertools
+DPSGRAPHING_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.5.0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}more-itertools>0:devel/py-more-itertools@${PY_FLAVOR}
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}
diff --git a/games/pysolfc/Makefile b/games/pysolfc/Makefile
index 034be7a758cb..b53f4e89ba84 100644
--- a/games/pysolfc/Makefile
+++ b/games/pysolfc/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow
-USES= python shebangfix tar:bzip2
+USES= python:2.7 shebangfix tar:bzip2
USE_PYTHON= autoplist distutils
NO_ARCH= yes
SHEBANG_FILES= data/themes/clearlooks/create_imgs.py
diff --git a/games/pyspacewar/Makefile b/games/pyspacewar/Makefile
index 133b598e1769..5b2e7b5b2c97 100644
--- a/games/pyspacewar/Makefile
+++ b/games/pyspacewar/Makefile
@@ -18,7 +18,7 @@ USE_GITHUB= yes
GH_ACCOUNT= mgedmin
GH_TAGNAME= f872564
-USES= python
+USES= python:2.7
USE_PYTHON= distutils autoplist
PORTDOCS= *.rst
diff --git a/games/pysycache/Makefile b/games/pysycache/Makefile
index 678ef350ebce..8a51b0843ba2 100644
--- a/games/pysycache/Makefile
+++ b/games/pysycache/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:devel/py-game
-USES= python shebangfix zip
+USES= python:2.7 shebangfix zip
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
SUB_FILES= pkg-message
diff --git a/games/pythonchess/Makefile b/games/pythonchess/Makefile
index 4e7986baf1ef..df959432b04a 100644
--- a/games/pythonchess/Makefile
+++ b/games/pythonchess/Makefile
@@ -17,7 +17,7 @@ COMMENT= Small program for playing chess against the computer
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/gpl.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
WRKSRC= ${WRKDIR}/${PORTNAME:S/p/P/:S/c/C/}
diff --git a/games/pythonsudoku/Makefile b/games/pythonsudoku/Makefile
index 0149704d40f0..82208b1db70c 100644
--- a/games/pythonsudoku/Makefile
+++ b/games/pythonsudoku/Makefile
@@ -20,8 +20,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS+= libcups.so:print/cups
RUN_DEPENDS= ${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow \
- ${PYTHON_PKGNAMEPREFIX}reportlab1>=0:print/py-reportlab1
+ ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}reportlab1>=0:print/py-reportlab1@${FLAVOR}
USES= python:2 tar:bzip2
USE_GNOME= pygtk2
diff --git a/games/retroarch/Makefile b/games/retroarch/Makefile
index 488fc5e838b3..151d59f818d9 100644
--- a/games/retroarch/Makefile
+++ b/games/retroarch/Makefile
@@ -44,7 +44,7 @@ OPENAL_USES= openal:soft
OPENAL_CONFIGURE_ENABLE=al
NETPLAY_CONFIGURE_ENABLE= netplay
PYTHON_CONFIGURE_ENABLE=python
-PYTHON_USES= python:3
+PYTHON_USES= python:3.4+
V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l
V4L_BUILD_DEPENDS= v4l_compat>0:multimedia/v4l_compat
V4L_CONFIGURE_ENABLE= v4l2
@@ -80,6 +80,10 @@ post-patch:
/^check_lib OSS_LIB/d' \
${WRKSRC}/qb/config.libs.sh
+post-patch-PYTHON-on:
+ @${REINPLACE_CMD} -e '/check_pkgconf PYTHON/s/python3/python-${PYTHON_VER}/' \
+ ${WRKSRC}/qb/config.libs.sh
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/retroarch
@${REINPLACE_CMD} -e 's|# libretro_directory =|libretro_directory = "${PREFIX}/libexec/libretro"|' \
diff --git a/games/slune/Makefile b/games/slune/Makefile
index 804bbb705dd7..d40b07d643c6 100644
--- a/games/slune/Makefile
+++ b/games/slune/Makefile
@@ -14,12 +14,12 @@ COMMENT= 3D game. includes racing, car-crashing, and lots of action
LICENSE= GPLv2
LIB_DEPENDS= libcal3d.so:graphics/cal3d
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openal>0:audio/py-openal \
- ${PYTHON_PKGNAMEPREFIX}vorbis>0:audio/py-vorbis \
- ${PYTHON_PKGNAMEPREFIX}soya3d>0:graphics/py-soya3d \
- ${PYTHON_PKGNAMEPREFIX}py2play>0:net-p2p/py-py2play
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openal>0:audio/py-openal@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}vorbis>0:audio/py-vorbis@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}soya3d>0:graphics/py-soya3d@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}py2play>0:net-p2p/py-py2play@${FLAVOR}
-USES= dos2unix gettext python tar:bzip2
+USES= dos2unix gettext python:2.7 tar:bzip2
DOS2UNIX_GLOB= *.po *.mo
USE_GL= glew
USE_SDL= sdl mixer
diff --git a/games/unknown-horizons/Makefile b/games/unknown-horizons/Makefile
index 31f3fbfdd201..1a69f8bd8ce1 100644
--- a/games/unknown-horizons/Makefile
+++ b/games/unknown-horizons/Makefile
@@ -13,10 +13,10 @@ LICENSE= GPLv2+
BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl \
${LOCALBASE}/bin/xsltproc:textproc/libxslt
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/fife/__init__.py:games/py-fife \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_SITELIBDIR}/yaml/__init__.py:devel/py-yaml \
- ${PYTHON_PKGNAMEPREFIX}gdbm>0:databases/py-gdbm
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/fife/__init__.py:games/py-fife@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${FLAVOR} \
+ ${PYTHON_SITELIBDIR}/yaml/__init__.py:devel/py-yaml@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gdbm>0:databases/py-gdbm@${FLAVOR}
ONLY_FOR_ARCHS= i386 amd64
diff --git a/games/wxlauncher/Makefile b/games/wxlauncher/Makefile
index 2e10fa56f46a..95cf8f9bb394 100644
--- a/games/wxlauncher/Makefile
+++ b/games/wxlauncher/Makefile
@@ -13,8 +13,8 @@ COMMENT= Multi-platform launcher for the Freespace 2 Source Code Project
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GPLv2.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>0:textproc/py-markdown \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>0:textproc/py-markdown@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= scp-fs2open
diff --git a/games/zephulor/Makefile b/games/zephulor/Makefile
index 39fae5c6df4e..396d2598ffad 100644
--- a/games/zephulor/Makefile
+++ b/games/zephulor/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING.txt
RUN_DEPENDS= ${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}tkinter>=0:x11-toolkits/py-tkinter
+ ${PYTHON_PKGNAMEPREFIX}tkinter>=0:x11-toolkits/py-tkinter@${PY_FLAVOR}
WRKSRC= ${WRKDIR}/zephulor-source