aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/cursive/Makefile17
-rw-r--r--games/cursive/distinfo5
-rw-r--r--games/cursive/files/patch-Makefile23
-rw-r--r--games/cursive/files/patch-cursive.611
-rw-r--r--games/cursive/files/patch-cursive.c11
-rw-r--r--games/cursive/pkg-descr2
6 files changed, 19 insertions, 50 deletions
diff --git a/games/cursive/Makefile b/games/cursive/Makefile
index 0be21b674623..e9bda601690a 100644
--- a/games/cursive/Makefile
+++ b/games/cursive/Makefile
@@ -2,18 +2,29 @@
# $FreeBSD$
PORTNAME= cursive
-PORTVERSION= 1.0
+PORTVERSION= 0.11
+PORTEPOCH= 1
CATEGORIES= games
-MASTER_SITES= ftp://puck.nether.net/pub/janc/
+MASTER_SITES= https://www.unixpapa.com/software/
DISTNAME= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ed.arrakis@gmail.com
COMMENT= Create ASCII character cursive handwriting
USES= tar:tgz
+NO_WRKSUBDIR= yes
+
PLIST_FILES= bin/cursive \
man/man6/cursive.6.gz
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/games/||g' ${WRKSRC}/cursive.6
+
+do-build:
+ ${CC} ${CFLAGS} -c ${WRKSRC}/cursive.c -o ${WRKSRC}/cursive.o
+ ${CC} ${CFLAGS} -c ${WRKSRC}/font.c -o ${WRKSRC}/font.o
+ ${CC} ${CFLAGS} -o ${WRKSRC}/cursive ${WRKSRC}/cursive.o ${WRKSRC}/font.o
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cursive ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/cursive.6 ${STAGEDIR}${PREFIX}/man/man6
diff --git a/games/cursive/distinfo b/games/cursive/distinfo
index 019157e9f1b9..9228651dee3c 100644
--- a/games/cursive/distinfo
+++ b/games/cursive/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cursive.tgz) = a76238f9f0b52ecddf2011fad801ba5cc01a14f2a518b05edb07dcba9699ef40
-SIZE (cursive.tgz) = 11207
+TIMESTAMP = 1582636072
+SHA256 (cursive.tgz) = f7068552689e753df6b4f546f0cfa69fa4e689487ce4eb1f0766b5751105e4ae
+SIZE (cursive.tgz) = 7129
diff --git a/games/cursive/files/patch-Makefile b/games/cursive/files/patch-Makefile
deleted file mode 100644
index cc6937586d5b..000000000000
--- a/games/cursive/files/patch-Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
---- Makefile.old Sun Oct 20 01:13:47 1991
-+++ Makefile Thu Apr 4 08:24:44 2002
-@@ -1,7 +1,9 @@
--CFLAGS = -g
-+CFLAGS += -g
-+
-+all: cursive
-
- cursive: cursive.o x.o xs.o
-- cc -g -o cursive cursive.o x.o xs.o
-+ ${CC} -g -o cursive cursive.o x.o xs.o
-
- x.c: font.c
- xstr font.c
-@@ -13,7 +15,7 @@
- # the same, but is slightly bigger.
-
- lcursive: cursive.o font.o
-- cc -g -o lcursive cursive.o font.o
-+ ${CC} -g -o lcursive cursive.o font.o
-
- cursive.shar: cursive.c font.c cursive.h cursive.6 Makefile shar
- shar cursive.c font.c cursive.h cursive.6 Makefile shar > cursive.shar
diff --git a/games/cursive/files/patch-cursive.6 b/games/cursive/files/patch-cursive.6
deleted file mode 100644
index fcf82cf4e2ab..000000000000
--- a/games/cursive/files/patch-cursive.6
+++ /dev/null
@@ -1,11 +0,0 @@
---- cursive.6.orig Sat Dec 4 17:31:42 1999
-+++ cursive.6 Sat Dec 4 17:32:03 1999
-@@ -3,7 +3,7 @@
- .SH NAME
- cursive \- print text in cursive script
- .SH SYNOPSIS
--.B /usr/games/cursive
-+.B cursive
- [
- .BI \-i n
- ]
diff --git a/games/cursive/files/patch-cursive.c b/games/cursive/files/patch-cursive.c
deleted file mode 100644
index 8a3e553c4203..000000000000
--- a/games/cursive/files/patch-cursive.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- cursive.c.orig Sat Dec 4 17:20:55 1999
-+++ cursive.c Sat Dec 4 17:21:32 1999
-@@ -128,7 +128,7 @@
- else
- {
- /* Message from standard input */
-- while (gets(message) != NULL)
-+ while (fgets(message, sizeof(message), stdin) != NULL)
- prline(message);
- }
- }
diff --git a/games/cursive/pkg-descr b/games/cursive/pkg-descr
index 8143272840ad..dd0318e01f08 100644
--- a/games/cursive/pkg-descr
+++ b/games/cursive/pkg-descr
@@ -9,3 +9,5 @@ Cursive is a program for generating cursive signatures and text like
Do not be fooled by inferior immitations (like the figlet font which
doesn't connect letters right). This is the one and only original
cursive program.
+
+WWW: https://www.unixpapa.com/cursive.html