aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/bos/Makefile45
-rw-r--r--games/bos/distinfo2
-rw-r--r--games/bos/pkg-descr4
-rw-r--r--games/boswars/Makefile45
-rw-r--r--games/boswars/distinfo2
-rw-r--r--games/boswars/pkg-descr4
7 files changed, 103 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 7dba44a6f5af..88925b74bacf 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -66,6 +66,7 @@
SUBDIR += bomberinstinct
SUBDIR += bombermaze
SUBDIR += bomns
+ SUBDIR += bos
SUBDIR += braincurses
SUBDIR += briquolo
SUBDIR += bs
diff --git a/games/bos/Makefile b/games/bos/Makefile
new file mode 100644
index 000000000000..e57f3ef7dffb
--- /dev/null
+++ b/games/bos/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: bos
+# Date created: 14 Oct 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bos
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= http://bos.seul.org/files/
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= A real-time strategy game
+
+RUN_DEPENDS= stratagus:${PORTSDIR}/games/stratagus
+
+PLIST= ${WRKDIR}/pkg-plist
+
+PLIST_FILES= bin/bos
+PLIST_DIRS= %%DATADIR%%
+
+do-build:
+ @(${ECHO_CMD} "#!${SH}"; \
+ ${ECHO_CMD} 'exec ${LOCALBASE}/bin/stratagus -d ${DATADIR} "$$@"') \
+ > ${WRKDIR}/${PORTNAME}
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @cd ${WRKSRC}/data && \
+ ${FIND} * -type d -empty | ${SORT} | ${SED} -e \
+ 's|^|@exec mkdir -p %D/%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} * -type f | ${SORT} | ${SED} -e \
+ 's|^|%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} * -type d | ${SORT} -r | ${SED} -e \
+ 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ cd ${WRKSRC}/data && \
+ ${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+
+.include <bsd.port.mk>
diff --git a/games/bos/distinfo b/games/bos/distinfo
new file mode 100644
index 000000000000..5db7ac4ae2cd
--- /dev/null
+++ b/games/bos/distinfo
@@ -0,0 +1,2 @@
+MD5 (bos_1_1.tar.gz) = 39e705ad6b4ae77e808cd88aabae361c
+SIZE (bos_1_1.tar.gz) = 21942511
diff --git a/games/bos/pkg-descr b/games/bos/pkg-descr
new file mode 100644
index 000000000000..dffb52b47342
--- /dev/null
+++ b/games/bos/pkg-descr
@@ -0,0 +1,4 @@
+Battle of Survival is a real-time strategy game using the Stratagus game
+engine.
+
+WWW: http://bos.seul.org/
diff --git a/games/boswars/Makefile b/games/boswars/Makefile
new file mode 100644
index 000000000000..e57f3ef7dffb
--- /dev/null
+++ b/games/boswars/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: bos
+# Date created: 14 Oct 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bos
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= http://bos.seul.org/files/
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= A real-time strategy game
+
+RUN_DEPENDS= stratagus:${PORTSDIR}/games/stratagus
+
+PLIST= ${WRKDIR}/pkg-plist
+
+PLIST_FILES= bin/bos
+PLIST_DIRS= %%DATADIR%%
+
+do-build:
+ @(${ECHO_CMD} "#!${SH}"; \
+ ${ECHO_CMD} 'exec ${LOCALBASE}/bin/stratagus -d ${DATADIR} "$$@"') \
+ > ${WRKDIR}/${PORTNAME}
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @cd ${WRKSRC}/data && \
+ ${FIND} * -type d -empty | ${SORT} | ${SED} -e \
+ 's|^|@exec mkdir -p %D/%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} * -type f | ${SORT} | ${SED} -e \
+ 's|^|%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} * -type d | ${SORT} -r | ${SED} -e \
+ 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ cd ${WRKSRC}/data && \
+ ${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+
+.include <bsd.port.mk>
diff --git a/games/boswars/distinfo b/games/boswars/distinfo
new file mode 100644
index 000000000000..5db7ac4ae2cd
--- /dev/null
+++ b/games/boswars/distinfo
@@ -0,0 +1,2 @@
+MD5 (bos_1_1.tar.gz) = 39e705ad6b4ae77e808cd88aabae361c
+SIZE (bos_1_1.tar.gz) = 21942511
diff --git a/games/boswars/pkg-descr b/games/boswars/pkg-descr
new file mode 100644
index 000000000000..dffb52b47342
--- /dev/null
+++ b/games/boswars/pkg-descr
@@ -0,0 +1,4 @@
+Battle of Survival is a real-time strategy game using the Stratagus game
+engine.
+
+WWW: http://bos.seul.org/