aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/bsdgames/Makefile8
-rw-r--r--games/doomlegacy/Makefile4
-rw-r--r--games/exult/Makefile8
-rw-r--r--games/freebsd-games/Makefile8
-rw-r--r--games/glaxium/Makefile8
-rw-r--r--games/gnubg/Makefile16
-rw-r--r--games/gturing/Makefile8
-rw-r--r--games/ldmud/Makefile8
-rw-r--r--games/mirrormagic/Makefile8
-rw-r--r--games/nighthawk/Makefile8
-rw-r--r--games/nil/Makefile4
-rw-r--r--games/openmortal/Makefile8
12 files changed, 81 insertions, 15 deletions
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
index 89c6ced4dee6..b42c67c5ca3a 100644
--- a/games/bsdgames/Makefile
+++ b/games/bsdgames/Makefile
@@ -57,6 +57,12 @@ PATHNAME_FILES= atc/atc.6 \
quiz/quiz.6 \
wump/pathnames.h
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-extract:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} extract)
@@ -74,4 +80,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
"${WRKSRC}/hack/hack.unix.c"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/doomlegacy/Makefile b/games/doomlegacy/Makefile
index 2fd1fdce78be..dbbfc859d345 100644
--- a/games/doomlegacy/Makefile
+++ b/games/doomlegacy/Makefile
@@ -72,6 +72,10 @@ post-install:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
.if defined(WITH_X86_ASM) && ${ARCH} == "i386"
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
MAKE_ARGS+= USEASM=1
diff --git a/games/exult/Makefile b/games/exult/Makefile
index a3c479f4dc74..3c41a2bc0edf 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -27,6 +27,12 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= expack.1 ipack.1 shp2pcx.1 splitshp.1 textpack.1
MAN6= exult.6
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|desktop||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
@@ -40,4 +46,4 @@ post-install:
.endif
@${SED} -e 's|%%DOCSDIR%%|${DOCSDIR}|' <${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/freebsd-games/Makefile b/games/freebsd-games/Makefile
index 89c6ced4dee6..b42c67c5ca3a 100644
--- a/games/freebsd-games/Makefile
+++ b/games/freebsd-games/Makefile
@@ -57,6 +57,12 @@ PATHNAME_FILES= atc/atc.6 \
quiz/quiz.6 \
wump/pathnames.h
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-extract:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} extract)
@@ -74,4 +80,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
"${WRKSRC}/hack/hack.unix.c"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/glaxium/Makefile b/games/glaxium/Makefile
index 868c61ae9038..0a936f6d3bcf 100644
--- a/games/glaxium/Makefile
+++ b/games/glaxium/Makefile
@@ -27,6 +27,12 @@ ALL_TARGET= ${PORTNAME}
MAN6= glaxium.6
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -i '' -e 's|/usr/X11R6|${X11BASE}|g; \
s|\$datadir/games/glaxium|\$datadir/glaxium|g' \
@@ -34,4 +40,4 @@ post-patch:
@${REINPLACE_CMD} -i '' -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index 351f305546dc..1b7bae321de7 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -67,6 +67,16 @@ CONFIGURE_ARGS+= --with-python
CONFIGURE_ARGS+= --without-python
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
+.if ${ARCH} == "sparc64"
+BROKEN= does not compile on sparc64
+.endif
+
post-extract:
${GUNZIP_CMD} --stdout ${DISTDIR}/${DIST_SUBDIR}/gnubg.weights-${GNUBG_WEIGHTS_VERSION}.gz > ${WRKSRC}/gnubg.weights
${GUNZIP_CMD} --stdout ${DISTDIR}/${DIST_SUBDIR}/gnubg_os0.bd.gz > ${WRKSRC}/gnubg_os0.bd
@@ -77,10 +87,4 @@ post-patch:
${REINPLACE_CMD} -e 's|"getopt\.h"|<getopt.h>|g' ${WRKSRC}/${file}
.endfor
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= does not compile on sparc64
-.endif
-
.include <bsd.port.post.mk>
diff --git a/games/gturing/Makefile b/games/gturing/Makefile
index f34733817de4..a644bf2e1927 100644
--- a/games/gturing/Makefile
+++ b/games/gturing/Makefile
@@ -31,6 +31,12 @@ EXAMPLES= 3ones2zeroes.tur add.tur bb3.tur dashnumbers.tur addbin.tur \
bb5.tur dec2bin.tur dec2bin_shift.tur bb2.tur bin2dec.tur \
bin2dec_shift.tur sort.tur subst.tur
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
${WRKSRC}/configure
@@ -47,4 +53,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/ldmud/Makefile b/games/ldmud/Makefile
index 5eb859374742..8a4a1542a58e 100644
--- a/games/ldmud/Makefile
+++ b/games/ldmud/Makefile
@@ -29,6 +29,12 @@ PLIST_SUB+= LPMUD="@comment " MUDLIB=""
PLIST_SUB+= LPMUD="@comment " MUDLIB="@comment "
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-install:
# Install an RC script for ldmud
${CAT} ${FILESDIR}/ldmud.sh | ${SED} -e "s:%%PREFIX%%:${PREFIX}:" \
@@ -56,4 +62,4 @@ post-install:
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} \
POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/mirrormagic/Makefile b/games/mirrormagic/Makefile
index 1cbca697985c..d6be7227240a 100644
--- a/games/mirrormagic/Makefile
+++ b/games/mirrormagic/Makefile
@@ -27,6 +27,12 @@ USE_XLIB= yes
ALL_TARGET= x11
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|$$(SDL_CONFIG)|g' \
${WRKSRC}/src/Makefile
@@ -49,4 +55,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/nighthawk/Makefile b/games/nighthawk/Makefile
index c52a983d361c..b6814cb1f177 100644
--- a/games/nighthawk/Makefile
+++ b/games/nighthawk/Makefile
@@ -24,6 +24,12 @@ USE_XPM= yes
USE_GMAKE= yes
MAN6= nighthawk.6
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
${REINPLACE_CMD} "s/malloc.h/stdlib.h/g" ${WRKSRC}/src/floor.cc \
${WRKSRC}/src/ship.cc ${WRKSRC}/src_sound/nighthawk_sound.c \
@@ -34,4 +40,4 @@ post-install:
${CHMOD} g+s ${PREFIX}/bin/nighthawk
${SH} pkg-install ${PORTNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/nil/Makefile b/games/nil/Makefile
index c0ee1b8a132e..bc41954ad404 100644
--- a/games/nil/Makefile
+++ b/games/nil/Makefile
@@ -27,6 +27,10 @@ OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
.if ${ARCH} == "ia64"
BROKEN= does not link on ${ARCH}
.endif
diff --git a/games/openmortal/Makefile b/games/openmortal/Makefile
index 36402df8794a..a717e01c5cb5 100644
--- a/games/openmortal/Makefile
+++ b/games/openmortal/Makefile
@@ -27,4 +27,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
post-patch:
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
+.include <bsd.port.post.mk>