aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/HeroesOfMightAndMagic/Makefile1
-rw-r--r--games/adom/Makefile6
-rw-r--r--games/atitd/Makefile8
-rw-r--r--games/dsnake/Makefile9
-rw-r--r--games/halflifeserver/Makefile2
-rw-r--r--games/hlserver-cs/Makefile2
-rw-r--r--games/hohlin/Makefile11
-rw-r--r--games/linux-enemyterritory-fortress/Makefile3
-rw-r--r--games/linux-enemyterritory-tce/Makefile5
-rw-r--r--games/linux-enemyterritory/Makefile13
-rw-r--r--games/linux-nwnclient/Makefile3
-rw-r--r--games/linux-nwserver/Makefile10
-rw-r--r--games/linux-q3ademo/Makefile10
-rw-r--r--games/linux-quake3-demo/Makefile10
-rw-r--r--games/linux-quake3/Makefile8
-rw-r--r--games/linux-quake3/pkg-plist3
-rw-r--r--games/linux-spheresofchaos-demo/Makefile2
-rw-r--r--games/linux-ssamtse/Makefile6
-rw-r--r--games/linux-steam/Makefile6
-rw-r--r--games/q3server-ra3/Makefile6
-rw-r--r--games/q3server/Makefile8
-rw-r--r--games/q3server/pkg-plist3
-rw-r--r--games/quake3-ra3/Makefile6
-rw-r--r--games/rt2-demo/Makefile2
-rw-r--r--games/rtcw-paks/Makefile14
-rw-r--r--games/rtcw-paks/pkg-plist12
-rw-r--r--games/rtcw/Makefile8
-rw-r--r--games/ssamtse/Makefile6
-rw-r--r--games/stvef-paks/Makefile16
-rw-r--r--games/stvef-paks/pkg-plist10
-rw-r--r--games/stvef-server/Makefile14
-rw-r--r--games/stvef-server/pkg-plist12
-rw-r--r--games/utserver-to/Makefile15
-rw-r--r--games/utserver/Makefile6
-rw-r--r--games/utserver/pkg-message6
35 files changed, 136 insertions, 126 deletions
diff --git a/games/HeroesOfMightAndMagic/Makefile b/games/HeroesOfMightAndMagic/Makefile
index 0809894d01cf..1518ee2cebdc 100644
--- a/games/HeroesOfMightAndMagic/Makefile
+++ b/games/HeroesOfMightAndMagic/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux
PLIST= ${WRKDIR}/PLIST
IS_INTERACTIVE= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
NO_CDROM= Software is commercial
diff --git a/games/adom/Makefile b/games/adom/Makefile
index 0ce9b2bdc672..136ae457dbf4 100644
--- a/games/adom/Makefile
+++ b/games/adom/Makefile
@@ -7,7 +7,7 @@
PORTNAME= adom
PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= http://www.adom.de/adom/download/linux/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}-elf
@@ -15,11 +15,11 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}-elf
MAINTAINER= sr-13@mail.ru
COMMENT= An rogue-like advanced rpg with color support (binary port)
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
NO_CDROM= Copy of CD must be sent to author
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/adom
NO_BUILD= yes
diff --git a/games/atitd/Makefile b/games/atitd/Makefile
index 4377c5fa0817..44d220448515 100644
--- a/games/atitd/Makefile
+++ b/games/atitd/Makefile
@@ -7,14 +7,14 @@
PORTNAME= atitd
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games graphics linux
MASTER_SITES= http://www.atitd.com/
DISTNAME= eClient-linux.run
EXTRACT_SUFX=
EXTRACT_ONLY=
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= The Linux "A Tale in the Desert" (ATITD) client
RUN_DEPENDS= ${X11BASE}/bin/xhost:${X_CLIENTS_PORT}
@@ -28,7 +28,8 @@ RUN_DEPENDS+= ${LINUXBASE}/lib/libGL.so:${PORTSDIR}/graphics/linux_glx
.endif
PLIST_FILES= bin/atitd
-USE_LINUX?= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
USE_MESA= yes
ONLY_FOR_ARCHS= i386
@@ -58,6 +59,7 @@ do-install:
post-install:
@${ECHO_MSG} "===> Fixing permissions."
@${CHOWN} -R atitd:atitd ${PREFIX}/games/atitd
+ @${BRANDELF} -t Linux ${PREFIX}/games/atitd/elaunch
@${CHMOD} ug+s ${PREFIX}/games/atitd/elaunch
${INSTALL_SCRIPT} ${WRKSRC}/atitd.sh ${PREFIX}/bin/atitd
@${ECHO_MSG} "===> Running the post-install script."
diff --git a/games/dsnake/Makefile b/games/dsnake/Makefile
index 032fa929fc02..6c583ec364ec 100644
--- a/games/dsnake/Makefile
+++ b/games/dsnake/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dsnake
PORTVERSION= 3.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= http://bitblaze.com/downloads/
DISTNAME= ${PORTNAME}-linux-${PORTVERSION}
@@ -20,10 +20,13 @@ RUN_DEPENDS= ${LINUXBASE}/usr/lib/liballeg.so.4.0:${PORTSDIR}/devel/linux-allegr
NO_PACKAGE= Licence forbids any repacking and reselling
ONLY_FOR_ARCHS= i386
-NO_BUILD= yes
-PREFIX?= ${X11BASE}
+USE_LINUX= yes
+USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/DeluxeSnake
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/dsnake
+
do-install:
${MKDIR} ${DATADIR}
(cd ${WRKSRC}; ${TAR} -cf - *) | (cd ${DATADIR}; ${TAR} -xf -)
diff --git a/games/halflifeserver/Makefile b/games/halflifeserver/Makefile
index 5ae639046c1d..4989f8948a2a 100644
--- a/games/halflifeserver/Makefile
+++ b/games/halflifeserver/Makefile
@@ -18,7 +18,7 @@ COMMENT= Half-Life Dedicated Server for Linux
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
+USE_LINUX= yes
USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
diff --git a/games/hlserver-cs/Makefile b/games/hlserver-cs/Makefile
index f0dfa2888124..5c2a84031f15 100644
--- a/games/hlserver-cs/Makefile
+++ b/games/hlserver-cs/Makefile
@@ -26,7 +26,7 @@ USE_SUBMAKE= yes
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
+USE_LINUX= yes
USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
diff --git a/games/hohlin/Makefile b/games/hohlin/Makefile
index 4045216f221c..838a8ecc7d8f 100644
--- a/games/hohlin/Makefile
+++ b/games/hohlin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hohlin
PORTVERSION= 1.01
+PORTREVISION= 1
CATEGORIES= games
#MASTER_SITES= http://retrospec.sgn.net/download.php?id=63&path=games/hoh/bin/
#requires post to download
@@ -17,20 +18,22 @@ DISTNAME= ${PORTNAME}-${SHORTPORTVERSION}
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Remake of the classic spectrum game Head over Heels
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrandr.so.2:${PORTSDIR}/x11/linux-XFree86-libs
-
WRKSRC= ${WRKDIR}/hoh-install-${PORTVERSION}/
USE_BZIP2= YES
-NO_BUILD= YES
+USE_LINUX= yes
+USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386
SHORTPORTVERSION=${PORTVERSION:C/([0-9]*)\.([0-9]*)/\1\2/}
.include <bsd.port.pre.mk>
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/data/HoH
+
do-install:
${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/data/HoH ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/data/HoH ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/data/HoHOriginal.dat ${DATADIR}
${MKDIR} ${DATADIR}/Sound
${INSTALL_DATA} ${WRKSRC}/data/Sound/Sound.dat ${DATADIR}/Sound/
diff --git a/games/linux-enemyterritory-fortress/Makefile b/games/linux-enemyterritory-fortress/Makefile
index 962c7a834928..70eb3aac3c2b 100644
--- a/games/linux-enemyterritory-fortress/Makefile
+++ b/games/linux-enemyterritory-fortress/Makefile
@@ -7,6 +7,7 @@
PORTNAME= enemyterritory-fortress
PORTVERSION= 1.4
+PORTREVISON= 1
CATEGORIES= games linux
MASTER_SITES= http://ftp.games.skynet.be/pub/wolfenstein/etf/ \
http://www.playlinux.net/pub/files/native/
@@ -20,8 +21,8 @@ COMMENT= A class-based teamplay modification for Enemy Territory
RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
ONLY_FOR_ARCHS= i386
-PREFIX?= ${X11BASE} # USE_X_PREFIX would pull in USE_XLIB
USE_LINUX= yes
+USE_X_PREFIX= yes
NO_PACKAGE= Distfile is 249MB, set FORCE_PACKAGE if you really want to build this package
RESTRICTED= Redistribution is limited, see license
NO_WRKSUBDIR= yes
diff --git a/games/linux-enemyterritory-tce/Makefile b/games/linux-enemyterritory-tce/Makefile
index 155a0c249864..cf51e33fe694 100644
--- a/games/linux-enemyterritory-tce/Makefile
+++ b/games/linux-enemyterritory-tce/Makefile
@@ -7,7 +7,7 @@
PORTNAME= enemyterritory-tce
PORTVERSION= 0.48
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= http://ftp.games.skynet.be/pub/www.filesnetwork.com/Wolfenstein_Enemy_Territory/Mods/Total_Conversions/:full,update \
http://darkstar.ist.utl.pt/pub/games/:full,update \
@@ -26,12 +26,11 @@ RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
ONLY_FOR_ARCHS= i386
USE_ZIP= yes
-PREFIX?= ${X11BASE} # USE_X_PREFIX would pull in USE_XLIB
USE_LINUX= yes
+USE_X_PREFIX= yes
NO_PACKAGE= Distfiles are 135MB, set FORCE_PACKAGE if you really want to build this package
RESTRICTED= Redistribution is limited, see license
ETDIR= ${PREFIX}/lib/enemyterritory
-STRIP= # do not brand Linux binaries as FreeBSD on INSTALL_PROGRAM
do-build:
.for f in et etded
diff --git a/games/linux-enemyterritory/Makefile b/games/linux-enemyterritory/Makefile
index 3da7b2e94b76..1b4b597645f7 100644
--- a/games/linux-enemyterritory/Makefile
+++ b/games/linux-enemyterritory/Makefile
@@ -7,6 +7,7 @@
PORTNAME= enemyterritory
PORTVERSION= 2.60
+PORTREVISION= 1
CATEGORIES= games linux
MASTER_SITES= http://mirrors.xmission.com/idsoftware/et/linux/ \
http://3dgamers.intelenet.net/pub/3dgamers/games/wolfensteinet/ \
@@ -22,15 +23,11 @@ EXTRACT_SUFX= .run
MAINTAINER= benlutz@datacomm.ch
COMMENT= Wolfenstein: Enemy Territory (Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
-
ONLY_FOR_ARCHS= i386
-PREFIX?= ${X11BASE} # USE_X_PREFIX would pull in USE_XLIB
USE_LINUX= yes
+USE_X_PREFIX= yes
NO_PACKAGE= Package will be 257MB, set FORCE_PACKAGE if you really want to build it
RESTRICTED= Redistribution is limited, see license
-NO_BUILD= yes
-STRIP= # empty: do not strip(1) linux binaries
NO_WRKSUBDIR= yes
ETDIR= ${PREFIX}/lib/${PORTNAME}
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
@@ -45,6 +42,12 @@ post-patch:
@${SED} -e 's|@ETDIR@|${ETDIR}|' ${FILESDIR}/${FILE}.in > ${WRKSRC}/${FILE}
.endfor
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/pb/pbweb.x86
+.for FILE in et.x86 etded.x86
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/${FILE}
+.endfor
+
do-install:
${INSTALL_DIR} ${ETDIR}
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index 4fc4b98f2e0b..76d420fd22b7 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nwnclient
PORTVERSION= 1.65
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= http://content.bioware.com/neverwinternights/linux/${PORTVERSION:S/.//}/
PKGNAMEPREFIX= linux-
@@ -23,6 +23,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/nwndata/NWNv129.txt:${PORTSDIR}/games/nwndata \
NO_BUILD= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
NWNDATADIR= ${LOCALBASE}/share/nwndata
PLIST_SUB+= NWNVERSION="${PORTVERSION:S/.//}"
diff --git a/games/linux-nwserver/Makefile b/games/linux-nwserver/Makefile
index 0f7072225c6f..fad8f784d27e 100644
--- a/games/linux-nwserver/Makefile
+++ b/games/linux-nwserver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nwserver
PORTVERSION= 1.32
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= http://nwdownloads.bioware.com/neverwinternights/linux/${PORTVERSION:S/.//}/
PKGNAMEPREFIX= linux-
@@ -16,14 +16,12 @@ DISTNAME= linuxserver${PORTVERSION:S/.//}
MAINTAINER= apeiron@coitusmentis.info
COMMENT= Neverwinter Nights Linux (x86) Dedicated Server
-USE_LINUX?= yes
-NO_BUILD= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
WRKSRC= ${WRKDIR}
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
+do-build:
+ ${BRANDELF} -t Linux ${WRKDIR}/nwserver
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/fixinstall ${PREFIX}/bin
diff --git a/games/linux-q3ademo/Makefile b/games/linux-q3ademo/Makefile
index be3e026c84f3..7416ed8b981c 100644
--- a/games/linux-q3ademo/Makefile
+++ b/games/linux-q3ademo/Makefile
@@ -10,7 +10,7 @@
PORTNAME= linux-q3ademo
PORTVERSION= 1.11.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games graphics linux
# fetch manually
MASTER_SITES=
@@ -21,8 +21,9 @@ EXTRACT_SUFX=
MAINTAINER= ports@FreeBSD.org
COMMENT= Linux 3d shooter from id Software / Loki Software (demo version)
-PREFIX?= ${X11BASE}
USE_GL= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
.include <bsd.port.pre.mk>
@@ -32,9 +33,6 @@ RUN_DEPENDS += ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_
RUN_DEPENDS += ${LINUXBASE}/lib/libGL.so:${PORTSDIR}/graphics/linux_glx
.endif
-# Linux binary should not be stripped by INSTALL_PROGRAM as it uses /usr/bin/strip which then brands the binary as a FreeBSD ELF one.
-STRIP=
-
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= may not be automatically fetched due to licensing\
restrictions. You MUST manually fetch the Linux version from:\
@@ -63,6 +61,8 @@ do-configure:
@${ECHO_CMD} "quake=\"./q3demo\"" >> ${WRKSRC}/q3demo
@${ECHO_CMD} "\""$$"quake\" "$$"*" >> ${WRKSRC}/q3demo
@${ECHO_CMD} "exit "$$"?" >> ${WRKSRC}/q3demo
+ @${BRANDELF} -t Linux ${WRKSRC}/bin/x86/glibc-2.0/q3ded
+ @${BRANDELF} -t Linux ${WRKSRC}/bin/x86/glibc-2.0/q3demo
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/q3demo ${PREFIX}/bin
diff --git a/games/linux-quake3-demo/Makefile b/games/linux-quake3-demo/Makefile
index be3e026c84f3..7416ed8b981c 100644
--- a/games/linux-quake3-demo/Makefile
+++ b/games/linux-quake3-demo/Makefile
@@ -10,7 +10,7 @@
PORTNAME= linux-q3ademo
PORTVERSION= 1.11.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games graphics linux
# fetch manually
MASTER_SITES=
@@ -21,8 +21,9 @@ EXTRACT_SUFX=
MAINTAINER= ports@FreeBSD.org
COMMENT= Linux 3d shooter from id Software / Loki Software (demo version)
-PREFIX?= ${X11BASE}
USE_GL= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
.include <bsd.port.pre.mk>
@@ -32,9 +33,6 @@ RUN_DEPENDS += ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_
RUN_DEPENDS += ${LINUXBASE}/lib/libGL.so:${PORTSDIR}/graphics/linux_glx
.endif
-# Linux binary should not be stripped by INSTALL_PROGRAM as it uses /usr/bin/strip which then brands the binary as a FreeBSD ELF one.
-STRIP=
-
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= may not be automatically fetched due to licensing\
restrictions. You MUST manually fetch the Linux version from:\
@@ -63,6 +61,8 @@ do-configure:
@${ECHO_CMD} "quake=\"./q3demo\"" >> ${WRKSRC}/q3demo
@${ECHO_CMD} "\""$$"quake\" "$$"*" >> ${WRKSRC}/q3demo
@${ECHO_CMD} "exit "$$"?" >> ${WRKSRC}/q3demo
+ @${BRANDELF} -t Linux ${WRKSRC}/bin/x86/glibc-2.0/q3ded
+ @${BRANDELF} -t Linux ${WRKSRC}/bin/x86/glibc-2.0/q3demo
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/q3demo ${PREFIX}/bin
diff --git a/games/linux-quake3/Makefile b/games/linux-quake3/Makefile
index 781b49a5b18f..33a6c620ffef 100644
--- a/games/linux-quake3/Makefile
+++ b/games/linux-quake3/Makefile
@@ -18,14 +18,14 @@ MAINTAINER= pat@FreeBSD.org
COMMENT= Quake III Arena Dedicated Server for Linux
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
+USE_LINUX= yes
USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
NO_WRKSUBDIR= yes
-Q3DIR= usr/games/quake3/
-PLIST_SUB+= Q3DIR="${Q3DIR}"
+Q3BASE= games
+Q3DIR= ${Q3BASE}/quake3/
+PLIST_SUB+= Q3DIR="${Q3DIR}" Q3BASE="${Q3BASE}"
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
do-extract:
diff --git a/games/linux-quake3/pkg-plist b/games/linux-quake3/pkg-plist
index 88a94199ab49..6f7c422a1252 100644
--- a/games/linux-quake3/pkg-plist
+++ b/games/linux-quake3/pkg-plist
@@ -95,4 +95,5 @@
%%PORTDOCS%%@dirrm %%Q3DIR%%Docs/PunkBuster
%%PORTDOCS%%@dirrm %%Q3DIR%%Docs/LinuxFAQ
%%PORTDOCS%%@dirrm %%Q3DIR%%Docs
-@unexec rmdir %D/%%Q3DIR%% 2>/dev/null || echo "If you are permanently removing this port, you should do a ``rm -Rf ${PKG_PREFIX}/%%Q3DIR%%`` to remove any configuration files, *.pk3 files, and mods left." | fmt
+@unexec rmdir %D/%%Q3DIR%% >/dev/null 2>&1 || echo "If you are permanently removing this port, you should do a ``rm -Rf ${PKG_PREFIX}/%%Q3DIR%%; rmdir ${PKG_PREFIX}/%%Q3BASE%% >/dev/null 2>&1 || true`` to remove any configuration files, *.pk3 files, and mods left." | fmt
+@unexec rmdir %D/%%Q3BASE%% >/dev/null 2>&1 || true
diff --git a/games/linux-spheresofchaos-demo/Makefile b/games/linux-spheresofchaos-demo/Makefile
index 4f641f568a5d..7a7ce470044b 100644
--- a/games/linux-spheresofchaos-demo/Makefile
+++ b/games/linux-spheresofchaos-demo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= spheresofchaos
PORTVERSION= 2.06
+PORTREVISION= 1
CATEGORIES= games linux
MASTER_SITES= http://people.FreeBSD.org/~roam/games/ \
${MASTER_SITE_LOCAL}
@@ -21,6 +22,7 @@ COMMENT= An unusual and spectacular shoot-em-up for the PC
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
USE_ZIP= yes
+USE_LINUX= yes
NO_BUILD= yes
diff --git a/games/linux-ssamtse/Makefile b/games/linux-ssamtse/Makefile
index 9f365edfdfaf..bd4a3dcab9ed 100644
--- a/games/linux-ssamtse/Makefile
+++ b/games/linux-ssamtse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ssamtse
PORTVERSION= b1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= # must fetch manually
DISTFILES= ${PORTNAME}-${PORTVERSION:S|b|beta|}.sh.bin
@@ -16,11 +16,10 @@ EXTRACT_ONLY=
MAINTAINER= asa@gascom.ru
COMMENT= Serious Sam - The Second Encounter
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
NO_BUILD= yes
USE_BZIP2= yes
USE_REINPLACE= yes
+USE_LINUX= yes
USE_X_PREFIX= yes
USE_GL= yes
INSTALLS_SHLIB= yes
@@ -59,6 +58,7 @@ post-patch:
@${SED} 's|%SSAMDIR%|${SSAMDIR}|g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
do-install:
+# XXX: this is missing "${BRANDELF} -t Linux <executables>"
@${MKDIR} ${SSAMDIR}
@${TAR} --bzip2 -C ${SSAMDIR} -xf \
${WRKDIR}/ssam/bins.tar.bz2
diff --git a/games/linux-steam/Makefile b/games/linux-steam/Makefile
index efa38c1064d9..26362f628e60 100644
--- a/games/linux-steam/Makefile
+++ b/games/linux-steam/Makefile
@@ -7,7 +7,7 @@
PORTNAME= steam
PORTVERSION= 1.0
-PORTREVISOIN= 1
+PORTREVISOIN= 2
CATEGORIES= games linux
MASTER_SITES= http://www.coreblack.com/files/
PKGNAMEPREFIX= linux-
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= linux-
MAINTAINER= hido@coreblack.com
COMMENT= Half Life dedicated server running on steam
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
-
IS_INTERACTIVE= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
INSTALLDIR?= steam
diff --git a/games/q3server-ra3/Makefile b/games/q3server-ra3/Makefile
index fba662cc6309..651707b7893b 100644
--- a/games/q3server-ra3/Makefile
+++ b/games/q3server-ra3/Makefile
@@ -19,10 +19,10 @@ DISTFILES?= ${PORTNAME}${PORTVERSION:S/.//}cl.zip \
MAINTAINER?= pat@FreeBSD.org
COMMENT?= Quake III Arena Mod: Rocket Arena 3 for Linux
-RUN_DEPENDS= ${LINUXBASE}/usr/games/quake3/q3ded:${Q3SERVER_PORT}
+RUN_DEPENDS= ${LOCALBASE}/games/quake3/q3ded:${Q3SERVER_PORT}
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
+USE_LINUX= yes
USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
@@ -42,7 +42,7 @@ WRKSRC?= ${WRKDIR}/${PORTNAME}
Q3SUBDIR?= ${PORTNAME}
.endif
-Q3DIR= usr/games/quake3/${Q3SUBDIR}/
+Q3DIR= games/quake3/${Q3SUBDIR}/
PLIST_SUB+= Q3DIR="${Q3DIR}"
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
diff --git a/games/q3server/Makefile b/games/q3server/Makefile
index 781b49a5b18f..33a6c620ffef 100644
--- a/games/q3server/Makefile
+++ b/games/q3server/Makefile
@@ -18,14 +18,14 @@ MAINTAINER= pat@FreeBSD.org
COMMENT= Quake III Arena Dedicated Server for Linux
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
+USE_LINUX= yes
USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
NO_WRKSUBDIR= yes
-Q3DIR= usr/games/quake3/
-PLIST_SUB+= Q3DIR="${Q3DIR}"
+Q3BASE= games
+Q3DIR= ${Q3BASE}/quake3/
+PLIST_SUB+= Q3DIR="${Q3DIR}" Q3BASE="${Q3BASE}"
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
do-extract:
diff --git a/games/q3server/pkg-plist b/games/q3server/pkg-plist
index 88a94199ab49..6f7c422a1252 100644
--- a/games/q3server/pkg-plist
+++ b/games/q3server/pkg-plist
@@ -95,4 +95,5 @@
%%PORTDOCS%%@dirrm %%Q3DIR%%Docs/PunkBuster
%%PORTDOCS%%@dirrm %%Q3DIR%%Docs/LinuxFAQ
%%PORTDOCS%%@dirrm %%Q3DIR%%Docs
-@unexec rmdir %D/%%Q3DIR%% 2>/dev/null || echo "If you are permanently removing this port, you should do a ``rm -Rf ${PKG_PREFIX}/%%Q3DIR%%`` to remove any configuration files, *.pk3 files, and mods left." | fmt
+@unexec rmdir %D/%%Q3DIR%% >/dev/null 2>&1 || echo "If you are permanently removing this port, you should do a ``rm -Rf ${PKG_PREFIX}/%%Q3DIR%%; rmdir ${PKG_PREFIX}/%%Q3BASE%% >/dev/null 2>&1 || true`` to remove any configuration files, *.pk3 files, and mods left." | fmt
+@unexec rmdir %D/%%Q3BASE%% >/dev/null 2>&1 || true
diff --git a/games/quake3-ra3/Makefile b/games/quake3-ra3/Makefile
index fba662cc6309..651707b7893b 100644
--- a/games/quake3-ra3/Makefile
+++ b/games/quake3-ra3/Makefile
@@ -19,10 +19,10 @@ DISTFILES?= ${PORTNAME}${PORTVERSION:S/.//}cl.zip \
MAINTAINER?= pat@FreeBSD.org
COMMENT?= Quake III Arena Mod: Rocket Arena 3 for Linux
-RUN_DEPENDS= ${LINUXBASE}/usr/games/quake3/q3ded:${Q3SERVER_PORT}
+RUN_DEPENDS= ${LOCALBASE}/games/quake3/q3ded:${Q3SERVER_PORT}
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
+USE_LINUX= yes
USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
@@ -42,7 +42,7 @@ WRKSRC?= ${WRKDIR}/${PORTNAME}
Q3SUBDIR?= ${PORTNAME}
.endif
-Q3DIR= usr/games/quake3/${Q3SUBDIR}/
+Q3DIR= games/quake3/${Q3SUBDIR}/
PLIST_SUB+= Q3DIR="${Q3DIR}"
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
diff --git a/games/rt2-demo/Makefile b/games/rt2-demo/Makefile
index bd99ff6d6bf1..8ea4735c9423 100644
--- a/games/rt2-demo/Makefile
+++ b/games/rt2-demo/Makefile
@@ -19,7 +19,7 @@ COMMENT= The free demo of Railroad Tycoon II
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_LINUX?= yes
+USE_LINUX= yes
do-install:
@${SH} ${FILESDIR}/do-install ${PREFIX} ${DISTDIR}
diff --git a/games/rtcw-paks/Makefile b/games/rtcw-paks/Makefile
index 001775f2d5cd..daace097aabb 100644
--- a/games/rtcw-paks/Makefile
+++ b/games/rtcw-paks/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rtcw-paks
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= games linux
MASTER_SITES= #
DISTFILES= mp_pak0.pk3 mp_pak1.pk3 mp_pak2.pk3 \
@@ -18,17 +19,17 @@ IGNOREFILES= ${ALLFILES}
MAINTAINER= nik@FreeBSD.org
COMMENT= Return to Castle Wolfenstein for Linux .pk3 files
-# Make this a BUILD_ rather than a RUN_DEPEND so that it can create the
+# Make this a BUILD_DEPENDS too, so that it can create the
# directory hierarchy for us.
-BUILD_DEPENDS= ${PREFIX}/usr/games/rtcw/wolf.x86:${PORTSDIR}/games/rtcw
+BUILD_DEPENDS= ${X11BASE}/games/rtcw/wolf.x86:${PORTSDIR}/games/rtcw
+RUN_DEPENDS= ${BUILD_DEPENDS}
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
EXTRACT_ONLY= # Don't extract anything
-STRIP=
-GAMEDIR= ${PREFIX}/usr/games/rtcw/
+GAMEDIR= ${PREFIX}/games/rtcw/
.include <bsd.port.pre.mk>
@@ -41,6 +42,7 @@ IGNORE=You must manually copy all the .pk3 files from the main/ directory of an
# Do nothing for the build. Don't set NO_BUILD because of the earlier
# BUILD_DEPENDS
do-build:
+ @${DO_NADA}
do-install:
${MKDIR} -p ${GAMEDIR}/main
diff --git a/games/rtcw-paks/pkg-plist b/games/rtcw-paks/pkg-plist
index a9c76a4bde87..29fd53465658 100644
--- a/games/rtcw-paks/pkg-plist
+++ b/games/rtcw-paks/pkg-plist
@@ -1,6 +1,6 @@
-usr/games/rtcw/main/mp_pak0.pk3
-usr/games/rtcw/main/mp_pak1.pk3
-usr/games/rtcw/main/mp_pak2.pk3
-usr/games/rtcw/main/pak0.pk3
-usr/games/rtcw/main/sp_pak1.pk3
-usr/games/rtcw/main/sp_pak2.pk3
+games/rtcw/main/mp_pak0.pk3
+games/rtcw/main/mp_pak1.pk3
+games/rtcw/main/mp_pak2.pk3
+games/rtcw/main/pak0.pk3
+games/rtcw/main/sp_pak1.pk3
+games/rtcw/main/sp_pak2.pk3
diff --git a/games/rtcw/Makefile b/games/rtcw/Makefile
index d4b58d65182e..37a8a142d439 100644
--- a/games/rtcw/Makefile
+++ b/games/rtcw/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rtcw
PORTVERSION= 1.1b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/wolf/linux/old/
DISTNAME= wolf-linux-${PORTVERSION}.x86
@@ -17,13 +17,13 @@ MAINTAINER= nik@FreeBSD.org
COMMENT= Return to Castle Wolfenstein for Linux
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_PERL5_BUILD=yes
-RTCWDIR= usr/games/rtcw
+RTCWDIR= games/rtcw
PLIST_SUB+= RTCWDIR="${RTCWDIR}"
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
diff --git a/games/ssamtse/Makefile b/games/ssamtse/Makefile
index 9f365edfdfaf..bd4a3dcab9ed 100644
--- a/games/ssamtse/Makefile
+++ b/games/ssamtse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ssamtse
PORTVERSION= b1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= # must fetch manually
DISTFILES= ${PORTNAME}-${PORTVERSION:S|b|beta|}.sh.bin
@@ -16,11 +16,10 @@ EXTRACT_ONLY=
MAINTAINER= asa@gascom.ru
COMMENT= Serious Sam - The Second Encounter
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
NO_BUILD= yes
USE_BZIP2= yes
USE_REINPLACE= yes
+USE_LINUX= yes
USE_X_PREFIX= yes
USE_GL= yes
INSTALLS_SHLIB= yes
@@ -59,6 +58,7 @@ post-patch:
@${SED} 's|%SSAMDIR%|${SSAMDIR}|g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
do-install:
+# XXX: this is missing "${BRANDELF} -t Linux <executables>"
@${MKDIR} ${SSAMDIR}
@${TAR} --bzip2 -C ${SSAMDIR} -xf \
${WRKDIR}/ssam/bins.tar.bz2
diff --git a/games/stvef-paks/Makefile b/games/stvef-paks/Makefile
index a5784dda5731..c30aab5a16db 100644
--- a/games/stvef-paks/Makefile
+++ b/games/stvef-paks/Makefile
@@ -7,7 +7,7 @@
PORTNAME= stvef-paks
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= #
DISTFILES= pak0.pk3
@@ -17,17 +17,17 @@ IGNOREFILES= ${ALLFILES}
MAINTAINER= nik@FreeBSD.org
COMMENT= Star Trek Voyager: Elite Forces dedicated server for Linux .pk3 files
-# Make this a BUILD_ rather than a RUN_DEPEND so that it can create the
+# Make this a BUILD_DEPENDS too, so that it can create the
# directory hierarchy for us.
-BUILD_DEPENDS= ${PREFIX}/usr/games/stvef/linuxstvefded_1.2-static:${PORTSDIR}/games/stvef-server
+BUILD_DEPENDS= ${X11BASE}/games/stvef/linuxstvefded_1.2-static:${PORTSDIR}/games/stvef-server
+RUN_DEPENDS= ${BUILD_DEPENDS}
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
EXTRACT_ONLY= # Don't extract anything
-STRIP=
-GAMEDIR= ${PREFIX}/usr/games/stvef/
+GAMEDIR= ${PREFIX}/games/stvef/
.include <bsd.port.pre.mk>
@@ -45,7 +45,7 @@ do-build:
${RM} -f ${PLIST}
for file in ${DISTDIR}/stvef/*; do \
b=`basename $$file`; \
- ${ECHO} usr/games/stvef/baseEF/$$b >> ${PLIST}; \
+ ${ECHO_CMD} games/stvef/baseEF/$$b >> ${PLIST}; \
done
do-install:
diff --git a/games/stvef-paks/pkg-plist b/games/stvef-paks/pkg-plist
index a133f1f2662f..a8d434ded82a 100644
--- a/games/stvef-paks/pkg-plist
+++ b/games/stvef-paks/pkg-plist
@@ -1,5 +1,5 @@
-usr/games/stvef/baseEF/efconfig.cfg
-usr/games/stvef/baseEF/hmconfig.cfg
-usr/games/stvef/baseEF/pak0.pk3
-usr/games/stvef/baseEF/pak1.pk3
-usr/games/stvef/baseEF/pak2.pk3
+games/stvef/baseEF/efconfig.cfg
+games/stvef/baseEF/hmconfig.cfg
+games/stvef/baseEF/pak0.pk3
+games/stvef/baseEF/pak1.pk3
+games/stvef/baseEF/pak2.pk3
diff --git a/games/stvef-server/Makefile b/games/stvef-server/Makefile
index 0232ab3316c0..a3da8be781c4 100644
--- a/games/stvef-server/Makefile
+++ b/games/stvef-server/Makefile
@@ -6,7 +6,7 @@
PORTNAME= stvef-server
PORTVERSION= 1.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= ftp.multiplay.co.uk/pub/games/fps/eliteforce/patches/linux/ \
ftp://3dgamers.in-span.net/pub/3dgamers/games/stveliteforce/
@@ -17,20 +17,22 @@ COMMENT= Star Trek Voyager: Elite Forces dedicated server for Linux
ONLY_FOR_ARCHS= i386
USE_ZIP= yes
-USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
-NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/Linux
-STRIP=
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
-GAMEDIR= ${PREFIX}/usr/games/stvef/
+GAMEDIR= ${PREFIX}/games/stvef/
# files which should be installed with executables perms
EXECUTABLES= linuxstvefded_1.2-static linuxstvefded_1.2-glibc2.1.3
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/linuxstvefded_1.2-static
+ ${BRANDELF} -t Linux ${WRKSRC}/linuxstvefded_1.2-glibc2.1.3
+
do-install:
${MKDIR} ${GAMEDIR}
${INSTALL_PROGRAM} ${WRKSRC}/linuxstvefded_1.2-static ${GAMEDIR}
diff --git a/games/stvef-server/pkg-plist b/games/stvef-server/pkg-plist
index 063c006ad23a..8375a0b53c51 100644
--- a/games/stvef-server/pkg-plist
+++ b/games/stvef-server/pkg-plist
@@ -1,6 +1,6 @@
-usr/games/stvef/linuxstvefded_1.2-glibc2.1.3
-usr/games/stvef/linuxstvefded_1.2-static
-usr/games/stvef/readme.txt
-usr/games/stvef/baseEF/server.cfg
-@dirrm usr/games/stvef/baseEF
-@dirrm usr/games/stvef
+games/stvef/linuxstvefded_1.2-glibc2.1.3
+games/stvef/linuxstvefded_1.2-static
+games/stvef/readme.txt
+games/stvef/baseEF/server.cfg
+@dirrm games/stvef/baseEF
+@dirrm games/stvef
diff --git a/games/utserver-to/Makefile b/games/utserver-to/Makefile
index b2985e1aeb89..89b0e7435b8b 100644
--- a/games/utserver-to/Makefile
+++ b/games/utserver-to/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= to
PORTVERSION?= 2.2.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= games linux
MASTER_SITES?= http://www.netreachgames.com/downloads/to/ \
http://downloads.fragism.com/ \
@@ -22,13 +22,12 @@ DISTNAME?= TacticalOps220
MAINTAINER?= pat@FreeBSD.org
COMMENT?= Unreal Tournament mod Tactical Ops full server package for Linux
-RUN_DEPENDS= ${LINUXBASE}/usr/games/ut-server/System/ucc-bin:${UTSERVER_PORT}
+RUN_DEPENDS= ${LOCALBASE}/games/ut-server/System/ucc-bin:${UTSERVER_PORT}
BROKEN= Unfetchable
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
-USE_LINUX?= yes
+USE_LINUX= yes
USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
@@ -43,13 +42,8 @@ USE_ZIP= yes
.ifndef(DO_USE_WRKSUBDIR)
NO_WRKSUBDIR= yes
.endif
-.if defined(DO_USE_STRIP) && exists(${LINUXBASE}/usr/bin/strip)
-STRIP= ${LINUXBASE}/usr/bin/strip
-.else
-STRIP=
-.endif
-UTDIR= usr/games/ut-server/
+UTDIR= games/ut-server/
PLIST_SUB+= UTDIR="${UTDIR}"
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
@@ -84,6 +78,7 @@ pre-patch:
# Contributed by <lioux@FreeBSD.org>
do-install: install-parse-plist install-scripts
+# XXX: this is missing a ${BRANDELF} -t Linux <executables>
install-parse-plist: generate-plist
@${PERL} -e 'open(FHANDLER,"${TMPPLIST}");' \
-e 'open(FDIR,">${WRKDIR}/dirs.sh.tmp");' \
diff --git a/games/utserver/Makefile b/games/utserver/Makefile
index 1a27c4d85a83..5aa955b830c6 100644
--- a/games/utserver/Makefile
+++ b/games/utserver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= utserver
PORTVERSION= 436
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games linux
MASTER_SITES= http://public.planetmirror.com/pub/lokigames/installers/ut/ \
http://fileserver.talkware.net/ut/
@@ -22,13 +22,13 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
BROKEN= Incomplete pkg-plist
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
+USE_LINUX= yes
USE_PERL5= yes
NO_CDROM= "Size; the data set is much too big"
NO_BUILD= yes
WRKSRC= ${WRKDIR}/ut-server
-UTDIR= usr/games/ut-server/
+UTDIR= games/ut-server/
PLIST_SUB= UTDIR="${UTDIR}"
EXTRA_PATCHES= ${WRKDIR}/patch-ngstatsut
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
diff --git a/games/utserver/pkg-message b/games/utserver/pkg-message
index fbac5c6e76af..b428a91bf6af 100644
--- a/games/utserver/pkg-message
+++ b/games/utserver/pkg-message
@@ -7,8 +7,4 @@ user root.
------------------------------------------------------------
If you want to use ngStats and/or ngWorldStats
-install linux-jdk-1.2.2 from /usr/ports/java/linux-jdk
-
-Install the ASU port from /usr/ports/games/utserver-asu
-for easy installation of addon packages and managing
-server settings.
+install a 1.2 jdk from /usr/ports/java/*jdk12