aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/lbreakout/Makefile14
-rw-r--r--games/lbreakout/files/patch-lbreakout__hiscore.h20
-rw-r--r--games/lbreakout/pkg-plist5
3 files changed, 31 insertions, 8 deletions
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
index d41f18a9649a..478fc906560a 100644
--- a/games/lbreakout/Makefile
+++ b/games/lbreakout/Makefile
@@ -3,25 +3,29 @@
PORTNAME= lbreakout
PORTVERSION= 010315
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
MASTER_SITES= SF/lgames/${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Nice clone of classical Breakout game
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_SDL= sdl
USES= gmake
GNU_CONFIGURE= yes
LIBS+= -lcompat
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
- 's|"SDL/SDL|"SDL|g ; \
- s|<SDL/SDL|<SDL|g'
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
pre-install:
${MKDIR} ${STAGEDIR}/var/games/${PORTNAME}
+post-install:
+ ${MV} ${STAGEDIR}/var/games/${PORTNAME}/lbreakout.hscr \
+ ${STAGEDIR}/var/games/${PORTNAME}/lbreakout.hscr.sample
+
.include <bsd.port.mk>
diff --git a/games/lbreakout/files/patch-lbreakout__hiscore.h b/games/lbreakout/files/patch-lbreakout__hiscore.h
new file mode 100644
index 000000000000..04a18e00e987
--- /dev/null
+++ b/games/lbreakout/files/patch-lbreakout__hiscore.h
@@ -0,0 +1,20 @@
+--- lbreakout/hiscore.h.orig 2001-02-24 22:00:24.000000000 +0300
++++ lbreakout/hiscore.h 2015-01-25 05:37:12.000000000 +0300
+@@ -60,7 +60,7 @@
+ protected:
+ HiScoreEntry *entries;
+ int entry_num;
+- char filename[32];
++ char filename[1024];
+ public:
+ StandardHiScore(char* f);
+ StandardHiScore(FILE* f);
+@@ -88,7 +88,7 @@
+ // maintains two tables: one per score, the other per level
+ class CompositeHiScore : public HiScore {
+ private:
+- char filename[32];
++ char filename[1024];
+ LevelHiScore* pLevel;
+ StandardHiScore* pStandard;
+
diff --git a/games/lbreakout/pkg-plist b/games/lbreakout/pkg-plist
index e9751a68ff18..ddd89c1b5a14 100644
--- a/games/lbreakout/pkg-plist
+++ b/games/lbreakout/pkg-plist
@@ -43,6 +43,5 @@ share/lbreakout/wall.wav
share/lbreakout/weapon.bmp
share/lbreakout/weapon.wav
share/lbreakout/wontgiveup.wav
-@dirrm share/lbreakout
-@(root,games,664) /var/games/lbreakout/lbreakout.hscr
-@dirrm /var/games/lbreakout
+@sample(root,games,664) /var/games/lbreakout/lbreakout.hscr.sample
+@dir /var/games/lbreakout