aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/jaggedalliance2/Makefile81
-rw-r--r--games/jaggedalliance2/distinfo3
-rw-r--r--games/jaggedalliance2/pkg-descr6
-rw-r--r--games/jaggedalliance2/pkg-message14
-rw-r--r--games/jaggedalliance2/pkg-plist4
6 files changed, 109 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 60013bb5eed5..e6e8ed5c2828 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -343,6 +343,7 @@
SUBDIR += ioquake3
SUBDIR += ishido
SUBDIR += ivan
+ SUBDIR += jaggedalliance2
SUBDIR += jchessboard
SUBDIR += jetpack
SUBDIR += jfduke3d
diff --git a/games/jaggedalliance2/Makefile b/games/jaggedalliance2/Makefile
new file mode 100644
index 000000000000..bcb179a081dd
--- /dev/null
+++ b/games/jaggedalliance2/Makefile
@@ -0,0 +1,81 @@
+# New ports collection makefile for: Jagged Alliance 2
+# Date created: xx Nov 2006
+# Whom: Christoph Mallon <christoph.mallon@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ja2
+PORTVERSION= 0.1
+CATEGORIES= games
+MASTER_SITES= \
+ http://deponie.yamagi.org/freebsd/distfiles/ \
+ http://ja2.dragonriders.de/files/
+
+MAINTAINER= christoph.mallon@gmx.de
+COMMENT= A port of "Jagged Alliance 2" using SDL
+
+BUILD_DEPENDS= iconv:${PORTSDIR}/converters/iconv
+
+DISTVERSIONSUFFIX= -source
+
+# There are still many endianness and data size issues
+# Ignore this if you feel adventurous
+ONLY_FOR_ARCHS= i386
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+NO_CDROM= License only permits non-commerical use
+NO_PACKAGE= Language of the datafiles must be hardcoded in the game binary
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+OPTIONS= DUTCH "Compile for dutch version" Off \
+ ENGLISH "Compile for english version" On \
+ FRENCH "Compile for french version" Off \
+ GERMAN "Compile for german version" Off \
+ ITALIAN "Compile for italian version" Off \
+ POLISH "Compile for polish version" Off
+
+.include <bsd.port.pre.mk>
+
+.ifndef WITHOUT_ENGLISH
+MAKE_ARGS+= ENGLISH=yes
+.elifdef WITH_DUTCH
+MAKE_ARGS+= DUTCH=yes
+.elifdef WITH_FRENCH
+MAKE_ARGS+= FRENCH=yes
+.elifdef WITH_GERMAN
+MAKE_ARGS+= GERMAN=yes
+.elifdef WITH_ITALIAN
+MAKE_ARGS+= ITALIAN=yes
+.elifdef WITH_POLISH
+MAKE_ARGS+= POLISH=yes
+.else
+IGNORE= no language has been chosen. Please choose the appropriate language for your game CD
+.endif
+
+MAKE_ARGS+= NO_DEPS=yes # For a single full build dependency calculation is unnecessary
+
+MAKE_ARGS+= DATADIR=${DATADIR}
+
+MAN6= ja2.6
+
+do-install:
+ @${MKDIR} ${DATADIR}/Data/TILECACHE
+ @${INSTALL_PROGRAM} ${WRKSRC}/ja ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MANPREFIX}/man/man6
+
+post-install:
+ @${SED} -e 's|$${DATADIR}|${DATADIR}|' ${PKGMESSAGE}
+
+lowercase:
+ @for i in \
+ ${DATADIR}/Data/*.[Ss][Ll][Ff] \
+ ${DATADIR}/Data/TILECACHE/*.[Jj][Ss][Dd] \
+ ${DATADIR}/Data/TILECACHE/*.[Ss][Tt][Ii]; \
+ do \
+ ${MV} -n $$i `${DIRNAME} $$i`/`${BASENAME} $$i | ${TR} '[A-Z]' '[a-z]'`; \
+ done
+
+.include <bsd.port.post.mk>
diff --git a/games/jaggedalliance2/distinfo b/games/jaggedalliance2/distinfo
new file mode 100644
index 000000000000..2390543af00e
--- /dev/null
+++ b/games/jaggedalliance2/distinfo
@@ -0,0 +1,3 @@
+MD5 (ja2-0.1-source.tar.bz2) = ae34e02ee5e8ce59b64247ba83df581b
+SHA256 (ja2-0.1-source.tar.bz2) = 1632bf93bea91f1515274dcbebde517d7f094e0aa60132538e0b617b8944e63e
+SIZE (ja2-0.1-source.tar.bz2) = 3402438
diff --git a/games/jaggedalliance2/pkg-descr b/games/jaggedalliance2/pkg-descr
new file mode 100644
index 000000000000..21ec4d69e1b7
--- /dev/null
+++ b/games/jaggedalliance2/pkg-descr
@@ -0,0 +1,6 @@
+This is a source port of Jagged Alliance 2, in which the player controls
+mercenaries to liberate the small country of Arulco.
+
+You need an original game CD and installation to use this port.
+
+WWW: http://ja2.dragonriders.de/
diff --git a/games/jaggedalliance2/pkg-message b/games/jaggedalliance2/pkg-message
new file mode 100644
index 000000000000..ead77387c78c
--- /dev/null
+++ b/games/jaggedalliance2/pkg-message
@@ -0,0 +1,14 @@
+==========================================================================
+
+ This Jagged Alliance 2 port requires data files from the original
+ game CD and installation. Copy the following files:
+
+ Put all *.slf files into ${DATADIR}/Data.
+ Put all *.jsd and *.sti files from the TILECACHE directory into
+ ${DATADIR}/Data/TILECACHE.
+ All filenames must be lowercase!
+ After copying you can use "make lowercase" to rename all files.
+
+ Enjoy!
+
+==========================================================================
diff --git a/games/jaggedalliance2/pkg-plist b/games/jaggedalliance2/pkg-plist
new file mode 100644
index 000000000000..9e5b0b94b019
--- /dev/null
+++ b/games/jaggedalliance2/pkg-plist
@@ -0,0 +1,4 @@
+bin/ja2
+@dirrmtry %%DATADIR%%/Data/TILECACHE
+@dirrmtry %%DATADIR%%/Data
+@unexec rmdir %D/%%DATADIR%% 2>/dev/null || echo "Warning: data files in %D/%%DATADIR%% have been left intact."