aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/fretsonfire/Makefile13
-rw-r--r--games/hypatia_engine/Makefile13
-rw-r--r--games/pysolfc/Makefile14
-rw-r--r--games/pythonsudoku/Makefile4
4 files changed, 33 insertions, 11 deletions
diff --git a/games/fretsonfire/Makefile b/games/fretsonfire/Makefile
index 132416ccf48b..2ea875a4df57 100644
--- a/games/fretsonfire/Makefile
+++ b/games/fretsonfire/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fretsonfire
PORTVERSION= 1.3.110
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= games python
MASTER_SITES= SF
DISTNAME= ${PORTNAME_UCASE}-${PORTVERSION}
@@ -18,7 +18,6 @@ LICENSE_FILE= ${WRKSRC}/copying.txt
RUN_DEPENDS= ${PYNUMPY} \
${PYGAME} \
${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
${LOCALBASE}/share/${PORTNAME}/default.ttf:games/fretsonfire-data
USES= dos2unix python
@@ -38,6 +37,14 @@ OPTIONS_DEFINE= DOCS
PORTNAME_UCASE= FretsOnFire
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>=0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
do-install:
@${MKDIR} ${STAGEDIR}${FOF_DIR}/${PORTNAME_UCASE}
@cd ${WRKSRC}/src && \
@@ -53,4 +60,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}/README
${INSTALL_DATA} ${WRKSRC}/install.txt ${STAGEDIR}${DOCSDIR}/INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/hypatia_engine/Makefile b/games/hypatia_engine/Makefile
index a6eff66c3fd8..9e6f523fb47a 100644
--- a/games/hypatia_engine/Makefile
+++ b/games/hypatia_engine/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hypatia_engine
PORTVERSION= 0.3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,10 +14,17 @@ LICENSE= MIT
RUN_DEPENDS= ${PYGAME} \
${PYTHON_PKGNAMEPREFIX}pyganim>0:graphics/py-pyganim@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
${PY_ENUM34}
USES= python
USE_PYTHON= autoplist concurrent distutils
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/pysolfc/Makefile b/games/pysolfc/Makefile
index 78935e5d7822..4f721f532f4c 100644
--- a/games/pysolfc/Makefile
+++ b/games/pysolfc/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pysolfc
DISTVERSION= 2.6.4
+PORTREVISION= 1
CATEGORIES= games python
MASTER_SITES= SF/${PORTNAME}/PySolFC/${PYSOLFCDIR} \
SF/${PORTNAME}/PySolFC-Cardsets/${CARDSETDIR}:cardsets
@@ -15,8 +16,7 @@ COMMENT= Solitaire game, written in Python and the successor of PySol
LICENSE= GPLv2+ GPLv3+ MIT PCW PD UCP UCJ ULG
LICENSE_COMB= multi
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}random2>=0:math/py-random2@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}random2>=0:math/py-random2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
@@ -74,6 +74,14 @@ PYSOLFCDIST= ${PYSOLFCDIR}${EXTRACT_SUFX}
CARDSETDIR= PySolFC-Cardsets-2.0
CARDSETDIST= ${CARDSETDIR}.tar.bz2
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
post-patch:
@${MV} ${WRKSRC}/pysol.py ${WRKSRC}/pysolfc
@${REINPLACE_CMD} -e 's|pysol.py|pysolfc|' ${WRKSRC}/setup.py
@@ -96,4 +104,4 @@ post-install:
(cd ${WRKDIR}/${CARDSETDIR} && \
${FIND} . -type f | ${SED} -e 's|^./|${DATADIR_REL}/|' >> ${TMPPLIST})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/pythonsudoku/Makefile b/games/pythonsudoku/Makefile
index a8dce4bb8334..222ec1b2070c 100644
--- a/games/pythonsudoku/Makefile
+++ b/games/pythonsudoku/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pythonsudoku
PORTVERSION= 0.13
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= games python
MASTER_SITES= SF/${PORTNAME}/Python%20Sudoku/${PORTVERSION}/ \
SF/nemysisfreebsdp/games/:icons
@@ -23,7 +23,7 @@ EXPIRATION_DATE= 2020-03-01
LIB_DEPENDS+= libcups.so:print/cups
RUN_DEPENDS= ${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow6>=0:graphics/py-pillow6@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}reportlab>=0:print/py-reportlab@${PY_FLAVOR}
USES= gnome python:2.7 tar:bzip2