aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/blobandconquer/Makefile2
-rw-r--r--games/bloboats/Makefile2
-rw-r--r--games/blobwars/Makefile1
-rw-r--r--games/bloodfrontier/Makefile1
-rw-r--r--games/bugsquish/Makefile1
-rw-r--r--games/connectfive/Makefile5
-rw-r--r--games/cube/Makefile1
-rw-r--r--games/dangerdeep/Makefile1
-rw-r--r--games/djgame2/Makefile1
-rw-r--r--games/f1spirit-remake/Makefile1
-rw-r--r--games/falconseye/Makefile2
-rw-r--r--games/filters/Makefile2
-rw-r--r--games/gemdropx/Makefile3
-rw-r--r--games/gnudoku/Makefile3
-rw-r--r--games/icebreaker/Makefile3
-rw-r--r--games/jigzo/Makefile1
-rw-r--r--games/kiki/Makefile2
-rw-r--r--games/marsnomercy/Makefile1
-rw-r--r--games/nethack33/Makefile2
-rw-r--r--games/nethack34/Makefile2
-rw-r--r--games/palomino/Makefile1
-rw-r--r--games/pouetchess/Makefile2
-rw-r--r--games/race/Makefile3
-rw-r--r--games/randomshooter/Makefile2
-rw-r--r--games/redeclipse/Makefile1
-rw-r--r--games/reminiscence/Makefile2
-rw-r--r--games/sauerbraten/Makefile1
-rw-r--r--games/solarconquest/Makefile1
-rw-r--r--games/starfighter/Makefile1
-rw-r--r--games/stonesoup/Makefile1
-rw-r--r--games/stransball2/Makefile1
-rw-r--r--games/vdrift/Makefile1
-rw-r--r--games/viruskiller/Makefile1
-rw-r--r--games/vultures-eye/Makefile2
-rw-r--r--games/wmminichess/Makefile2
-rw-r--r--games/xevil/Makefile1
-rw-r--r--games/xrally/Makefile4
-rw-r--r--games/xtux/Makefile2
38 files changed, 18 insertions, 48 deletions
diff --git a/games/blobandconquer/Makefile b/games/blobandconquer/Makefile
index 01b5cc145f85..d0a86e5d1d43 100644
--- a/games/blobandconquer/Makefile
+++ b/games/blobandconquer/Makefile
@@ -30,7 +30,7 @@ WRKSRC= ${WRKDIR}/blobAndConquer-${DISTVERSION:C/^([0-9]\.[0-9][0-9]).*/\1/}
PORTDOCS= *
MAKEFILE= makefile
-MAKE_ENV= CXX="${CXX}" DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
+MAKE_ENV= DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
post-build:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} buildpak)
diff --git a/games/bloboats/Makefile b/games/bloboats/Makefile
index f2034da00ffb..d513a2dc96b7 100644
--- a/games/bloboats/Makefile
+++ b/games/bloboats/Makefile
@@ -21,7 +21,7 @@ USE_GMAKE= yes
USE_SDL= mixer image net sdl
USE_GL= yes
-MAKE_ENV+= CXX="${CXX}" DATADIR="${DATADIR}"
+MAKE_ENV+= DATADIR="${DATADIR}"
post-patch:
@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/Makefile
diff --git a/games/blobwars/Makefile b/games/blobwars/Makefile
index 6b5ec066adc6..aa0aea8de887 100644
--- a/games/blobwars/Makefile
+++ b/games/blobwars/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= lorenl@north-winds.org
COMMENT= You are the fearless Blob agent, Bob
MAKEFILE= makefile
-MAKE_ENV= CXX="${CXX}"
USE_SDL= sdl image mixer ttf
USE_GMAKE= yes
diff --git a/games/bloodfrontier/Makefile b/games/bloodfrontier/Makefile
index 5416931229d8..d671f6a49d8d 100644
--- a/games/bloodfrontier/Makefile
+++ b/games/bloodfrontier/Makefile
@@ -20,7 +20,6 @@ USE_BZIP2= yes
CONFIGURE_ENV= ACLOCAL=true AUTOCONF=true AUTOMAKE=true
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
-MAKE_ENV+= CXX="${CXX}"
BUILD_WRKSRC= ${WRKSRC}/src
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= libenet
diff --git a/games/bugsquish/Makefile b/games/bugsquish/Makefile
index bae3a6eb4a4e..bd0a71bc51b7 100644
--- a/games/bugsquish/Makefile
+++ b/games/bugsquish/Makefile
@@ -16,7 +16,6 @@ COMMENT= Bug-squishing, fly-swatting action
USE_SDL= mixer image
USE_GMAKE= yes
-MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/games/connectfive/Makefile b/games/connectfive/Makefile
index a5a82b0cf463..7869f625347e 100644
--- a/games/connectfive/Makefile
+++ b/games/connectfive/Makefile
@@ -16,9 +16,8 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Place five pieces in a row on a 3d board
MAKEFILE= Makefile.linux
-MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
ALL_TARGET= default
USE_SDL= sdl
diff --git a/games/cube/Makefile b/games/cube/Makefile
index 359ab1b9cc6e..70e892265269 100644
--- a/games/cube/Makefile
+++ b/games/cube/Makefile
@@ -23,7 +23,6 @@ USE_ZIP= yes
USE_DOS2UNIX= yes
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}_source/src
-MAKE_ENV+= CXX="${CXX}"
CFLAGS+= -fsigned-char
ALL_TARGET= #empty
diff --git a/games/dangerdeep/Makefile b/games/dangerdeep/Makefile
index 38a6ba8fa736..88bee8337ccc 100644
--- a/games/dangerdeep/Makefile
+++ b/games/dangerdeep/Makefile
@@ -24,7 +24,6 @@ RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/maps/default.xml:${PORTSDIR}/games/d
USE_GL= yes
USE_SDL= sdl mixer image net
-MAKE_ENV= CC="${CC}" CXX="${CXX}"
SCONS_ARGS= installbindir=${PREFIX}/bin installdatadir=${DATADIR}
PLIST_FILES= bin/dangerdeep bin/crosssection bin/damagemodel \
diff --git a/games/djgame2/Makefile b/games/djgame2/Makefile
index 4c3aef9bdbd8..611d28db55b8 100644
--- a/games/djgame2/Makefile
+++ b/games/djgame2/Makefile
@@ -23,7 +23,6 @@ QT_COMPONENTS= gui qt3support qmake_build uic_build rcc_build moc_build svg
QMAKE?= qmake-qt4
QMAKESPEC?= ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++
-MAKE_ENV= QMAKESPEC="{QMAKESPEC}"
WRKSRC= ${WRKDIR}/${DISTNAME}
DATADIR= ${PREFIX}/share/djgame2
diff --git a/games/f1spirit-remake/Makefile b/games/f1spirit-remake/Makefile
index a858a6bb0d96..4ec9ffcf1795 100644
--- a/games/f1spirit-remake/Makefile
+++ b/games/f1spirit-remake/Makefile
@@ -22,7 +22,6 @@ USE_ZIP= yes
USE_GMAKE= yes
USE_SDL= sdl net image mixer sound
USE_GL= gl glu
-MAKE_ENV= CXX="${CXX}"
WRKSRC= "${WRKDIR}/F-1 Spirit"
BUILD_WRKSRC= ${WRKSRC}/sources
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index a02d4c0be277..a898c8589060 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -24,7 +24,7 @@ USE_SDL= sdl
USE_PERL5_BUILD=yes
USE_ZIP= yes
USE_XORG= x11 xpm xaw
-MAKE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11" PREFIX="${PREFIX}"
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11
WRKSRC= ${WRKDIR}
post-patch:
diff --git a/games/filters/Makefile b/games/filters/Makefile
index 431dc1c9dc87..d3ce7a090252 100644
--- a/games/filters/Makefile
+++ b/games/filters/Makefile
@@ -22,8 +22,6 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ENV+= CC="${CC}"
-
PERLFILTERS= b1ff censor chef eleet fudd jibberish kenny pirate rasterman \
spammer studly uniencode upside-down
CFILTERS= jethro kraut cockney jive nyc ken ky00te newspeak nethackify
diff --git a/games/gemdropx/Makefile b/games/gemdropx/Makefile
index 5b0761e62b0e..ea6f5df78695 100644
--- a/games/gemdropx/Makefile
+++ b/games/gemdropx/Makefile
@@ -16,8 +16,7 @@ COMMENT= An interesting one-player puzzle game for X
USE_SDL= mixer
USE_GMAKE= yes
-MAKE_ENV= JOY=NO \
- SDL_CONFIG="${SDL_CONFIG}"
+MAKE_ENV= JOY=NO
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gemdropx ${PREFIX}/bin
diff --git a/games/gnudoku/Makefile b/games/gnudoku/Makefile
index 0a920f70b443..f6a2c0193fa9 100644
--- a/games/gnudoku/Makefile
+++ b/games/gnudoku/Makefile
@@ -18,8 +18,7 @@ COMMENT= A free program for creating and solving Su Doku puzzles
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
USE_GMAKE= yes
-MAKE_ENV= CXX="${CXX}" CXXLAGS="${CXXFLAGS}"
-USE_GCC= 3.4+
+MAKE_ENV= CXXLAGS="${CXXFLAGS}"
post-patch:
@${REINPLACE_CMD} -e 's|PREFIX=|PREFIX?=|' ${WRKSRC}/Makefile
diff --git a/games/icebreaker/Makefile b/games/icebreaker/Makefile
index 33448dc031f5..e64a6d8f70fb 100644
--- a/games/icebreaker/Makefile
+++ b/games/icebreaker/Makefile
@@ -22,8 +22,7 @@ MAKE_ENV+= prefix="${PREFIX}" \
mandir="${MANPREFIX}/man" \
CHMOD="${CHMOD}" \
CHOWN="${CHOWN}" \
- MKDIR="${MKDIR}" \
- CC="${CC}"
+ MKDIR="${MKDIR}"
MAN6= ${PORTNAME}.6
diff --git a/games/jigzo/Makefile b/games/jigzo/Makefile
index e2c22f9ba788..a341305070d0 100644
--- a/games/jigzo/Makefile
+++ b/games/jigzo/Makefile
@@ -22,7 +22,6 @@ USE_SDL= sdl mixer
USE_GL= gl
USE_GMAKE= yes
-MAKE_ENV= CXX="${CXX}"
PORTDOCS= *
post-patch:
diff --git a/games/kiki/Makefile b/games/kiki/Makefile
index 9e8d276f742f..fe35b86d2bfa 100644
--- a/games/kiki/Makefile
+++ b/games/kiki/Makefile
@@ -24,8 +24,6 @@ USE_GL= gl
USE_SDL= sdl mixer image
USE_DOS2UNIX= kodilib/linux/Makefile src/main/KikiController.cpp linux/Makefile kodilib/src/types/KVector.h src/main/KikiPythonWidget.h
-MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
-
WRKSRC= ${WRKDIR}/kiki
post-patch:
diff --git a/games/marsnomercy/Makefile b/games/marsnomercy/Makefile
index d2161b90cf59..586be49a9e76 100644
--- a/games/marsnomercy/Makefile
+++ b/games/marsnomercy/Makefile
@@ -20,7 +20,6 @@ BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
USE_GL= gl
USE_SDL= sdl image ttf
-MAKE_ENV= CC="${CC}" CXX="${CXX}"
SCONS_ARGS= prefix=${PREFIX}
PLIST= ${WRKDIR}/pkg-plist
diff --git a/games/nethack33/Makefile b/games/nethack33/Makefile
index 7000f5f8dce1..f1065a5b9152 100644
--- a/games/nethack33/Makefile
+++ b/games/nethack33/Makefile
@@ -21,7 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
LATEST_LINK= nethack33${PKGNAMESUFFIX}
USE_GMAKE= yes
-MAKE_ENV= CXX="${CXX}" GRAPHICS="${GRAPHICS}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV= GRAPHICS="${GRAPHICS}" LDFLAGS="${LDFLAGS}"
PLIST_SUB= HACKNAME="${HACKNAME}" \
HACKEXT="${HACKEXT}"
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index a59ff8278531..323a24985a6b 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -20,7 +20,7 @@ COMMENT= A dungeon explorin', slashin', hackin' game
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
-MAKE_ENV= CXX="${CXX}" GRAPHICS="${GRAPHICS}"
+MAKE_ENV= GRAPHICS="${GRAPHICS}"
PLIST_SUB= HACKNAME="${HACKNAME}" \
HACKDIR="${HACKDIR}" \
HACKDOCSDIR="${HACKDOCSDIR}"
diff --git a/games/palomino/Makefile b/games/palomino/Makefile
index f30fa2fc0c74..487ffb7a3362 100644
--- a/games/palomino/Makefile
+++ b/games/palomino/Makefile
@@ -23,7 +23,6 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
INSTALL_WRKSRC= ${WRKSRC}/${PORTNAME}/modules/pony
MAKEFILE= GNUmakefile
-MAKE_ENV= CC="${CC}" CXX="${CXX}"
post-patch:
@${REINPLACE_CMD} -e '/APPLE_CC/s|$$| \&\& !defined(__FreeBSD__)|'\
diff --git a/games/pouetchess/Makefile b/games/pouetchess/Makefile
index 23dee426f3b7..06d3bfac8f5e 100644
--- a/games/pouetchess/Makefile
+++ b/games/pouetchess/Makefile
@@ -21,8 +21,6 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/pouetChess_0.11
-MAKE_ENV= CXX="${CXX}"
-
DESKTOP_ENTRIES="pouetChess" \
"Play chess" \
"${DATADIR}/textures/1.png" \
diff --git a/games/race/Makefile b/games/race/Makefile
index 045019b5dfd9..21c2f6095c34 100644
--- a/games/race/Makefile
+++ b/games/race/Makefile
@@ -19,7 +19,8 @@ USE_SDL= mixer image sdl
USE_BZIP2= yes
USE_GL= glut
CFLAGS+= "-I${LOCALBASE}/include"
-MAKE_ENV= CC="${CC} ${CFLAGS}" LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CC+= ${CFLAGS}
+MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
post-patch:
@${REINPLACE_CMD} -e "s|^CC|#CC|g" \
diff --git a/games/randomshooter/Makefile b/games/randomshooter/Makefile
index 4d455f31ef90..8de7883b38ab 100644
--- a/games/randomshooter/Makefile
+++ b/games/randomshooter/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/-1$$//}
PORTDOCS= *
MAKEFILE= makefile
-MAKE_ENV= CXX="${CXX}" DATADIR=${DATADIR}/
+MAKE_ENV= DATADIR=${DATADIR}/
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index 5416931229d8..d671f6a49d8d 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -20,7 +20,6 @@ USE_BZIP2= yes
CONFIGURE_ENV= ACLOCAL=true AUTOCONF=true AUTOMAKE=true
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
-MAKE_ENV+= CXX="${CXX}"
BUILD_WRKSRC= ${WRKSRC}/src
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= libenet
diff --git a/games/reminiscence/Makefile b/games/reminiscence/Makefile
index e40a20cea3c7..e6245c7f3119 100644
--- a/games/reminiscence/Makefile
+++ b/games/reminiscence/Makefile
@@ -20,9 +20,7 @@ USE_GMAKE= yes
USE_SDL= sdl
ALL_TARGET= rs
-MAKE_ENV= CXX="${CXX}"
-PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
PORTDOCS= README
diff --git a/games/sauerbraten/Makefile b/games/sauerbraten/Makefile
index 5416931229d8..d671f6a49d8d 100644
--- a/games/sauerbraten/Makefile
+++ b/games/sauerbraten/Makefile
@@ -20,7 +20,6 @@ USE_BZIP2= yes
CONFIGURE_ENV= ACLOCAL=true AUTOCONF=true AUTOMAKE=true
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
-MAKE_ENV+= CXX="${CXX}"
BUILD_WRKSRC= ${WRKSRC}/src
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= libenet
diff --git a/games/solarconquest/Makefile b/games/solarconquest/Makefile
index ab9e896e1ea3..3f3b1b992472 100644
--- a/games/solarconquest/Makefile
+++ b/games/solarconquest/Makefile
@@ -23,7 +23,6 @@ USE_GL= yes
USE_DOS2UNIX= makefile source/MenuScreen.h source/main.cpp
MAKEFILE= makefile
-MAKE_ENV= CXX="${CXX}"
post-patch:
@${REINPLACE_CMD} -e 's|images/|${DATADIR}/images/|' \
diff --git a/games/starfighter/Makefile b/games/starfighter/Makefile
index 1213ed79522d..b7485bea381f 100644
--- a/games/starfighter/Makefile
+++ b/games/starfighter/Makefile
@@ -23,7 +23,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-1.1
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
MAKEFILE= makefile
-MAKE_ENV= CXX="${CXX}"
.if !defined(NOPORTDOCS)
post-install:
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index d31dae57e37a..e51d12e8a580 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -18,7 +18,6 @@ COMMENT= Dungeon Crawl Stone Soup - a fun, free rogue-like game
USE_BISON= build
USE_GMAKE= yes
-MAKE_ENV= CC=${CC} CXX=${CXX}
SAVEDIR?= /var/games/${PORTNAME}
WRKSRC= ${WRKDIR}/${DISTNAME}/source/
diff --git a/games/stransball2/Makefile b/games/stransball2/Makefile
index a96af408b834..a541b07584cb 100644
--- a/games/stransball2/Makefile
+++ b/games/stransball2/Makefile
@@ -20,7 +20,6 @@ LIB_DEPENDS= SGE.0:${PORTSDIR}/devel/sdl_sge
USE_ZIP= yes
USE_GMAKE= yes
USE_SDL= sdl image mixer sound
-MAKE_ENV= CXX="${CXX}"
BUILD_WRKSRC= ${WRKSRC}/sources
diff --git a/games/vdrift/Makefile b/games/vdrift/Makefile
index 43a804cb4bad..0aecfe06fc66 100644
--- a/games/vdrift/Makefile
+++ b/games/vdrift/Makefile
@@ -26,7 +26,6 @@ USE_BZIP2= yes
USE_GL= yes
USE_SDL= sdl image net gfx
-MAKE_ENV= CC="${CC}" CXX="${CXX}"
SCONS_ARGS= prefix=${PREFIX} \
datadir=share/${PORTNAME} \
bindir=bin \
diff --git a/games/viruskiller/Makefile b/games/viruskiller/Makefile
index dd140ae4481f..0c205b242906 100644
--- a/games/viruskiller/Makefile
+++ b/games/viruskiller/Makefile
@@ -24,7 +24,6 @@ USE_SDL= image mixer sdl ttf
WRKSRC= ${WRKDIR}/${PORTNAME}-1.0
MAKEFILE= makefile
-MAKE_ENV= CXX="${CXX}"
post-patch:
# Fix Makefile
diff --git a/games/vultures-eye/Makefile b/games/vultures-eye/Makefile
index 2b2a2024f12b..0e6b832ecce0 100644
--- a/games/vultures-eye/Makefile
+++ b/games/vultures-eye/Makefile
@@ -28,7 +28,7 @@ HAS_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/sys/unix
CONFIGURE_SCRIPT= setup.sh
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
-MAKE_ENV+= SDL_CONFIG="${SDL_CONFIG}" DATADIR="${DATADIR}" MAKE="${GMAKE}"
+MAKE_ENV+= DATADIR="${DATADIR}" MAKE="${GMAKE}"
pre-configure:
@${CHMOD} 755 ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/games/wmminichess/Makefile b/games/wmminichess/Makefile
index 8379208a296e..e7f3c585c8be 100644
--- a/games/wmminichess/Makefile
+++ b/games/wmminichess/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/gnuchess:${PORTSDIR}/games/gnuchess
USE_GMAKE= YES
USE_XORG= xpm
-MAKE_ENV= PREFIX="${PREFIX}" INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
LOCAL="${LOCALBASE}" MKDIR="${MKDIR}" \
INSTALL_DATA="${INSTALL_DATA}"
diff --git a/games/xevil/Makefile b/games/xevil/Makefile
index ba410fb42ef5..379c8a3cfae6 100644
--- a/games/xevil/Makefile
+++ b/games/xevil/Makefile
@@ -17,7 +17,6 @@ COMMENT= A fast-action, networked, anti-social, kill-everything game
USE_ZIP= yes
USE_XORG= xpm
-MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
MAKEFILE= makefile
ALL_TARGET= freebsd
diff --git a/games/xrally/Makefile b/games/xrally/Makefile
index a134a18353b6..4546d320a729 100644
--- a/games/xrally/Makefile
+++ b/games/xrally/Makefile
@@ -23,10 +23,10 @@ HAS_CONFIGURE= yes
USE_XORG= x11 xi xpm
USE_BZIP2= yes
USE_GMAKE= yes
+CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- CFLAGS="${PTHREAD_CFLAGS}"
+ CFLAGS="${CFLAGS}"
MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
INCLUDES="-I${LOCALBASE}/include"
.include <bsd.port.pre.mk>
diff --git a/games/xtux/Makefile b/games/xtux/Makefile
index 6585c84a57bd..a5eede81fc6e 100644
--- a/games/xtux/Makefile
+++ b/games/xtux/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XORG= xpm
USE_GMAKE= yes
-MAKE_ENV= CPP="${CC} -E" CC="${CC}"
+MAKE_ENV= CPP="${CC} -E"
CFLAGS+= -DDATADIR=\\\"${DATADIR}\\\"