aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-doom3/Makefile61
-rw-r--r--games/linux-doom3/distinfo6
-rw-r--r--games/linux-doom3/files/doom3-ded.in5
-rw-r--r--games/linux-doom3/files/doom3.in5
-rw-r--r--games/linux-doom3/files/pkg-message.in7
-rw-r--r--games/linux-doom3/pkg-descr6
-rw-r--r--games/linux-doom3/pkg-plist12
8 files changed, 103 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index c27572322304..bdf5e24097f0 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -355,6 +355,7 @@
SUBDIR += lincity-ng
SUBDIR += linux-alienarena
SUBDIR += linux-americasarmy
+ SUBDIR += linux-doom3
SUBDIR += linux-doom3-demo
SUBDIR += linux-enemyterritory
SUBDIR += linux-enemyterritory-fortress
diff --git a/games/linux-doom3/Makefile b/games/linux-doom3/Makefile
new file mode 100644
index 000000000000..a13fd364c8d6
--- /dev/null
+++ b/games/linux-doom3/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: linux-doom3
+# Date created: 7 May 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= doom3
+PORTVERSION= 1.3.1302
+CATEGORIES= games linux
+MASTER_SITES= ${MASTER_SITE_IDSOFTWARE}
+MASTER_SITE_SUBDIR= doom3/linux
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-linux-${PORTVERSION}.x86
+EXTRACT_SUFX= .run
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Doom III for Linux
+
+ONLY_FOR_ARCHS= i386
+USE_XLIB= yes
+USE_LINUX= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+OPTIONS= NO_CDKEY "Use older version which doesn't require cd key" off
+
+DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
+SUB_FILES= doom3 doom3-ded pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NO_CDKEY)
+PORTVERSION= 1.1.1286
+MASTER_SITE_SUBDIR= doom3/linux/old
+PLIST_SUB+= NEW="@comment "
+.else
+PLIST_SUB+= NEW=""
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @cd ${WRKDIR} && ${TAIL} +374 ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAR} zxf -
+
+do-install:
+ ${MKDIR} ${DATADIR}/base
+ cd ${WRKSRC}/base && \
+ ${INSTALL_DATA} game01.pk4 pak*.pk4 ${DATADIR}/base
+ cd ${WRKSRC}/bin/Linux/x86 && \
+ ${INSTALL_PROGRAM} doom.x86 doomded.x86 ${DATADIR}
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/doom3.png ${PREFIX}/share/pixmaps
+ ${INSTALL_PROGRAM} ${WRKDIR}/doom3 ${WRKDIR}/doom3-ded ${PREFIX}/bin
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-doom3/distinfo b/games/linux-doom3/distinfo
new file mode 100644
index 000000000000..36d00882d09d
--- /dev/null
+++ b/games/linux-doom3/distinfo
@@ -0,0 +1,6 @@
+MD5 (doom3-linux-1.1.1286.x86.run) = 2a45d0769b39473887c61a11cbba981c
+SHA256 (doom3-linux-1.1.1286.x86.run) = d02ee014017260f25e9ca07ccd3241f3766651fc94e3ca4924715f22c9029dbf
+SIZE (doom3-linux-1.1.1286.x86.run) = 7941364
+MD5 (doom3-linux-1.3.1302.x86.run) = b1d04da2d64bb8d54f64cbaa2fdb4490
+SHA256 (doom3-linux-1.3.1302.x86.run) = da90ba338eadb298a736af8786c0d7b11be698a399ac7a20549de0926a434677
+SIZE (doom3-linux-1.3.1302.x86.run) = 17199582
diff --git a/games/linux-doom3/files/doom3-ded.in b/games/linux-doom3/files/doom3-ded.in
new file mode 100644
index 000000000000..f9b0bbce0a60
--- /dev/null
+++ b/games/linux-doom3/files/doom3-ded.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd %%DATADIR%% || exit 1
+
+exec ./doomded.x86 "$@"
diff --git a/games/linux-doom3/files/doom3.in b/games/linux-doom3/files/doom3.in
new file mode 100644
index 000000000000..56cbabe75a65
--- /dev/null
+++ b/games/linux-doom3/files/doom3.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd %%DATADIR%% || exit 1
+
+exec ./doom.x86 "$@"
diff --git a/games/linux-doom3/files/pkg-message.in b/games/linux-doom3/files/pkg-message.in
new file mode 100644
index 000000000000..9d5fc6f81959
--- /dev/null
+++ b/games/linux-doom3/files/pkg-message.in
@@ -0,0 +1,7 @@
+==============================================================================
+
+To complete the installation of this port you need to copy the files
+"base/pak00[0-4].pk4", from the original Doom III distribution to
+"%%DATADIR%%/base".
+
+==============================================================================
diff --git a/games/linux-doom3/pkg-descr b/games/linux-doom3/pkg-descr
new file mode 100644
index 000000000000..5f77785d1b8a
--- /dev/null
+++ b/games/linux-doom3/pkg-descr
@@ -0,0 +1,6 @@
+Doom 3 is a sci-fi horror first-person shooter computer game developed by id
+Software and published by Activision. Set in 2145 in the Union Aerospace
+Corporation (UAC) research center on Mars, it is a reimagining of the original
+Doom, with completely new graphics and game engine.
+
+WWW: http://www.doom3.com/
diff --git a/games/linux-doom3/pkg-plist b/games/linux-doom3/pkg-plist
new file mode 100644
index 000000000000..58271643fc17
--- /dev/null
+++ b/games/linux-doom3/pkg-plist
@@ -0,0 +1,12 @@
+bin/doom3
+bin/doom3-ded
+%%DATADIR%%/base/game01.pk4
+%%DATADIR%%/base/pak005.pk4
+%%NEW%%%%DATADIR%%/base/pak006.pk4
+%%NEW%%%%DATADIR%%/base/pak007.pk4
+%%DATADIR%%/doom.x86
+%%DATADIR%%/doomded.x86
+share/pixmaps/doom3.png
+@dirrmtry share/pixmaps
+@dirrmtry %%DATADIR%%/base
+@unexec rmdir %D/%%DATADIR%% >/dev/null 2>&1 || echo "If you are permanently removing this port, you should remove any configuration files, data files, and mods left in %D/%%DATADIR%%." | fmt