aboutsummaryrefslogtreecommitdiff
path: root/german
diff options
context:
space:
mode:
Diffstat (limited to 'german')
-rw-r--r--german/Makefile1
-rw-r--r--german/geonext/Makefile48
-rw-r--r--german/geonext/distinfo1
-rw-r--r--german/geonext/pkg-descr17
-rw-r--r--german/geonext/pkg-plist16
5 files changed, 83 insertions, 0 deletions
diff --git a/german/Makefile b/german/Makefile
index 780b2b416cf8..f8b54e88cdc5 100644
--- a/german/Makefile
+++ b/german/Makefile
@@ -6,6 +6,7 @@
SUBDIR += citrix_ica
SUBDIR += dict
SUBDIR += ding
+ SUBDIR += geonext
SUBDIR += ispell
SUBDIR += ispell-alt
SUBDIR += ispell-neu
diff --git a/german/geonext/Makefile b/german/geonext/Makefile
new file mode 100644
index 000000000000..5fc55c5a781d
--- /dev/null
+++ b/german/geonext/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: de-geonext
+# Date created: 24 July 2003
+# Whom: Andreas Fehlner (fehlner@gmx.de)
+#
+# $FreeBSD$
+#
+
+PORTNAME= geonext
+PORTVERSION= 1.0
+CATEGORIES= german
+MASTER_SITES= http://geonext.uni-bayreuth.de/data/download/linux/
+PKGNAMEPREFIX?= de-
+DISTNAME= geonext
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= fehlner@gmx.de
+COMMENT= Interactive (dynamic) elementary Geometry Software
+
+WRKSRC= ${WRKDIR}/geonext_install
+NO_BUILD= yes
+#USE_JAVA= 1.4
+#JAVA= ${JAVA_HOME}/bin/java
+GNAME= geonext-de
+GLOCATE= ${PREFIX}/share/${GNAME}
+DATA= cacerts didmat.crt geonext.html geonext.jar license.txt index.html
+GIF= pixel.gif gx.gif gni.gif gn.gif g.gif x.ico
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/${GNAME}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DATA} ${GLOCATE}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${GIF} ${GLOCATE}
+ @${ECHO_MSG} '#!/bin/sh' > ${GLOCATE}/${GNAME}
+ @${ECHO_MSG} '${JAVA} -cp ${GLOCATE}/geonext.jar geonext/Geonext&'\
+ >>${GLOCATE}/${GNAME}
+ ${CHMOD} a+x ${GLOCATE}/${GNAME}
+ ${SED} -e 's/GEONExT.html/geonext.html/' ${GLOCATE}/index.html > \
+ ${GLOCATE}/index.tmp
+ ${LN} ${GLOCATE}/${GNAME} ${GLOCATE}/geonext
+ ${MV} ${GLOCATE}/index.tmp ${GLOCATE}/index.html
+ ${INSTALL_SCRIPT} ${GLOCATE}/geonext-de ${PREFIX}/bin
+ @${ECHO_MSG} "---------------------------------------------------------"
+ @${ECHO_MSG} "Application: ${GLOCATE}/geonext or geonext-de"
+ @${ECHO_MSG} "Browser-Applet: ${GLOCATE}/geonext.html"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WWW: http://www.geonext.de"
+ @${ECHO_MSG} "------------------------------------------------------"
+
+.include <bsd.port.mk>
diff --git a/german/geonext/distinfo b/german/geonext/distinfo
new file mode 100644
index 000000000000..c8be26b4ed58
--- /dev/null
+++ b/german/geonext/distinfo
@@ -0,0 +1 @@
+MD5 (geonext.tgz) = 82edd8a852bb6eff6e7edae3a5caa32d
diff --git a/german/geonext/pkg-descr b/german/geonext/pkg-descr
new file mode 100644
index 000000000000..3aaaf5a053a4
--- /dev/null
+++ b/german/geonext/pkg-descr
@@ -0,0 +1,17 @@
+The dynamic mathematics software Geonext establishes new ways of teaching and
+learning mathematics. It offers opportunities of visualisation that can't be
+realised on paper or blackboard and with traditional construction tools.
+
+Geonext enables autonomous and cooperative learning of mathematics in the
+classroom. It encourages an active discovering approach to mathematical
+thinking. Geonext can be used at school and at home for free (GPL).
+Therefore the software can be handed out to students without any copyright
+problems (GPL).
+
+Geonext can be used from elementary school up to calculus at high school and
+in teacher-training at university in a manifold and flexible way.
+
+WWW: http://www.geonext.de
+
+- Andreas Fehlner
+fehlner@gmx.de
diff --git a/german/geonext/pkg-plist b/german/geonext/pkg-plist
new file mode 100644
index 000000000000..1432668930c7
--- /dev/null
+++ b/german/geonext/pkg-plist
@@ -0,0 +1,16 @@
+bin/geonext-de
+share/geonext-de/geonext-de
+share/geonext-de/geonext
+share/geonext-de/cacerts
+share/geonext-de/didmat.crt
+share/geonext-de/g.gif
+share/geonext-de/geonext.html
+share/geonext-de/geonext.jar
+share/geonext-de/gn.gif
+share/geonext-de/gni.gif
+share/geonext-de/gx.gif
+share/geonext-de/index.html
+share/geonext-de/license.txt
+share/geonext-de/pixel.gif
+share/geonext-de/x.ico
+@dirrm share/geonext-de