aboutsummaryrefslogtreecommitdiff
path: root/graphics/Coin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/Coin/Makefile')
-rw-r--r--graphics/Coin/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index 37c788b55df0..c1538c3c37d5 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Coin
PORTVERSION= 3.1.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/Coin3D/coin/downloads/
@@ -29,4 +29,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|DATA install-data-local|DATA|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+post-build:
+ @${REINPLACE_CMD} -e '/^ldflags=/s|-R|-Wl,-rpath,|' ${WRKSRC}/coin-default.cfg
+
.include <bsd.port.mk>