aboutsummaryrefslogtreecommitdiff
path: root/graphics/GraphicsMagick13
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/GraphicsMagick13')
-rw-r--r--graphics/GraphicsMagick13/Makefile83
-rw-r--r--graphics/GraphicsMagick13/distinfo3
-rw-r--r--graphics/GraphicsMagick13/files/patch-Makefile.in89
-rw-r--r--graphics/GraphicsMagick13/files/patch-coders-png.c22
-rw-r--r--graphics/GraphicsMagick13/files/patch-configure23
-rw-r--r--graphics/GraphicsMagick13/pkg-descr13
-rw-r--r--graphics/GraphicsMagick13/pkg-plist249
7 files changed, 0 insertions, 482 deletions
diff --git a/graphics/GraphicsMagick13/Makefile b/graphics/GraphicsMagick13/Makefile
deleted file mode 100644
index 020568579843..000000000000
--- a/graphics/GraphicsMagick13/Makefile
+++ /dev/null
@@ -1,83 +0,0 @@
-# New ports collection makefile for: GraphicsMagick
-# Date created: 25 july 2005
-# Whom: Ron van Daal
-#
-# $FreeBSD$
-#
-
-PORTNAME= GraphicsMagick
-PORTVERSION= 1.1.7
-CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/
-MASTER_SITE_SUBDIR= ${PORTNAME:L}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Fast image processing tools based on ImageMagick
-
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
- jbig:${PORTSDIR}/graphics/jbigkit \
- wmf:${PORTSDIR}/graphics/libwmf \
- xml2:${PORTSDIR}/textproc/libxml2
-OTHERGRAPHICS= jasper jpeg lcms png tiff
-LIB_DEPENDS+= ${OTHERGRAPHICS:C|(.+)|\1:${PORTSDIR}/graphics/\1|}
-OPTIONS= Q8BIT "Use 8-bit pixels (speed) instead of 16 (quality)" off
-
-# Use libfpx only on i386. On other systems it does not seem to work :-(
-OPTIONS+= FPX "Build FPX backend -- broken on non-i386 systems" \
- ${ARCH:S,i386,on,:C,^[^o].*,off,}
-
-USE_AUTOTOOLS= libtool:15
-USE_BZIP2= yes
-USE_GHOSTSCRIPT=yes
-GNU_CONFIGURE= yes
-
-MAN1= GraphicsMagick++-config.1 \
- GraphicsMagick-config.1 \
- GraphicsMagickWand-config.1 \
- gm.1
-MAN4= miff.4
-MAN5= quantize.5
-
-.ifndef WINDOWS_FONT_DIR
-# Use fonts installed by x11-fonts/webfonts by default
-WINDOWS_FONT_DIR=${X11BASE}/lib/X11/webfonts
-.endif
-
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --without-perl --with-windows-font-dir=${WINDOWS_FONT_DIR} \
- --enable-shared --enable-static --without-threads \
- --enable-symbol-prefix
-USE_LDCONFIG= yes
-
-.if !defined(NOPORTDOCS)
-INSTALL_TARGET= install install-data-html
-.endif
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-.include <bsd.port.pre.mk>
-
-# Perl and Tcl APIs will be installed by separate ports
-PLIST_SUB+= WITH_PERL="@comment "
-
-.if defined(WITHOUT_X11)
-PKGNAMESUFFIX+= -nox11
-CONFIGURE_ARGS+=--without-x
-.endif
-
-.if defined(WITH_FPX)
-LIB_DEPENDS+= fpx:${PORTSDIR}/graphics/libfpx
-.else
-CONFIGURE_ARGS+=--without-fpx
-.endif
-
-.if defined(WITH_Q8BIT) || defined(WITHOUT_GRAPHICSMAGICK_16BIT_PIXEL)
-CONFIGURE_ARGS+= --with-quantum-depth=8
-PLIST_SUB+= Q=8
-.else
-CONFIGURE_ARGS+= --with-quantum-depth=16
-PLIST_SUB+= Q=16
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/graphics/GraphicsMagick13/distinfo b/graphics/GraphicsMagick13/distinfo
deleted file mode 100644
index e95e45e200a3..000000000000
--- a/graphics/GraphicsMagick13/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (GraphicsMagick-1.1.7.tar.bz2) = f75d830ca623bf10385b3ad62c48437a
-SHA256 (GraphicsMagick-1.1.7.tar.bz2) = 95f85e8bb84cc7ad05e84988f4cd93432ab2d4b300827fef34d1ada5e69196cc
-SIZE (GraphicsMagick-1.1.7.tar.bz2) = 4957394
diff --git a/graphics/GraphicsMagick13/files/patch-Makefile.in b/graphics/GraphicsMagick13/files/patch-Makefile.in
deleted file mode 100644
index 695f093c89fc..000000000000
--- a/graphics/GraphicsMagick13/files/patch-Makefile.in
+++ /dev/null
@@ -1,89 +0,0 @@
---- Makefile.in Fri Mar 18 19:36:21 2005
-+++ Makefile.in Sun Jul 24 18:21:35 2005
-@@ -466,5 +466,5 @@
-
- # Install HTML files
--pkgdocdir = @MagickSharePath@
-+pkgdocdir = ${DATA_DIR}/doc/GraphicsMagick
- DOCDIRS = images www www/api www/Magick++
- @WITH_PERL_TRUE@PERLMAGICK = PerlMagick
-@@ -1079,5 +1079,5 @@
-
- # Install arch-independent package data
--install-data-local: install-data-html
-+install-data-local:
-
- # Uninstall arch-independent package data
---- coders/Makefile.in Fri Mar 18 19:36:16 2005
-+++ coders/Makefile.in Sun Jul 24 19:22:21 2005
-@@ -1479,5 +1479,5 @@
- install-pkgLTLIBRARIES: $(pkg_LTLIBRARIES)
- @$(NORMAL_INSTALL)
-- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
-+ test -z "$(pkgdir)" -o -z "$(pkg_LTLIBRARIES)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
- @list='$(pkg_LTLIBRARIES)'; for p in $$list; do \
- if test -f $$p; then \
-@@ -1825,5 +1825,5 @@
- install-pkgDATA: $(pkg_DATA)
- @$(NORMAL_INSTALL)
-- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
-+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
- @list='$(pkg_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-@@ -1842,5 +1842,5 @@
- install-pkgdataDATA: $(pkgdata_DATA)
- @$(NORMAL_INSTALL)
-- test -z "$(pkgdatadir)" || $(mkdir_p) "$(DESTDIR)$(pkgdatadir)"
-+ test -z "$(pkgdatadir)" -o -z '$(pkgdata_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdatadir)"
- @list='$(pkgdata_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
---- filters/Makefile.in Fri Mar 18 19:36:17 2005
-+++ filters/Makefile.in Sun Jul 24 19:23:33 2005
-@@ -522,5 +522,5 @@
- install-pkgLTLIBRARIES: $(pkg_LTLIBRARIES)
- @$(NORMAL_INSTALL)
-- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
-+ test -z "$(pkgdir)" -o -z '$(pkg_LTLIBRARIES)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
- @list='$(pkg_LTLIBRARIES)'; for p in $$list; do \
- if test -f $$p; then \
-@@ -592,5 +592,5 @@
- install-pkgDATA: $(pkg_DATA)
- @$(NORMAL_INSTALL)
-- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
-+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
- @list='$(pkg_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
---- magick/Makefile.in Fri Mar 18 19:36:18 2005
-+++ magick/Makefile.in Tue Jul 26 21:05:48 2005
-@@ -664,5 +664,5 @@
-
- # Pkgconfig directory
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
-
- # Files to install in Pkgconfig directory
-@@ -930,5 +930,5 @@
- install-pkgDATA: $(pkg_DATA)
- @$(NORMAL_INSTALL)
-- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
-+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
- @list='$(pkg_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
---- Magick++/lib/Makefile.in Fri Mar 18 19:36:13 2005
-+++ Magick++/lib/Makefile.in Tue Jul 26 21:37:39 2005
-@@ -453,5 +453,5 @@
-
- # Pkgconfig directory
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
-
- # Files to install in Pkgconfig directory
---- wand/Makefile.in Fri Mar 18 19:36:20 2005
-+++ wand/Makefile.in Tue Jul 26 21:38:43 2005
-@@ -478,5 +478,5 @@
-
- # Pkgconfig directory
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
-
- # Files to install in Pkgconfig directory
diff --git a/graphics/GraphicsMagick13/files/patch-coders-png.c b/graphics/GraphicsMagick13/files/patch-coders-png.c
deleted file mode 100644
index 7a3b687f08cf..000000000000
--- a/graphics/GraphicsMagick13/files/patch-coders-png.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- coders/png.c 2004/11/11 03:10:42 1.369.2.3
-+++ coders/png.c 2006/08/18 04:03:02 1.369.2.4
-@@ -1709,7 +1709,7 @@ static Image *ReadOnePNGImage(MngInfo *m
- #if defined(PNG_USE_PNGGCCRD) && defined(PNG_ASSEMBLER_CODE_SUPPORTED) \
- && (PNG_LIBPNG_VER >= 10200)
- /* Disable thread-unsafe features of pnggccrd */
-- if (png_access_version() >= 10200)
-+ if (png_access_version_number() >= 10200)
- {
- png_uint_32 mmx_disable_mask=0;
- png_uint_32 asm_flags;
-@@ -1718,8 +1718,8 @@ static Image *ReadOnePNGImage(MngInfo *m
- | PNG_ASM_FLAG_MMX_READ_FILTER_SUB \
- | PNG_ASM_FLAG_MMX_READ_FILTER_AVG \
- | PNG_ASM_FLAG_MMX_READ_FILTER_PAETH );
-- asm_flags=png_get_asm_flags(png_ptr);
-- png_set_asm_flags(png_ptr, asm_flags & ~mmx_disable_mask);
-+ asm_flags=png_get_asm_flags(ping);
-+ png_set_asm_flags(ping, asm_flags & ~mmx_disable_mask);
- }
- #endif
-
diff --git a/graphics/GraphicsMagick13/files/patch-configure b/graphics/GraphicsMagick13/files/patch-configure
deleted file mode 100644
index af50a04fedad..000000000000
--- a/graphics/GraphicsMagick13/files/patch-configure
+++ /dev/null
@@ -1,23 +0,0 @@
---- configure Fri Mar 18 19:35:06 2005
-+++ configure Tue Jul 26 22:53:50 2005
-@@ -2092,5 +2092,5 @@
- MagickLibConfigSubDir="${MagickLibSubdir}/config"
- AC_DEFINE_UNQUOTED(MagickLibConfigSubDir,"$MagickLibConfigSubDir",Subdirectory of lib where architecture-dependent configuration files live.)
--MagickLibConfigPath="${LIB_DIR}/${MagickLibConfigSubDir}"
-+MagickLibConfigPath="${DATA_DIR}/GraphicsMagick/config"
- MagickLibConfigPathDefine="${MagickLibConfigPath}/"
- if test "$native_win32_build" = 'yes'
-@@ -2130,5 +2130,5 @@
- # Path to GraphicsMagick share files
- MagickShareSubdir="${PACKAGE_NAME}-${PACKAGE_VERSION}"
--MagickSharePath="${DATA_DIR}/${MagickShareSubdir}"
-+MagickSharePath="${DATA_DIR}/GraphicsMagick/"
- MagickSharePathDefine="${MagickSharePath}/"
- if test "$native_win32_build" = 'yes'
-@@ -2142,5 +2142,5 @@
- MagickShareConfigSubDir="${MagickLibSubdir}/config"
- AC_DEFINE_UNQUOTED(MagickShareConfigSubDir,"$MagickShareConfigSubDir",Subdirectory of lib where architecture-independent configuration files live.)
--MagickShareConfigPath="${DATA_DIR}/${MagickShareConfigSubDir}"
-+MagickShareConfigPath="${MagickLibConfigPath}"
- MagickShareConfigPathDefine="${MagickShareConfigPath}/"
- if test "$native_win32_build" = 'yes'
diff --git a/graphics/GraphicsMagick13/pkg-descr b/graphics/GraphicsMagick13/pkg-descr
deleted file mode 100644
index e43f63a5ad60..000000000000
--- a/graphics/GraphicsMagick13/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-This is a port of GraphicsMagick(TM), the "swiss army knife" of image
-processing. It provides a robust collection of tools and libraries which
-support reading, writing, and manipulating an image in over 88 major
-formats including formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF, SVG
-and TIFF.
-
-The program is the fork of a better-known ImageMagick (5.5.2), which
-emphasizes end-user and API-stabilities.
-
-WWW: http://www.graphicsmagick.org/
-
-- Ron van Daal
-ronvdaal@n1x.nl
diff --git a/graphics/GraphicsMagick13/pkg-plist b/graphics/GraphicsMagick13/pkg-plist
deleted file mode 100644
index fb02ec662470..000000000000
--- a/graphics/GraphicsMagick13/pkg-plist
+++ /dev/null
@@ -1,249 +0,0 @@
-bin/GraphicsMagick++-config
-bin/GraphicsMagick-config
-bin/GraphicsMagickWand-config
-bin/gm
-include/GraphicsMagick/Magick++.h
-include/GraphicsMagick/Magick++/Blob.h
-include/GraphicsMagick/Magick++/CoderInfo.h
-include/GraphicsMagick/Magick++/Color.h
-include/GraphicsMagick/Magick++/Drawable.h
-include/GraphicsMagick/Magick++/Exception.h
-include/GraphicsMagick/Magick++/Geometry.h
-include/GraphicsMagick/Magick++/Image.h
-include/GraphicsMagick/Magick++/Include.h
-include/GraphicsMagick/Magick++/Montage.h
-include/GraphicsMagick/Magick++/Pixels.h
-include/GraphicsMagick/Magick++/STL.h
-include/GraphicsMagick/Magick++/TypeMetric.h
-include/GraphicsMagick/magick/PreRvIcccm.h
-include/GraphicsMagick/magick/api.h
-include/GraphicsMagick/magick/attribute.h
-include/GraphicsMagick/magick/blob.h
-include/GraphicsMagick/magick/cache.h
-include/GraphicsMagick/magick/cache_view.h
-include/GraphicsMagick/magick/color.h
-include/GraphicsMagick/magick/command.h
-include/GraphicsMagick/magick/composite.h
-include/GraphicsMagick/magick/compress.h
-include/GraphicsMagick/magick/constitute.h
-include/GraphicsMagick/magick/decorate.h
-include/GraphicsMagick/magick/delegate.h
-include/GraphicsMagick/magick/deprecate.h
-include/GraphicsMagick/magick/draw.h
-include/GraphicsMagick/magick/effect.h
-include/GraphicsMagick/magick/enhance.h
-include/GraphicsMagick/magick/error.h
-include/GraphicsMagick/magick/fx.h
-include/GraphicsMagick/magick/gem.h
-include/GraphicsMagick/magick/image.h
-include/GraphicsMagick/magick/list.h
-include/GraphicsMagick/magick/log.h
-include/GraphicsMagick/magick/magic.h
-include/GraphicsMagick/magick/magick.h
-include/GraphicsMagick/magick/magick_config.h
-include/GraphicsMagick/magick/magick_types.h
-include/GraphicsMagick/magick/module.h
-include/GraphicsMagick/magick/monitor.h
-include/GraphicsMagick/magick/montage.h
-include/GraphicsMagick/magick/paint.h
-include/GraphicsMagick/magick/profile.h
-include/GraphicsMagick/magick/quantize.h
-include/GraphicsMagick/magick/registry.h
-include/GraphicsMagick/magick/render.h
-include/GraphicsMagick/magick/resize.h
-include/GraphicsMagick/magick/resource.h
-include/GraphicsMagick/magick/shear.h
-include/GraphicsMagick/magick/signature.h
-include/GraphicsMagick/magick/stream.h
-include/GraphicsMagick/magick/symbols.h
-include/GraphicsMagick/magick/timer.h
-include/GraphicsMagick/magick/transform.h
-include/GraphicsMagick/magick/utility.h
-include/GraphicsMagick/magick/version.h
-include/GraphicsMagick/magick/widget.h
-include/GraphicsMagick/magick/xwindow.h
-include/GraphicsMagick/wand/drawing_wand.h
-include/GraphicsMagick/wand/magick_wand.h
-include/GraphicsMagick/wand/pixel_wand.h
-include/GraphicsMagick/wand/wand_api.h
-%%DATADIR%%/Copyright.txt
-%%DATADIR%%/config/colors.mgk
-%%DATADIR%%/config/delegates.mgk
-%%DATADIR%%/config/log.mgk
-%%DATADIR%%/config/magic.mgk
-%%DATADIR%%/config/modules.mgk
-%%DATADIR%%/config/type-ghostscript.mgk
-%%DATADIR%%/config/type-solaris.mgk
-%%DATADIR%%/config/type-windows.mgk
-%%DATADIR%%/config/type.mgk
-lib/libGraphicsMagick++.a
-lib/libGraphicsMagick++.la
-lib/libGraphicsMagick++.so
-lib/libGraphicsMagick++.so.1
-lib/libGraphicsMagick.a
-lib/libGraphicsMagick.la
-lib/libGraphicsMagick.so
-lib/libGraphicsMagick.so.1
-lib/libGraphicsMagickWand.a
-lib/libGraphicsMagickWand.la
-lib/libGraphicsMagickWand.so
-lib/libGraphicsMagickWand.so.0
-libdata/pkgconfig/GraphicsMagick++.pc
-libdata/pkgconfig/GraphicsMagick.pc
-libdata/pkgconfig/GraphicsMagickWand.pc
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Graphics/Magick.pm
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/.packlist
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/Magick.so
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/Magick.bs
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/autosplit.ix
-@comment lib/GraphicsMagick-%%PORTVERSION%%/modules-%%Q%%/coders
-@comment lib/GraphicsMagick-%%PORTVERSION%%/modules-%%Q%%/filters
-%%PORTDOCS%%%%DOCSDIR%%/images/ball.png
-%%PORTDOCS%%%%DOCSDIR%%/images/corbis.png
-%%PORTDOCS%%%%DOCSDIR%%/images/examples.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/gm-125x80t.png
-%%PORTDOCS%%%%DOCSDIR%%/images/gm-188x120t.png
-%%PORTDOCS%%%%DOCSDIR%%/images/gm-282x180t.png
-%%PORTDOCS%%%%DOCSDIR%%/images/home.png
-%%PORTDOCS%%%%DOCSDIR%%/images/mail.png
-%%PORTDOCS%%%%DOCSDIR%%/images/pdfsages.png
-%%PORTDOCS%%%%DOCSDIR%%/images/pngnow.png
-%%PORTDOCS%%%%DOCSDIR%%/images/right_triangle.png
-%%PORTDOCS%%%%DOCSDIR%%/images/right_triangle_option.png
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/www/AUTHORS.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Changelog.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Copyright.html
-%%PORTDOCS%%%%DOCSDIR%%/www/FAQ.html
-%%PORTDOCS%%%%DOCSDIR%%/www/GraphicsMagick.html
-%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-mac.html
-%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-unix.html
-%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-vms.html
-%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-windows.html
-%%PORTDOCS%%%%DOCSDIR%%/www/ImageMagickObject.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Blob.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.fig
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.svg
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ChangeLog.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/CoderInfo.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Color.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Drawable.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Drawable_example_1.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Enumerations.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Exception.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/FormatCharacters.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Future.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Geometry.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.fig
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ImageDesign.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ImageMagick.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Install.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Magick++.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Montage.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/NEWS.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/PixelPacket.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Pixels.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/STL.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/TypeMetric.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/gm-188x120t.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/index.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/montage-sample-framed.jpg
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/right_triangle.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-framed.fig
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-framed.jpg
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-plain.fig
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-plain.jpg
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-sample-framed.jpg
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-sample-plain.jpg
-%%PORTDOCS%%%%DOCSDIR%%/www/NEWS.html
-%%PORTDOCS%%%%DOCSDIR%%/www/README.html
-%%PORTDOCS%%%%DOCSDIR%%/www/animate.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/animate.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/annotate.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/attribute.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/blob.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/cache.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/cache_view.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/color.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/composite.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/constitute.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/decorate.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/deprecate.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/display.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/draw.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/effect.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/enhance.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/error.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/fx.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/image.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/list.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/magick.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/memory.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/monitor.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/montage.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/paint.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/profile.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/quantize.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/registry.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/render.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/resize.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/resource.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/segment.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/shear.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/signature.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/stream.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/transform.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/types.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/widget.html
-%%PORTDOCS%%%%DOCSDIR%%/www/body.html
-%%PORTDOCS%%%%DOCSDIR%%/www/body.html.rej
-%%PORTDOCS%%%%DOCSDIR%%/www/books.html
-%%PORTDOCS%%%%DOCSDIR%%/www/color.html
-%%PORTDOCS%%%%DOCSDIR%%/www/composite.html
-%%PORTDOCS%%%%DOCSDIR%%/www/conjure.html
-%%PORTDOCS%%%%DOCSDIR%%/www/contribute.html
-%%PORTDOCS%%%%DOCSDIR%%/www/convert.html
-%%PORTDOCS%%%%DOCSDIR%%/www/cvs.html
-%%PORTDOCS%%%%DOCSDIR%%/www/development.html
-%%PORTDOCS%%%%DOCSDIR%%/www/display.html
-%%PORTDOCS%%%%DOCSDIR%%/www/download.html
-%%PORTDOCS%%%%DOCSDIR%%/www/formats.html
-%%PORTDOCS%%%%DOCSDIR%%/www/gm.html
-%%PORTDOCS%%%%DOCSDIR%%/www/header.html
-%%PORTDOCS%%%%DOCSDIR%%/www/identify.html
-%%PORTDOCS%%%%DOCSDIR%%/www/import.html
-%%PORTDOCS%%%%DOCSDIR%%/www/index.html
-%%PORTDOCS%%%%DOCSDIR%%/www/install.html
-%%PORTDOCS%%%%DOCSDIR%%/www/links.html
-%%PORTDOCS%%%%DOCSDIR%%/www/magick.css
-%%PORTDOCS%%%%DOCSDIR%%/www/miff.html
-%%PORTDOCS%%%%DOCSDIR%%/www/mission.html
-%%PORTDOCS%%%%DOCSDIR%%/www/mogrify.html
-%%PORTDOCS%%%%DOCSDIR%%/www/montage.html
-%%PORTDOCS%%%%DOCSDIR%%/www/perl.html
-%%PORTDOCS%%%%DOCSDIR%%/www/programming.html
-%%PORTDOCS%%%%DOCSDIR%%/www/quantize.html
-%%PORTDOCS%%%%DOCSDIR%%/www/smile.c
-%%PORTDOCS%%%%DOCSDIR%%/www/tools.html
-%%PORTDOCS%%%%DOCSDIR%%/www/utilities.html
-%%PORTDOCS%%%%DOCSDIR%%/www/windows.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/www/api
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/www/Magick++
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/www
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%WITH_PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick
-%%WITH_PERL%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics
-%%WITH_PERL%%@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Graphics
-@dirrm %%DATADIR%%/config
-@dirrm %%DATADIR%%
-@dirrm include/GraphicsMagick/wand
-@dirrm include/GraphicsMagick/magick
-@dirrm include/GraphicsMagick/Magick++
-@dirrm include/GraphicsMagick