aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ImageMagick/Makefile')
-rw-r--r--graphics/ImageMagick/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 24e7822268df..bf7b139107eb 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -120,7 +120,8 @@ INSTALL_TARGET= install install-data-html
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
+# Do not use PTHREAD_LIBS here
+ @${REINPLACE_CMD} -e 's|-lpthread|-lc_r|g ; \
s|^tagnames=|#tagnames=|g ; \
s|LIBLTDL=.*$$|LIBLTDL="-lltdl"|g ; \
s|INCLTDL=.*$$|INCLTDL=|g ; \
@@ -128,13 +129,12 @@ post-patch:
s|lcms_lcms_h|lcms_h|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|top_builddir)/ltdl/libltdlc.la|LIBLTDL)|g ; \
+ s|ltdl magick|magick|g ; \
s|pkgdocdir =.*$$|pkgdocdir = ${DOCSDIR}/|g ; \
s| install-data-html||g'
@${REINPLACE_CMD} -e 's|lcms/lcms.h|lcms.h|g' ${WRKSRC}/magick/transform.c
@${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' ${WRKSRC}/ltdl/ltdl.c
@${REINPLACE_CMD} -e 's|timestamp: %ld|timestamp: %d|g' \
${WRKSRC}/magick/xwindow.c
- @${REINPLACE_CMD}-e 's|^tagnames.*\$$|#&|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>