aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ImageMagick/Makefile')
-rw-r--r--graphics/ImageMagick/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 16ba61a29dae..107400474681 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -39,7 +39,8 @@ MAN4= miff.4
MAN5= quantize.5
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-USE_AUTOCONF= YES
+USE_AUTOCONF= yes
+INSTALL_SHLIBS= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared --with-perl=${PERL5} \
--enable-16bit-pixel
@@ -55,7 +56,4 @@ CONFIGURE_ENV= LDFLAGS="$(LDFLAGS) -L${WRKSRC}/magick/.libs"
pre-configure:
${RM} -f ${WRKSRC}/config.cache
-post-install:
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-
.include <bsd.port.mk>