aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ImageMagick/Makefile')
-rw-r--r--graphics/ImageMagick/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 57954028286a..97828fe0ff7a 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -43,8 +43,11 @@ USE_AUTOCONF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-shared --without-modules \
- --with-threads --without-magick-plus-plus \
+ --without-magick-plus-plus \
--with-perl=${PERL5} --without-xml
+.if defined(PERL_THREADED) && ${PERL_THREADED} == "true"
+CONFIGURE_ARGS+= --with-threads
+.endif
INSTALLS_SHLIB= yes
.if defined(WITH_16BIT_PIXEL)