aboutsummaryrefslogtreecommitdiff
path: root/graphics/Mesa3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/Mesa3/Makefile')
-rw-r--r--graphics/Mesa3/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/graphics/Mesa3/Makefile b/graphics/Mesa3/Makefile
index a8200a941dbe..1e392a66c048 100644
--- a/graphics/Mesa3/Makefile
+++ b/graphics/Mesa3/Makefile
@@ -53,6 +53,10 @@ MAKE_ARGS= -e
MAKE_ENV+= SUB_GL="${SUB_GL}" \
INCLUDE_GL=${INCLUDE_GL}
+.ifdef USE_MESA
+.error You have `USE_MESA' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure