aboutsummaryrefslogtreecommitdiff
path: root/graphics/Mesa3
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/Mesa3')
-rw-r--r--graphics/Mesa3/Makefile3
-rw-r--r--graphics/Mesa3/files/patch-ae11
2 files changed, 14 insertions, 0 deletions
diff --git a/graphics/Mesa3/Makefile b/graphics/Mesa3/Makefile
index 6a3ab8afd701..6b17ab4fe2e6 100644
--- a/graphics/Mesa3/Makefile
+++ b/graphics/Mesa3/Makefile
@@ -53,6 +53,9 @@ MAKE_ENV+= SUB_GL=${SUB_GL} \
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+post-configure:
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/config.c
+
post-install:
.for lib in GL GLU
@${LN} -sf ${PREFIX}/lib/lib${lib}.so ${PREFIX}/lib/libMesa${lib}.so
diff --git a/graphics/Mesa3/files/patch-ae b/graphics/Mesa3/files/patch-ae
new file mode 100644
index 000000000000..295ebbb601f6
--- /dev/null
+++ b/graphics/Mesa3/files/patch-ae
@@ -0,0 +1,11 @@
+--- src/config.c 2000/09/11 12:25:04 1.1
++++ src/config.c 2000/09/11 12:25:27
+@@ -406,7 +406,7 @@
+ #if defined(__WIN32__) || defined(__MSDOS__)
+ const char *filename = "mesa.cnf";
+ #else
+- const char *filename = "/etc/mesa.conf";
++ const char *filename = "%%PREFIX%%/etc/mesa.conf";
+ #endif
+ FILE *file;
+ struct cnode *list;