aboutsummaryrefslogtreecommitdiff
path: root/graphics/OpenEXR/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/OpenEXR/Makefile')
-rw-r--r--graphics/OpenEXR/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/graphics/OpenEXR/Makefile b/graphics/OpenEXR/Makefile
index afabe399501b..e4213d1d9222 100644
--- a/graphics/OpenEXR/Makefile
+++ b/graphics/OpenEXR/Makefile
@@ -7,7 +7,7 @@
PORTNAME= OpenEXR
PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTREVISION= 2
DISTNAME= ${PORTNAME:L}-${PORTVERSION}
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
@@ -26,6 +26,10 @@ GNU_CONFIGURE= YES
CONFIGURE_ARGS+=--enable-imfexamples
+# must be explicitely linked with -l{thr|pthread}
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+PTHREAD_LIBS+= `${CC} -dumpspecs | ${GREP} -m 1 pthread | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}`
+
WRKSRC= ${WRKDIR}/${DISTNAME}
test check: build