aboutsummaryrefslogtreecommitdiff
path: root/graphics/aalib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/aalib/Makefile')
-rw-r--r--graphics/aalib/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/graphics/aalib/Makefile b/graphics/aalib/Makefile
index 1b82b377b7ca..41c6bd9a38c8 100644
--- a/graphics/aalib/Makefile
+++ b/graphics/aalib/Makefile
@@ -15,14 +15,14 @@ MAINTAINER= ports@FreeBSD.org
USE_AUTOCONF= yes
USE_LIBTOOL= yes
+.include <bsd.port.pre.mk>
+
#
# Support for X11 is compiled in by default only if X11 is installed.
#
-.if !exists(${X11BASE})
-NO_X11?= yes
-.endif
-.if !defined(NO_X11)
-USE_XLIB=YES
+.if defined(WITH_X11) || (exists(${X11BASE}/lib/libX11.a) \
+ && !defined(WITHOUT_X11))
+USE_XLIB= yes
CONFIGURE_ARGS= --with-x --x-includes="${X11BASE}/include" \
--x-libraries="${X11BASE}/lib"
.else
@@ -32,7 +32,4 @@ CONFIGURE_ARGS= --with-x11-driver=no
post-patch:
@${PERL} -pi -e "s:/usr/local:${LOCALBASE}:g;" ${WRKSRC}/configure.in
-post-install:
- @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>