aboutsummaryrefslogtreecommitdiff
path: root/graphics/ale/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ale/Makefile')
-rw-r--r--graphics/ale/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/graphics/ale/Makefile b/graphics/ale/Makefile
index 69c468c694e4..6370a2116904 100644
--- a/graphics/ale/Makefile
+++ b/graphics/ale/Makefile
@@ -18,6 +18,9 @@ PLIST_FILES= bin/ale
USE_GMAKE= yes
USE_REINPLACE= yes
+OPTIONS= IMAGEMAGICK "ImageMagick Support" on \
+ FFTW3 "FFTW3 Support" on
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
@@ -34,14 +37,6 @@ LIB_DEPENDS+= fftw3.3:${PORTSDIR}/math/fftw3
MAKE_ARGS+= FFTW=1
.endif
-pre-everything::
-.if !defined(WITHOUT_IMAGEMAGICK)
- @${ECHO_MSG} "===> Disable ImageMagick Support by defining WITHOUT_IMAGEMAGICK"
-.endif
-.if !defined(WITHOUT_FFTW3)
- @${ECHO_MSG} "===> Disable FFTW3 Support by defining WITHOUT_FFTW3"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|; \
s|g++|${CXX}|' ${WRKSRC}/${MAKEFILE}