aboutsummaryrefslogtreecommitdiff
path: root/graphics/alpng/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/alpng/Makefile')
-rw-r--r--graphics/alpng/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/alpng/Makefile b/graphics/alpng/Makefile
new file mode 100644
index 000000000000..72b202685ce5
--- /dev/null
+++ b/graphics/alpng/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: graphics/alpng
+# Date created: 27 Aug 2009
+# Whom: Stas Timokhin <stast@bsdportal.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alpng
+PORTVERSION= 1.3
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+DISTNAME= ${PORTNAME}13
+
+MAINTAINER= stast@bsdportal.ru
+COMMENT= Library for display PNG images in programs
+
+LIB_DEPENDS+= alleg.42:${PORTSDIR}/devel/allegro
+
+HAS_CONFIGURE= yes
+WRKSRC= ${WRKDIR}
+MAKEFILE= makefile
+USE_GMAKE= yes
+CFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV+= CFLAGS="${CFLAGS}"
+
+PLIST_FILES= include/alpng.h \
+ lib/libalpng.a
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libalpng.a ${PREFIX}/lib/libalpng.a
+ ${INSTALL_DATA} ${WRKSRC}/src/alpng.h ${PREFIX}/include/alpng.h
+
+.include <bsd.port.mk>