aboutsummaryrefslogtreecommitdiff
path: root/graphics/aolserver-nsgd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/aolserver-nsgd/Makefile')
-rw-r--r--graphics/aolserver-nsgd/Makefile62
1 files changed, 0 insertions, 62 deletions
diff --git a/graphics/aolserver-nsgd/Makefile b/graphics/aolserver-nsgd/Makefile
deleted file mode 100644
index 19bb55b8c7d5..000000000000
--- a/graphics/aolserver-nsgd/Makefile
+++ /dev/null
@@ -1,62 +0,0 @@
-# Created by: Martin Matuska <mm@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= nsgd
-PORTVERSION= 2.0
-PORTREVISION= 10
-CATEGORIES= graphics www
-MASTER_SITES= http://www.aolserver.cz/download/
-PKGNAMEPREFIX= aolserver-
-DISTNAME= ${PORTNAME}2
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= aolserver
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Graphics module for AOLserver
-
-LICENSE= GPLv2
-
-DEPRECATED= abandonware, messing up on clusters
-EXPIRATION_DATE= 2014-04-03
-
-WRKSRC= ${WRKDIR}
-
-AOLSERVERBASE?= aolserver
-LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
-BUILD_DEPENDS+= ${LOCALBASE}/${AOLSERVERBASE}/bin/nsd:${PORTSDIR}/www/aolserver
-RUN_DEPENDS+= ${LOCALBASE}/${AOLSERVERBASE}/bin/nsd:${PORTSDIR}/www/aolserver
-
-USE_GMAKE= yes
-
-USES= tcl
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-CFLAGS+= "-I${LOCALBASE}/include"
-
-MAKE_ARGS= NSHOME="${LOCALBASE}/${AOLSERVERBASE}" \
- MODLIBS="-L${LOCALBASE}/lib -lgd" \
- DLLLIBS="-L${LOCALBASE}/lib -lgd"
-
-PLIST_FILES= ${AOLSERVERBASE}/bin/nsgd2.so \
- ${AOLSERVERBASE}/lib/libnsgd2.a \
- ${AOLSERVERBASE}/lib/libnsgd2.so
-
-PORTDOCS= nsgd.html
-
-post-patch:
- @${REINPLACE_CMD} -e 's/CFLAGS =/CFLAGS +=/g' \
- -e '/^OBJS =.*/{p;s/OBJS =.*/MODOBJS = $$(OBJS)/g;}' \
- -e 's/^MODLIBS =/#MODLIBS =/g' \
- ${WRKSRC}/Makefile
-
-post-install:
-.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${DOCSDIR}
-.for FILE in ${PORTDOCS}
- @ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.post.mk>