aboutsummaryrefslogtreecommitdiff
path: root/graphics/apngasm/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/apngasm/files/patch-Makefile')
-rw-r--r--graphics/apngasm/files/patch-Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/apngasm/files/patch-Makefile b/graphics/apngasm/files/patch-Makefile
index ef82e7f03b42..1f3b392c9788 100644
--- a/graphics/apngasm/files/patch-Makefile
+++ b/graphics/apngasm/files/patch-Makefile
@@ -1,15 +1,16 @@
--- ./Makefile.orig 2013-12-18 15:23:41.000000000 -0200
+++ ./Makefile 2013-12-18 15:23:54.000000000 -0200
-@@ -1,10 +1,17 @@
+@@ -1,10 +1,18 @@
PACKAGE = apngasm
-CC = gcc
-+CC ?= cc
-+CXX ?= c++
- SRC_DIRS = . 7z zopfli
+-SRC_DIRS = . 7z zopfli
-CFLAGS = -Wall -pedantic
-CFLAGS_OPT = -O2
-CFLAGS_7Z = -Wno-sign-compare -Wno-reorder -Wno-maybe-uninitialized -Wno-parentheses
-LIBS = -lstdc++ -lm -lpng -lz
++CC ?= cc
++CXX ?= c++
++SRC_DIRS = . 7z
+CFLAGS += -Wall -pedantic
+CXXFLAGS += -Wall -pedantic
+CPPFLAGS += $(shell libpng-config --cflags)
@@ -17,6 +18,7 @@
+ifeq ($(strip $(STATIC)),)
+LIBS = $(shell libpng-config --ldflags)
+else
++SRC_DIRS += zopfli
+LIBS = $(shell libpng-config --static --ldflags)
+LDFLAGS += -static
+endif