aboutsummaryrefslogtreecommitdiff
path: root/graphics/autoq3d/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/autoq3d/Makefile')
-rw-r--r--graphics/autoq3d/Makefile63
1 files changed, 63 insertions, 0 deletions
diff --git a/graphics/autoq3d/Makefile b/graphics/autoq3d/Makefile
new file mode 100644
index 000000000000..eba0eee153dc
--- /dev/null
+++ b/graphics/autoq3d/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: autoq3d
+# Date created: 28 Jul 2007
+# Whom: Yinghong.Liu <relaxbsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autoq3d
+DISTVERSION= 1.36
+CATEGORIES= graphics
+MASTER_SITES= SF
+DISTNAME= AutoQ3DGPL${PORTVERSION:C/\./-/}qt4source
+
+MAINTAINER= relaxbsd@gmail.com
+COMMENT= A complete QT quick 3d model editor program
+
+USE_ZIP= yes
+USE_QT_VER= 4
+QT_COMPONENTS= qmake corelib moc gui opengl
+
+PORTDOCS= 3DQformat.txt ChangeLog.txt Install.txt license.txt
+
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+DESKTOP_ENTRIES= "AutoQ3D" \
+ "A complete QT quick 3d model editor program" \
+ "AutoQ3D" \
+ "AutoQ3D" \
+ "Qt;KDE;Graphics;" \
+ "false"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/AutoQ3D-GPL|${DATADIR}|g' \
+ ${WRKSRC}/src/main.cpp \
+ ${WRKSRC}/src/fgui/cadform.cpp \
+ ${WRKSRC}/src/dialogs/prgsettings.cpp
+
+pre-build:
+ @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
+
+post-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/AutoQ3D ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/pixmaps
+ @${INSTALL_DATA} ${WRKSRC}/AutoQ3D.png ${PREFIX}/share/pixmaps
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/qref*.htm ${DATADIR}
+ @${MKDIR} ${DATADIR}/images
+ @${INSTALL_DATA} ${WRKSRC}/images/*.png ${DATADIR}/images
+.if !defined(WITHOUT_NLS)
+ @${INSTALL_DATA} ${WRKSRC}/*.qm ${DATADIR}
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/docs/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>