aboutsummaryrefslogtreecommitdiff
path: root/graphics/aview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/aview/Makefile')
-rw-r--r--graphics/aview/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/graphics/aview/Makefile b/graphics/aview/Makefile
index e85ce3a4445b..0586efc3bd7c 100644
--- a/graphics/aview/Makefile
+++ b/graphics/aview/Makefile
@@ -1,6 +1,6 @@
-# New ports collection Makefile for: aview
-# Date created: Dec 18 1997
-# Whom: frankch@waru.life.nthu.edu.tw
+# New ports collection Makefile for: aview
+# Date created: Dec 18 1997
+# Whom: frankch@waru.life.nthu.edu.tw
#
# $FreeBSD$
#
@@ -8,9 +8,8 @@
PORTNAME= aview
PORTVERSION= 1.2
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.ta.jcu.cz/pub/aa/ \
- ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= applications
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= aa-project
MAINTAINER= ports@FreeBSD.org
@@ -18,6 +17,12 @@ RUN_DEPENDS= anytopnm:${PORTSDIR}/graphics/netpbm \
convert:${PORTSDIR}/graphics/ImageMagick
LIB_DEPENDS= aa.1:${PORTSDIR}/graphics/aalib
-GNU_CONFIGURE= YES
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-x=no
+
+post-patch:
+ @${PERL} -pi -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name '*.[ch]' | xargs ${PERL} -pi -e \
+ 's|<malloc.h>|<stdlib.h>|g' \
.include <bsd.port.mk>