aboutsummaryrefslogtreecommitdiff
path: root/graphics/cairo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/cairo/Makefile')
-rw-r--r--graphics/cairo/Makefile26
1 files changed, 16 insertions, 10 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index e7c86885f9e4..5c6c9822b909 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -3,27 +3,28 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/graphics/cairo/Makefile,v 1.30 2005/10/04 04:35:57 ahze Exp $
#
PORTNAME= cairo
-PORTVERSION= 0.4.0
+PORTVERSION= 1.0.2
CATEGORIES= graphics
-MASTER_SITES= http://cairographics.org/snapshots/
+MASTER_SITES= http://cairographics.org/releases/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Vector graphics library with cross-device output support
-LIB_DEPENDS= pixman.1:${PORTSDIR}/graphics/libpixman \
- freetype.9:${PORTSDIR}/print/freetype2 \
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
png.5:${PORTSDIR}/graphics/png \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
-USE_GNOME= gnometarget gnomehack
-USE_LIBTOOL_VER=15
+CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
+ --enable-pdf \
+ --enable-ps
+USE_GNOME= gnometarget gnomehack ltverhack
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --with-html-dir=${DOCSDIR}
-
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include" \
LDFLAGS="${PTHREAD_LIBS}"
@@ -31,10 +32,12 @@ OPTIONS+= GLITZ "Enable Glitz OpenGL Support" Off
.include <bsd.port.pre.mk>
-.if defined(WITH_GLITZ) || exists(${LOCALBASE}/lib/libglitz.a)
+.if defined(WITH_GLITZ)
LIB_DEPENDS+= glitz-glx.1:${PORTSDIR}/graphics/glitz
+CONFIGURE_ARGS+= --enable-glitz
PLIST_SUB+= GLITZ=""
.else
+CONFIGURE_ARGS+= --disable-glitz
PLIST_SUB+= GLITZ="@comment "
.endif
@@ -49,7 +52,10 @@ PLIST_SUB+= X11=""
post-patch:
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' \
- ${WRKSRC}/src/*.*
+ ${WRKSRC}/src/*.* \
+ ${WRKSRC}/pixman/src/*.*
.endif
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/test/Makefile.in
.include <bsd.port.post.mk>