aboutsummaryrefslogtreecommitdiff
path: root/graphics/cairo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/cairo/Makefile')
-rw-r--r--graphics/cairo/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index e501428f90be..1fdb0a986df8 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
--disable-directfb \
--enable-tee \
--enable-gobject
-USE_GNOME= glib20 gnomehack ltverhack referencehack
+USE_GNOME= gnomehack ltverhack referencehack
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
@@ -46,7 +46,8 @@ PLIST_SUB+= X11=""
.endif
OPTIONS+= GL "Enable OpenGL Support" Off \
- XCB "Enable XCB (X C-language Binding) Support" On
+ XCB "Enable XCB (X C-language Binding) Support" On \
+ GLIB "Enable GObject Functions Feature" On
.include <bsd.port.pre.mk>
@@ -70,6 +71,13 @@ CONFIGURE_ARGS+= --disable-xcb
PLIST_SUB+= XCB="@comment "
.endif
+.if defined(WITH_GLIB)
+USE_GNOME+= glib20
+.else
+CONFIGURE_ARGS+= --enable-gobject=no
+PLIST_SUB+= GLIB="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/test/s/==/=/g' \
-e '/LIBS/s/-lrt//' \