aboutsummaryrefslogtreecommitdiff
path: root/graphics/cal3d/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/cal3d/Makefile')
-rw-r--r--graphics/cal3d/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/graphics/cal3d/Makefile b/graphics/cal3d/Makefile
index 36ec4688246f..b8423e73ab00 100644
--- a/graphics/cal3d/Makefile
+++ b/graphics/cal3d/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cal3d
PORTVERSION= 0.10.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,13 +18,12 @@ COMMENT= Skeletal based 3d character animation library written in C++
CONFLICTS= cal3d-devel-[0-9]*
-USE_BZIP2= yes
-USE_REINPLACE= yes
-USE_GNOME= pkgconfig
-USE_AUTOTOOLS= automake:19 autoheader:259 libtool:15:inc
-AUTOMAKE_ARGS= "--add-missing"
-INSTALLS_SHLIB= yes
-CONFIGURE_ARGS+= --disable-static
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GNOME= pkgconfig
+USE_AUTOTOOLS= automake:19 autoheader:259 libtool:15
+AUTOMAKE_ARGS= "--add-missing"
+INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
@@ -36,4 +35,8 @@ pre-configure:
cd ${WRKSRC} && ${AUTOHEADER}
cd ${WRKSRC} && ${LIBTOOLIZE} --automake --force
+# XXX: handle slight differences between 6.x and 5.x/4.x
+post-install:
+ @${RM} -f ${PREFIX}/lib/libcal3d.a
+
.include <bsd.port.post.mk>