aboutsummaryrefslogtreecommitdiff
path: root/graphics/cenon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/cenon/Makefile')
-rw-r--r--graphics/cenon/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/graphics/cenon/Makefile b/graphics/cenon/Makefile
index 8b95cced8050..11c2ad305737 100644
--- a/graphics/cenon/Makefile
+++ b/graphics/cenon/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cenon
-PORTVERSION= 3.71
+PORTVERSION= 3.81
CATEGORIES= graphics
MASTER_SITES= http://www.vhf-group.com/vhfInterservice/download/source/
DISTNAME= Cenon-${PORTVERSION}
@@ -14,11 +14,10 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= danfe@FreeBSD.org
+MAINTAINER= dinoex@FreeBSD.org
COMMENT= A vector graphics tool for GNUstep
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
@@ -26,14 +25,14 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
WRKSRC= ${WRKDIR}/Cenon
-MAKEFILE= GNUmakefile
+FULLVERSION= 3.80
OPTIONS= FULL_LIBRARY "Install complete Cenon Library" off
.include <bsd.port.pre.mk>
-.if defined(WITH_FULL_LIBRARY)
-DISTFILES+= CenonLibrary-${PORTVERSION}-1${EXTRACT_SUFX}
+.if defined(WITH_FULL_LIBRARY) || target(makesum)
+DISTFILES+= CenonLibrary-${FULLVERSION}-1${EXTRACT_SUFX}
PLIST_SUB+= FULL=""
.else
PLIST_SUB+= FULL="@comment "
@@ -47,7 +46,7 @@ post-extract:
post-install:
-@${MKDIR} ${PREFIX}/Local/Library
.if defined(WITH_FULL_LIBRARY)
- ${TAR} xyvf ${_DISTDIR}/CenonLibrary-${PORTVERSION}-1${EXTRACT_SUFX} \
+ ${TAR} xyvf ${_DISTDIR}/CenonLibrary-${FULLVERSION}-1${EXTRACT_SUFX} \
-C ${PREFIX}/Local/Library --exclude COPYING
@${CHOWN} -R root:wheel ${PREFIX}/Local/Library/Cenon
@${CHMOD} -R u=rwX,go=rX ${PREFIX}/Local/Library/Cenon